Are Ubiquiti Blocking Lede Installation?

Hi all,

It appears from some research that Ubiquiti may have started proactively blocking the installation of 3rd Party Firmware on their WiFi Devices.

We have experienced this issue on the Ubiquiti UAP V2 and Ubiquiti themselves have refused to officially confirm or deny that they are.

As we are a sizeable Wireless Operator who, to-date, have used Ubiquiti kit extensively within our predominately Open Source infrastructure, this will cause us some issues!

Does anyone else have any knowledge or experience of this situation?

Regards,
Peter R-F

I think you will have to be a bit more specific about the issue's you are having.

More information on the issue in this post...

its a pity but i suspect thats not really new for Ubiquiti.
think about the discussion about closing down their SDK years ago. https://community.ubnt.com/t5/airOS-SDK-Custom-Development/No-more-SDK/td-p/440237

some weeks ago a was asking in ubnt "community" forum to get help with a slightly outdated ubnt-firmware.
when i was revealing that i want it to use it for openwrt/lede the conversation sudden halts.

Hi, Any chance to install lede on Litebeam M5?? I read a Patchwork but I don't understand for what is it??

I've picked up that thread again. Let's see if they have a response to the proposal of not locking the bootloader in new airOS firmware.

They say the bootloader will remain locked. "Unfortunately, due to regulatory and security concerns, we won't be changing our stance on this." So it goes. I don't take it as defeat, it just means that if we want to change the attitude of Ubiquiti, we might have to generate political changes and more demand for unlocked bootloaders.

Vote with money and buy open source friendly hardware.

What hardware is similar to a LiteBeam M5 or a PowerBeam and "open source friendly", in other words, easy to install OpenWrt and derivatives (specifically LibreMesh)?

FWIW, I recently bought a second Unifi UAP AC Pro. It came with firmware v3.7.58. Was prepared to downgrade it to be able to install OpenWrt, but tried a direct install just in case. And to my surprise that worked just fine! This is all I had to do:

BZ.v3.7.58# mtd -r -e kernel0 write /tmp/openwrt-18.06-snapshot-ar71xx-generic-ubnt-unifiac-pro-squashfs-sysupgrade.bin kernel0
Unlocking kernel0 ...
Erasing kernel0 ...

Writing from /tmp/openwrt-18.06-snapshot-ar71xx-generic-ubnt-unifiac-pro-squashfs-sysupgrade.bin to kernel0 ...     
Rebooting ...
Connection to 192.168.1.20 closed by remote host.
Connection to 192.168.1.20 closed.

So I guess they must have removed the bootloader restriction in these newer firmwares for the UAP AC product line?

I am almost sure that the previous UAP AC Pro I bought (with v3.4.14 firmware) refused to boot OpenWrt before I downgraded it to v3.4.7. I say "almost" because I've become uncertain whether that was just a confusion over the dual image feature. The install guides were (are?) quite misleading, giving the impression that you could install OpenWrt in either the kernel0 or kernel1 partitions, when OpenWrt in fact will only be able to run from kernel0. This might give the false impression that the bootloader refuses to boot OpenWrt. Especially since (almost) no one connects a console, given that the box is glued and there is no factory installed header.

Hello,

I want to install openwrt on litebeam m5, its posible?, can I find information about this in some place?, thanks a lot for your help.

Please create a new thread in the future.

https://openwrt.org/toh/start?dataflt[Brand*~]=Ubiquiti

If it's not listed, it's not supported.

1 Like

Thanks IIeachii,

I will create new thread.

i've recently came up with an idea how to flash locked/signed firmware on litebeam ac gen2. basically you start flashing same ubiquiti fw that is already on device and interrupt the process, that leaves mtd partitions unlocked and you can flash another image to these using dd. more info in this GH comment-> https://github.com/openwrt/openwrt/pull/689#issuecomment-493658317

let us know if it works on your litebeams/powerbeams too