The faster SPI clock speed only benefits when reading/writing the flash chip, faster reboots, firmware upgrades, etc. It has nothing to do with the CPU clock frequency.
I don't have the knowledge to implement SFE or even know where the source is.
The faster SPI clock speed only benefits when reading/writing the flash chip, faster reboots, firmware upgrades, etc. It has nothing to do with the CPU clock frequency.
I don't have the knowledge to implement SFE or even know where the source is.
Does anybody know if it's normal for the D7's mtd5 radioDECT partition to be only full of FFFF?
root@Archer_D7:~# hexdump /dev/mtd5
0000000 ffff ffff ffff ffff ffff ffff ffff ffff
*
0010000
Also my mtd 8 rom partition is the same.
root@Archer_D7:~# hexdump /dev/mtd8
0000000 ffff ffff ffff ffff ffff ffff ffff ffff
*
0010000
Would it mean that they have been erased some how?
Hey @Gingernut,
I am not completely sure, but I know this device hardware is similar to the FritzBox 7490 with DECT. Our device Archer D7 unfortunately hasn't a DECT part as far as I know. So I guess it's pretty normal that this part consists just of FFFF information.
I thought the D7b is the one with no DECT partition and that the D7v1 actually has one.
When going back to factory firmware I get errors every time I change through the different menu options. I think it might have something to do with the DECT partition.
I've just uploaded a newer build and uses the same link a few messages up.
Hi @suppenkasper0815
I managed to get wds sta + ap working on the same radio without problems. This is my configuration:
config wifi-device 'radio0'
option type 'mac80211'
option channel '36'
option hwmode '11a'
option path 'pci0000:00/0000:00:00.0'
option htmode 'VHT80'
config wifi-iface 'wifinet2'
option key 'PASS'
option ssid 'WIFI_SSID'
option device 'radio0'
option mode 'sta'
option bssid 'XX:XX:XX:XX:XX:XX'
option encryption 'psk2'
option wds '1'
option network 'lan'
config wifi-iface 'wifinet3'
option ssid 'TEST'
option encryption 'none'
option device 'radio0'
option mode 'ap'
option network 'lan'
ap + sta works with 36 and 44 channels. Other channels, I'm not sure.
Today i tried to flash the stock c7 v2 firmware on d7 and seemed to work (no wan port). I also flashed DD-Wrt firmware from the GUI interface and, to my surprise, it worked! I tested the speed of 5GHZ, but it only went up to 50 Mbps... Not sure why.
Have you tried to flash the OpenWrt firmware over TFTP Arcer c7? I would like to know if with the c7 firmware (on d7 obviously) it's possible to access in TFTP server mode on 192.168.0.66, in this way you can flash directly openwrt on there.
No, you have to flash c7 uboot in order to use TFTP recovery mode. You have to use a programmer.
I don't know if this procedure it was explained in this topic, but i want only ask if I need to use UART or something like this to access directly to the hardware. Anyway is it possible to apply a software method to change firmware on d7?
A short answer is no.
Thank you for reply, I want follow your method and flash via uboot the c7 firmware. I am not an expert in this and if you have a good guide it will be perfect for me. I don't know if you can help me, thanks for all anyway.
This is how to flash the uboot: Archer D7 support - #131 by blinkstar88.
I recommend you to learn first how to flash d7 firmware, and then flash the c7 uboot and firmware.
This is how to flash d7
go to the line : Flash instructions under U-Boot, using UART
This is a youtube video which is quite helpful to me when i first tried to flash openwrt firmware. Steps are almost the same. Watch this video first.
U are great man! I hope to solve this problem, thank you !
G'day!
Would someone be kind enough to make a video tutorial of getting started with this project? (proper installation procedure, setup etc.)
I would really like to use this on my Archer D7 and a video would help tremendously for me and others.
Thanks for your hardwork and keep it up!!
Cheers
Gentlemen,
I was following the instructions above and all was going well until putty stopped showing any commands/lines. I tried reading the other chip and commands are appearing so for some reason the main chip seems to have stopped working. Any idea what it can be?
I have a D7 and I am using a DSD TECH TTL CP2102.
Many thanks, Adelin
Hey guys, I noticed gwlim compiled us luckly some images with sfe in it for high-performance on our lovely device. - I haven't played with it for a while and unfortunately flashed the D7-image and forgot I updated to boodloader to an Archer C7 V2 like explained above.
Anyway, I try to reflash from beginning with fresh bootloader with my actual macadress in it and would love if you guys could also provide an D7-Uboot or checkout the images from July2020 on gwlim's site:
There is a special Version for D7 and also for D50 in the "mini-section" btw.!
@gwlim Thank you very much for providing us an D7 and D50 image!!! Great work in my opinion!
Edit: Btw... here is the bootlog, which stops at starting kernel....
/srv/atftp >>> sudo cat screen /dev/ttyUSB0 [1]
cat: screen: Datei oder Verzeichnis nicht gefunden
U-Boot 1.1.4 (Jun 29 2015 - 20:49:26)
ap135 - Scorpion 1.0DRAM:
sri
Scorpion 1.0
ath_ddr_initial_config(178): (32bit) ddr2 init
tap = 0x00000003
Tap (low, high) = (0x3, 0x1e)
Tap values = (0x10, 0x10, 0x10, 0x10)
128 MB
Flash Manuf Id 0xef, DeviceId0 0x40, DeviceId1 0x18
flash size 16MB, sector count = 256
Flash: 16 MB
Using default environment
*** Warning *** : PCIe WLAN Module not found !!!
In: serial
Out: serial
Err: serial
Net: ath_gmac_enet_initialize...
athrs_sgmii_res_cal: cal value = 0x1
No valid address in Flash. Using fixed address
No valid address in Flash. Using fixed address
ath_gmac_enet_initialize: reset mask:c02200
Scorpion ----> S17 PHY *
Vlan config...
TEST: FINAL REG VAL after TX Calibration - 0x46000000
TEST: FINAL XMII VAL after RX Calibration - 0x56000000
TEST: FINAL ETH_CFG VAL after RX Calibration - 0x00028001
athrs17_reg_init: complete
: cfg1 0x80000000 cfg2 0x7335
eth0: ba:be:fa:ce:08:41
eth0 up
athrs17_reg_init_wan done
SGMII in forced mode
athr_gmac_sgmii_setup SGMII done
: cfg1 0x800c0000 cfg2 0x7214
eth1: ba:be:fa:ce:08:41
eth1 up
eth0, eth1
Setting 0x18116290 to 0x3871214f
Autobooting in 1 seconds
## Booting image at 9f020000 ...
Uncompressing Kernel Image ... OK
Starting kernel ...
Hey guys,
it's again me. I noticed the eth0 and eth1 mac-addresses are the same and the same happend to me with the D5 as you see in
@jinglei207 Also you had the same MAC-Adresses in boot-log. So I guess these addresses are in our modded bootloader for Archer C7v2 from @blinkstar88.
I actually controlled again the address in 0x1FC00 in ghex, but there I put the mac-address from underneath the device-sticker (a4:2b:b0:dc:ce:4b) and it is diffrent from (ba:be:fa:ce:08:41).
At least as long as eth0 and eth1 mac-addresses are the same I absolutly understand why my switch-part is not working properly on the device... any ideas how to solve the problem?
Actually my switch works after each reboot for a short time, then my laptop shows me 100 Mbit/s instead of 1000 Mbit/s and then it drops to 10 Mbit/s and no connection to router. If I wait long or reboot it jumps back to 1000 Mbit/s again... it the same from LAN1 to LAN4. I am sure it has to do with the bootloader problem.
@Gingernut or maybe @blinkstar88 would you please reupload the original bootloader for Archer D7v1 again? I have an italien device. It just says "Archer D7 vers 1.1" on the sticker.
Good day!
I'm using a CP2102 USB 2.0 to TTL UART Module 6Pin Serial Converter to connect to my Archer D7. I've already soldered headers to the board. I tried connecting via Putty but it seems not responding.
The only time I was able to connect was it showed:
Scorpion 1.0
DRAM:
And that's it.
I tried reconnecting again and its just always blank screen on Putty.
I'm pretty sure that the headers are properly soldered.