Archer c7 with lede and no gui

some friend gave me an archer c7 v2 with an old version of openwrt (I think 2016 or 17) but it has no gui or luci... I just enter using putty and I have no idea how to use it and I want to update it to the latest version of Openwrt WITH GUI AND LUCI above all.

My friend used it without problems to extend his wired internet but I want to use it as the main router and apparently, it is configured as dumb-ap and also seems to have an ips conflict with my modem because when it is connected by cable from the lan port to My laptop can only enter by putty (this is what I mean when I say that it does not have gui or luci) using and root but if I connect the modem cable to the router's lan input and another cable from another router's lan to My laptop already has internet but I disconnect from putty ... it stops working because my modem is ...

I do not know what to do, someone helps me install the latest version of openwrt by ssh to this poor archer c7 and not die trying, please?

scp the current (release/ -rc) sysupgrade image to its /tmp/, sysupgrade -n /tmp/…-sysupgrade.bin, done.

sorry for the ignorance but... do i have to do this at tis order?

1 get in putty as root once that
2 next writte release/ -rc
3 next writte /tmp/, sysupgrade -n /tmp/...-sysupgrade.bin

thats it? sorry if im dumb but i dont know nothing of commands and terminals....

1 Like

ok im only have this...

ok gonna to read it

Download the 19.07 or 21.02 sysupgrade to your PC and save on the disk. Then disconnect the PC from any wired or wifi networks.

Boot up the router not connected to any network. After the power light stops flashing, reset OpenWrt to defaults by holding down the reset button for 5 seconds then release, and wait for all the lights to flash out and reboot.

Connect one of the LAN ports to the Ethernet port of the PC. PC should obtain a DHCP address 192.168.1.X. ssh to the router at If you have ssh'd to anything at before, you will need to forget the host key in your ssh client and remember the new key. There will be a rather dire warning that you may be sshing to a malicious site, but actually it is just a new device which you can trust since you know it is the only thing reachable on your network.

In another window scp the firmware to Be sure to specify the /tmp directory, or you will either just make a copy on your local disk, or crash the router by overflowing the flash chip.

Back to the ssh window you can optionally run sha256sum on the firmware file and compare the result to the web page. Then run sysupgrade -n -F /tmp/openwrt-....-sysupgrade.bin. Since the new version is ath79 and the old builds were ar71xx, you will need to force the upgrade with -F. Since -F will flash anything including a potential brick, be absolutely certain you're using the right file, and it is sysupgrade not factory.

ok thanks friend... just in the step you say...

i dont know what scp is... (sorry)... look i following the "wiki" here

and in the download and verify the OpenWrt firmware upgrade image section Talk about downloading the file to install, well... I downloaded it from here y es este

exactly this from here

next i did the checksum256

next in the wiki says this and here im stuck... i got the file in my pc but dont know how to upload it to the router :frowning: :frowning: sorry sorry hundren times sorry but These things from the console or terminal confuse me a lot, I'm not good at this ...

now you help me with this

i did it, i coneted to the router


dont know how to do scp the firmware... how to do this or i mean, dont know even how to upload the file to /tmp/ folder im stuck in here

i can´t get to this step cause dont know how to get the file to the /tmp/ folder of the router

sorry for the loong post but i so much confused about it hope you can helpme at this

aaaaa i think i got to writte and run this?

scp D:\Downloads\openwrt-19.07.7-ath79-generic-tplink_archer-c7-
v2-squashfs-sysupgrade.bin root@


there is something i doing wrong

Well you would have to run that command from your PC not from within the SSH session.
scp would be available if you open the powershell on Windows. Otherwise you could use something like winscp.

On Windows 10, open a command prompt (does not need to be powershell) and execute

cd Downloads
scp openwrt-19.07.7-ath79-generic-tplink_archer-c7-v2-squashfs-sysupgrade.bin root@

Then go back the ssh window and confirm that the file is now in the routers /tmp directory (which is a RAM disk, it will only stay there until the next reboot). You can then run sha256sum again on the router to check the file copied correctly.

aaa ok in the cmd de windos ok

ok i did and now i ha[ve this

mmm i just say yes rigth?

ok now i got this

next get in putty try to open the /tmp And it gave me an error of 'permission denied' so I created a password with and went back to putty I still have the same error

:cold_face: :dizzy_face: :astonished: :weary:

i wait in that screen without touching anytinh even whit no breathing... about 10 loong minutes (maibe more)

I pressed the shutdown button and I counted up to 50 more than everything to calm my nerves and then I turned on the equipment again ... I entered putty and I already saw this message

I saw that it says 19.07.07 and I brave ran to the brave and when I placed the ip... the screen of the beloved Lucy came out

:star_struck: :partying_face: :partying_face: :exploding_head:

Its cd /tmp to change to a directory.

You're already the root user so sudo is not necessary.

thank you very much friends! now i got my openwrt in this router... now i have to remember how to configure as dumb-ap and learn how to install it a printer in network :exploding_head: :partying_face:

this thread its solved

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.