Archer C7 v5 tx-power changes and Candela tech drivers

Hey, running the latest version of OpenWrt, tx-power was max 24db and 23db for the radios in the selection boxes. Later on, I manually change them to minus one each, but then the boxes now show 20db as maximum for both. Why did this happen (bug)?

Another question is, I see in installed packages the default OpenWrt version comes with prebundled with "ct" candela tech for atheros wifi, they are modified drivers, they also has "htt" variant and the original variants from atheros. Which one is the best in terms of range and stability?

Try non ct :wink:

can you please also explain why should i use the original atheros driver?

Sure, it's on the last ~ 10 archer c7 stability problem threads because the ct drivers have no encrypted mesh support and my 2.4ghz wifi often crashes when using ct drivers. With non ct its running very stable since months.

ok fair enough, my 2.4ghz didn't crash yet though.

so for installing non-ct, i think first i remove ath10k-ct
then install
then reboot.

is that right or am i missing something?

You also need to change the kmod-ath10k module as well.

thanks, got it!

1 Like

some heads up. im on the latest snapshot release and it also somes with CT driver/fw (but latest) and its spectacular! never have been great that much, longest distance in my house has 3/4 signal with full internet speed (20Mbps).

for tx-power you gotta select US for country code and i have 24db option.

For those who have Archer C7, is it normal to have -15dBm difference between 2.4G and 5G bands?

For example, where I'm sitting I get -50dBm of 2.4G and -65dBm of 5G. They both set at 23db power in settings.

I just put 5G to 40MHz from 80 and set the freq. to 44. Signal got better, speed is reduced but I only have 20Mbps internet.

edit: so basically dB difference is now 5-10dBm between bands. 40MHz at specific frequencies penetrate walls better, I guess...

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.