Archer C7 V5 - can't figure out internet connection


I am new to networking and trying my best. I have a TP-Link Archer C7 V5 which I have successfully installed OpenWrt, set the root password, turned on wireless. I've plugged it into my internet source (starlink router) and I have no internet connection.

I've done some searching and reading and it seems to about the firewall settings or something with the IPv4 addresses?

I've set the router to have as it's IPv4. Under interfaces LAN is green and WAN and WAN6 are red.

Sorry for being so uneducated on this! Hope someone is able to point me in the right direction.

Thank you!

We can't guess what configuration you need for your ISP, you need to provide those details (OpenWrt defaults to dhcp client on WAN) and then configure your router accordingly.

red/ green are the default colours for wan/ lan interfaces and firewall zones (colours for non-default zones are assigned semi-randomly), they don't have any functional meanings beyond that.

1 Like

Hi! Thanks for the help!

My ISP is Starlink. I’ve tried to search the forums for how others have configured with Starlink but can’t seem to find any similar threads. I did read that my Starlink router is running OpenWRT. Do I need to put the starlink router in a bridge mode or remove it from the equation? It seems like some people remove it while others keep it in the mix.

Good to know about the colours for the LAN and WAN in the settings. Thanks again for the help.

On the main status page, is there an "IPv4 Upstream" shown?

Connecting your router to the LAN side of the Starlink router is more certain to work, and probably the way you should start out, because of this issue:

However it should also be possible to connect WAN directly to the power unit and dish and remove the provided indoor router. Either way, "DHCP Client" is the proper setting for the WAN protocol.

Hi Mike! Thanks for the help.

I don’t see IPv4 Upstream on the main status page.

I have the Ethernet plugged in from the starlink router to a LAN port in the Archer C7. I did initially have it plugged into the WAN port.

In the interfaces section the two WAN interfaces are set to “DHCP client” and the LAN is set to “static address”

Thanks again!

The "upstream" path to the Internet should be plugged into the WAN port.

Makes sense! I was confused with something I had read (perhaps a theme).

I have it back in the wan port. Still no ipv4 upstream on the status page.

On Network--Switch do you see a connected icon or "cable unplugged" on WAN? It should be connected at 1000.

WAN has an empty port icon, “no link” under it.

That is a hardware connection problem then.

  • the other router needs to be powered on.
  • the Ethernet cable needs to be good cat 5e or cat6 and have all 8 wires connected. Old 4 wire cables sometimes supplied with DSL modems or other 10/100 equipment will not work for gigabit.

The flying saucer looking LED (maybe it's supposed to be a globe) on the front of the C7 indicates a physical connection on the WAN port.

Wow! Impressive troubleshooting! I had a bad connection on my Ethernet cable. I tried a new cable from the C7 and LED light came on and now the cable icon is with the WAN in the Network>Switch section.

Thank you very much!