Archer C7 V2/V5 Batman Mesh Setup

Hello guys,
I am trying to create a Mesh network based on Batman-adv with TP-Link Archer C7 devices. I have created the batman device and I am able to ping my Mesh nodes via batctl. Unfortunately I can not ping my nodes on the Lan Interface.

environment:
2 archer c7 router running OpenWRT 21.01 from this build here

I have already found the guide by @cgomesu and went trough it. Somewhere I did a mistake but I am unable to figure out where. I have already tried to bridge all devices into the br-lan device to get the config up an running, but I am still failing.

For now I want to archive the following:
fritzbox is 192.168.1.1
corerouter is 192.168.1.2
AP01 is 192.168.1.3

the corerouter should perform as DNS/DHCP server in a first step providing those services to my lan. It is cabled to my fritzbox which will perform as the WAN gateway. Later on I would like to enable guest access on fritzbox guest network, but for now I will go with the bare config of a single network.

Cgomesu Tut

I want to have a Bridge-Bridge scenario - but my Lan- Bridge will not work on corerouter and ap. Here my /etc/config/network file:

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth1.1' 
                                  
config interface 'lan'            
        option device 'br-lan' 
        ifname 'eth 1.1 bat0'    
        option proto 'static'
        list ipaddr '192.168.1.2/24'
        option gateway '192.168.1.1'
                                     
config switch                        
        option name 'switch0'        
        option reset '1'             
        option enable_vlan '1'
                              
config switch_vlan            
        option device 'switch0'
        option vlan '1'        
        option ports '1 2 3 4 5 6t 0t'
                                      
config interface 'bat0'               
        option proto 'batadv'         
        option routing_algo 'BATMAN_IV'
        option aggregated_ogms '1'     
        option ap_isolation '0'        
        option bonding '0'             
        option fragmentation '1'       
        option gw_mode 'off'      
        option log_level '0'    
        option orig_interval '1000'
        option bridge_loop_avoidance '1'
        option distributed_arp_table '1'
        option multicast_mode '1'       
        option network_coding '0'       
        option hop_penalty '30'         
        option isolation_mark '0x00000000/0x00000000' 

thanks in advance for your help!

regards
Carsten

Hey, @PadawanDeluxe . My tutorial makes use of the old syntax still but I'm in the process of updating it right now. There are other things I want to change as well, such as adding a section about building custom images with all the required packages and to use better hardware for the examples because 21.02 is too unstable with the wr1043nd_v1 used in the current examples (there are new hardware requirements with the release of 21.02).

The new current stable has a slightly different syntax for the network configuration (dropping the use of ifname and making a more clear distinction between layer 2 and layer 3 configurations), which i mentioned in the updated section Moving from OpenWrt 19 to 21. Indeed, after looking at your config file, it seems your issue is with the new bridge configuration. Specifically, your bridge device (br-lan) and lan interface stanzas should be the following instead:

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth1.1' 
        list ports 'bat0.1'
                                  
config interface 'lan'            
        option device 'br-lan' 
        option proto 'static'
        option ipaddr '192.168.1.2'
        option netmask '255.255.255.0'
        option gateway '192.168.1.1'

everything else is pretty much the same as before. make sure there is also a mesh interface stanza in your network config file in addition to the bat0 stanza:

config interface 'mesh'
        option proto 'batadv_hardif'
        option master 'bat0'
        option mtu '1536'

and in your wireless config file, make reference to the latter in the wmesh wifi-iface stanza, as in the following example:

config wifi-iface 'wmesh'
	option device 'radio1' #your radio might be different here
	option network 'mesh'
	option mode 'mesh'
	option mesh_id 'MyMeshId' #change it
	option encryption 'sae' #optional
	option key 'MyPassword123' #optional
	option mesh_fwding '0'
	option mesh_ttl '1'
	option mcast_rate '24000'

Talking about SAE, another difference is that the current stable comes with the wpad-basic-wolfssl package instead of wpad-basic. To use sae in your wireless mesh interface, you first need to remove wpad-basic-wolfssl (run opkg remove wpad-basic*) and then install wpad-mesh-wolfssl (run opkg update && opkg install wpad-mesh-wolfssl).

Let me know if this helps. If the issue persist, post your entire network and wireless files here.

CG

Hello & thank you so much!
I have simply changed the config as stated above and it is finally working right now. The most important factwill be to understand, that the vlan 1 is the untagged LAN entry here.

I will go and write down a bit more detailed information which maybe can be copied to your tutorial.

thanks a lot!

regards
Carsten

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.