Archer C7 V2 sysupgrade fails because of strange hw ID

I'm new to this and I might be asking stupid things.

Bought a pre-owned A C7 V2 AC1750, came with OpenWrt Chaos Calmer 15.05.1 / LuCI 15.05-149-g0d8bbd2 Release (git-15.363.78009-956be55)

Trying to flash LEDE. Over LuCI The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform. Tried shorter names and dd -32b, no luck.

sysupgrade -v lede-17.01.2-ar71xx-generic-archer-c7-v2-squashfs-factory.bin, -sysupgrade.bin, 32bits stripped .trx versions and shortened filenames without excessive dots end inadvertently with

Invalid image, hardware ID mismatch, hw:7d0e7106 image:c7000002.
Image check 'platform_check_image' failed.

According to all stickers it is a pre-215c Ver:2.0 Archer C7. Can the hw ID be correct? Can it be something left behind from buggy flashes of my "predecessor"?

All basic functionalities work, I can surrender and stay on OpenWrt. Or can I force-flash? What are my chances?

Thx a lot


Did you try sysupgrade -F?

Not yet, I asked first, what are my chances. Do you recommend it?

Or should I flash back to an older TPLink fw and from there to current factory.bin LEDE? Can I use Fried Zombie's stripped fw?

Thx. M.

C7v2 have recovery mode if You "brick" device when used -F with wrong firmware.

Try latest lede firmware (sysupgrade) with -F option

Thx a lot.

sysupgrade worked, my basic config has been preserved and all basic services are running with LEDE Reboot

Out of curiosity, where came the wrong hw ID from?

Most likely it changed in LEDE configuration compared to OpenWRT

No, has been present when router arrived (with OpenWrt on it). Can you change hw ID flashing an appropriate OpenWrt build over the stock fw?

The hwid could be specified in the bootloader. So no clue.