Archer C7 V2 - Massive Problems

I'm currently on custom build fw, using this configuration - - and so far it is behaving slightly differently - while previously I got 2.4 simply lost all connected stations (and none reconnected, as I have another AP in my house), now it seems it hold longer but still after eg. 5-10 hours I have to reboot (even just bringing wifi up/down don't help). I see some devices are still getting connected but not the same amount as after fresh reboot (eg. 3 instead of 10). And those 3 even being connected, there is almost no traffic anyway passed.

Also now I'm using 20MHz instead of 40Mhz, to see if this improves or not as I have now 8 hours uptime without issue.

It would be great, if someone may ask us which kind of debugging info to provide when this happens. @nbd Felix, maybe ? :wink:

1 Like

It seems that using the build I posted config above (developers build), drivers ath10k-firmware-qca988x-ct-htt and kernel optimized driver kmod-ath10k-ct-smallbuffers, in combination with 20 MHz bandwidth, is working solution for me - all 2.4 GHz connections are so far stable.

I had pretty much the same issue some weeks ago when I disconnected my router and moved it. It behaved the same with loss of several ping packages in a row and then 4-5 that went through.
After upgrade, and a total re-flash the issue was the same.

But I also have a router that was provided by my ISP that are connected between the internet port to the outside world and my OpenWRT router. The ISP router had the same ip adress that my OpenWRT router had. I changed ISP router to instead and kept the on my OpenWRT router and it now works. Even if you don't have a extra router on the line there might be a IP collision that results in the same result. Hope this helps

The weird thing here is that I think they both had the same IP address before I disconnected them and it still worked somehow.

wtf i may have the same problem. i will check tomorrow if my isp router is on

My tests indicated that fiddling/swapping out 5GHz drivers to fix 2.4GHz issues is pointless.
ath10 = 5GHz
ath9 = 2.4GHz

You can swap out ath10k as much as you want, it is ath9 firmware blob that has issues and it is proprietary/out of OpenWRT. Mine failed sooner or later. Only way to make it work 100% is to force it to 56Mbit/sec which is not really useful.

I just disabled 2.4GHz and use 5GHz only. It is rock solid and has plenty of bandwidth. 2.4GHz is legacy anyway and not recommended any more.

1 Like

The theory is that some ath10k configurations may have used too much memory? Also it's not impossible that software conflict happens... OTOH there doesn't seem to be solid evidence that it's definitely the case either.

2.4GHz maybe legacy in the sense that WPA2 is also legacy, it's going to be used for quite some time for quite a few people, especially for low-end devices which don't have 5GHz radio at all.

Sadly, while it's frustrating for those who're affected, it seems unlikely to be thoroughly fixed for everyone considering the complexities involved as there can be many different setups... Am lucky that it's been working fine for me, at least in the past month or so... But for others, I don't know what can be done... Getting a new router? Maybe in a year or two? As 11ac Wave-2 boxes don't seem to be a "big enough" of an upgrade and 11ax support is still in infancy.


I can attest to loyukfai's experience - my Archer C7 seems to be going ok. I use my Archer C7 V2 as an AP only but I've had to play with different configurations to get it to work. Recently, I just switched to the kmod-ath10k and ath10k-firmware-qca988x. I also set a cron job to reboot every morning at 4:30am. It seems to be working really good for me now.

1 Like

2.4GHz works if you have low bandwidth Internet, few devices and reboot it every night. But it falls apart if you start streaming stuff or have many devices attached to it.

The theory of ath10k using too much memory is not really plausible. My routers are configured as dumb AP's and worked just fine on 5GHz with 50% of memory free when 2.4GHz locked up. LUCI was accesible and you could Telnet to it, it just starts dropping packets or not allowing new clients to associate on 2.4GHz.

The issue seems to be in the firmware of ath9 device itself.

Does this limited mode work without any scripted reset workaround? I'm interrested in your wifi config to force this 56Mbit parameter.

1 Like

Hey guys, I'm running 18.06.2 on my Archer C7 V2 and I appear to have the same issue. 2.4GHz just slows way down over time, seemingly randomly.

I was hoping that upgrading to 19.07.2 would help, but it sounds like maybe not? Does everyone with our router have this problem?


I actually build my own for my Archer C7 V2, so I'm running off of Master build. However, I recently changed my ath10k drivers to use the kernel module kmod-ath10k and the firmware ath10k-firmware-qca988x. It has made a huge difference in the performance for the better for the 2.4GHz radio, and I have no issues with the 5GHz radio.

In addition, I have a CRON job that reboots the router at 4:30AM every morning, so when I get up, the router is running fresh.

Mind you, I just attach my IoT devices to the 2.4GHz channel and have my PC/iPad/etc. on the 5GHz channel.

NOTE: that's what's working for me. I only put this here for discussion purposes only. YMMV.

1 Like

I've recently upgraded to 19.07.3 , installed non-ct drivers and everything runs well (range, batman mesh, mesh + ap encryption, 2g+5g).

What is the throughput of ath10k without ct?

Using the ct versions of the ath10k drivers, I was getting about 52-64Mbps on my 2.4G channel. Switching to the non-ct versions, I'm now getting over 100Mbps on my 2.4G channel. These were tests I ran with my Macbook about 6 feet away from the Archer C7.

Note: I'm using my Archer C7 V2 as an AP with a Gigabit connection and OPNSense router. Usual disclaimer: YMMV.

Here is a listing of the ath10k drivers I'm using:

root@OpenWrt:~# opkg list-installed | grep ath10k
ath10k-firmware-qca988x - 2019-10-03-d622d160-1
kmod-ath10k - 4.19.115+5.4.27-1-3

Hope this helps.

Give this a spin see if it solves your problem

I just installed this lol see if it dies like everything else

Thanks for letting us know. Did you by any chance try it with stock 19.07.3 drivers? The release notes state that improvements were made for the Archer C7.

Also, which non-ct drivers did you install?



I just did

echo "[INFO] Switching WiFi firmware from ct to non-ct ..."
opkg remove ath10k-firmware-qca988x-ct kmod-ath10k-ct
opkg install ath10k-firmware-qca988x kmod-ath10k

echo "[INFO] Done. Reboot required."

... But cannot test ct drivers as then my encrypted mesh won't start. I don't understand why this only seems to be supported by non-ct drivers.

1 Like

Slightly better than -ct, measured on 5GHz. like 460Mbit/sec instead of 430MBit/sec iperf3 using 2x2 802.11ac radio at 80MHz channel width.

FYI: I just benchmarked this build and it used approx same amount of CPU% as stock OpenWRT while doing WLAN-LAN 5GHz iperf3 traffic (no routing, just wifi-to-ethernet). Is there some switch that needs to be toggled in order to enable HW acceleration? Also, is this acceleration only affecting NAT/routing or is there a possibility it can take some load of sirq?