Archer C7 V2 - Massive Problems

TP-Link Archer C7 v2
Qualcomm Atheros QCA9558 ver 1 rev 0
Firmware Version
OpenWrt 19.07.0-rc2 r10775-db8345d8e4 / LuCI openwrt-19.07 branch git-19.334.63023-039ef1f

Many problems with OpenWRT or this router:

Problems like... on wifi:

C:\Windows\System32>ping  -t

Pinging with 32 bytes of data:
Request timed out.
Reply from bytes=32 time=126ms TTL=63
Reply from bytes=32 time=22ms TTL=63
Request timed out.
Reply from bytes=32 time=119ms TTL=63
Request timed out.
Reply from bytes=32 time=85ms TTL=63
Reply from bytes=32 time=49ms TTL=63
Reply from bytes=32 time=76ms TTL=63
Request timed out.
Reply from bytes=32 time=34ms TTL=63

Ping statistics for
	Packets: Sent = 11, Received = 7, Lost = 4 (36% loss),
Approximate round trip times in milli-seconds:
	Minimum = 22ms, Maximum = 126ms, Average = 73ms

and stuff when uploading, gets to 10% and hangs, also downloading things, same thing..

1 Like

There really isn't enough to go on in terms of trying to identify and resolve an issue.

First thing I'd recommend is that you upgrade to the official stable release of 19.07.0. Before you run the upgrade, create a backup of your configuration. When you do the upgrade, do not keep the settings (this will put the router back into a known good default state). Setup the bare minimum you need in order to have normal connectivity (i.e. configure and enable wifi, etc.). Test to see if things are working better. If so, configure any other parameters you need and/or install packages, etc.

Since you have problems right now, I'd recommend not restoring your backup directly unless it is absolutely necessary. Perform everything manually and see if the problems are resolved.


And while you are at it, it can be a good idea to make sure to switch to ath97 target if you haven't done so already.

I have the same router (US model though, but still V2), and never had an issue with the wireless on 18.06 (although it was working as an AP for another router in a PA-Sta setup, so connected 24/7). It also seems to be working fine with 19.07 (ath97).

1 Like

Pleas let us know how you get on after a upgrade and a full reset! Good luck.

In addition, please specify your whole network setup. You could do something like 2 Nat Traversals with the same IP.

I just upgraded, but I still have the same problem... stuff times out for like 3 seconds (ending all downloads, livestreams, webpages that are loading get stopped) and then works after that

TP-Link Archer C7 v2
Qualcomm Atheros QCA9558 ver 1 rev 0
Firmware Version
OpenWrt 19.07.0 r10860-a3ffeb413b / LuCI openwrt-19.07 branch git-20.006.26738-35aa527
Kernel Version

Default settings. just made a wifi access point

i am having these problems off wifi, i cant use ethernet

However, it is now more stable, but still has the annoying problems that make it impossible to watch a stream or download things without failing

try removing ath10k-ct driver and firmware, then install regular ath10k driver/fw. this bug has been fixed 2 days ago, but i never encountered it with regular ath10k driver so i'm not quite sure what they've fixed there

Which wifi band are you using? And are you using the ar71xx build or the ath79 build?

There is also kmod-ath10k-ct-smallbuffers which is required instead of the standard ath10k-ct for devices with 64 MB RAM and likely a good idea for 128 MB RAM as well.

how do i do that? am nub

can you give me your commands? is it possible to do this over wifi, i have a fear that if i run the command to remove ath10k-ct it would disconnect me before it tries installing the other

igot dis shit when doing opkg list

kmod-ath - 4.14.162+4.19.85-1-1
kmod-ath10k-ct - 4.14.162+2019-09-09-5e8cd86f-1
kmod-ath9k - 4.14.162+4.19.85-1-1
kmod-ath9k-common - 4.14.162+4.19.85-1-1

Do not attempt to do this over WiFi. Always use a wired connection for low level changes.

How do you do it anyway? I tried kmod-ath10k-ct-smallbuffers and it still has the same problem, so what psyborg said could work maybe.

I am running ar71xx, whats the difference between them anyway? i thought it was a CPU architecture or something

Just do the upgrade to 19.07.1 ath79

I have updated, still timing out sometimes when watching a heavy stream

Upgraded to ath79? Did you save configs? You should try new ethernet cables well you are at it. I have a c7-v2 and don't have any issues. It's running 19.07.1 ath79

Do you get the dropouts on all devices or just the one? Do you get the dropouts just on WIFI or all connections. Could it be your modem?

What is a "heavy stream"? Is there anything else taking up bandwidth? Did you do a clean flash?


This is a known problem, see: Archer C7 2.4 GHz wireless dies in 24~48 hours

Basically, 2.4GHz interface will start acting up if loaded too much. 5GHz is rock solid. For me, it was the same in 18.06, 19.07 and 19.07.1. replacing ath10k-ct with (newest version of) ath10k did not work either.

Currently, only thing that seems to work is to revert to older driver:

opkg install

That would be surprising, considering that the 2.4 GHz radio is driven by ath9k and totally independent from ath10k{,-ct} and its firmware.

Well if that is the case then backdating will certainly fail. But according to gentleman in that thread, backdating to older ath10k fixed the issue with his 2.4 stability? :confused: