Archer C7 serial problem


I have tried to debrick archer C7 router without success.
I have followed the this guyde:

It is downloading the FW from tftp (I have checked with tcpdump and from the logs)
Tried the factory and openwrt FWs as well.

The problem is that the FW could not be applied.

So I have connected via serial, but something is wrong. The characters is not readable and where "#" should appear during download "n" chars is appear continuously.
Here is my settings:

After that the router immediately restarts. Get back into continious restart state (bricked)

Could you suggest some solutions?

Thank you,

Without seeing the output, you may have bad solder connections, or may need pull-up/down on the serial lines. I'm assuming you've already confirmed that your serial adapter is operating at the correct voltage.

Details on the pull-up/down are on the wiki page for the Archer C7

Here is my terminal:

I'd first look at the integrity of the connections and confirm you're running 3.3 V signal levels.

That's a different behavior from what I saw, which I attribute "bleed through" of other signals on the PCB, especially during driver-firmware load. After that, the serial connection "cleared up".

Worth looking at if you're sure the connections are good and that you've got signal-level compatibility. Be aware that some serial adapters may still supply 5 V when the signal level is set to 3.3 V. Adafruit FTDI Friend is one of those, at least without cutting the pad bridge and making a solder bridge on the back.