Archer C7 cannot ssh to all ip's

I am setting up a orange pi cluster using a secondary router with openwrt installed on it. The pi cluster (8) is connected via a switch to the secondary router. I had no problem assigning them all a DHCP lease and ssh'd to them to install and update linux. I am having a problem with one as it does not allow me to connect with putty to this specific ip address Openwrt does see the pi with that ip and does allow me to sign the lease but for some reason putty will not connect, any Ideas?

I was thinking it may be an ip conflict with my other router as it also has DHCP enabled, but I figured if the secondary router already recognizes that ip to be managed then the other router isn't the problem. Sorry I am new to this so please bear with me! thanks!!

The problem is very most likely client side.

I tried deleting the lease file in openwrt but it just assigned all the same ip's as last time. Is there a way I can change the ip through openwrt? Can I reset it and make it choose ip adresses in another range where they would not conflict with the other ip address's my primary router is assigning?

I agree with @slh that this is almost certainly client side.

However, I have to ask -- why do you have 2 routers with DHCP enabled on your network? This is generally a very bad idea and will often lead to unexpected behaviors.

Most DHCP clients will request to renew the same IP as they used previously, even if you remove the reservations or reset the router. You can, however, assign a different IP (via the reservations) which will usually force the desired IP next time the client asks for a renewal. Alternatively, you can on the client device, force a release and then renew -- this doesn't always get a new address, but is better than nothing.

EDIT: if you are setting up a double-NAT environment with your two routers, it may be okay as long as properly configured. That said, traversing the firewall/NAT may be more complicated than it is worth. Please explain the physical/logical network config if you think the problems are related to your router(s).