Archer C7: Can WAN-port be used as LAN-port?

OpenWrt 18.06.1

I don't need the WAN-port of a TP-Link Archer C7 v5 and would like to have a 5th LAN-port instead. Is this possible?

Using Luci: Network / Switch I couldn't find what I am searching.

Yes, all ports of the c7-v5 are members of the same switch - so you can remove the WAN interface and add it to the LAN VLAN with the switch configuration.

1 Like

Thanks, but I have no idea how to assign LAN. I clicked add, which you see empty in row 3 in the screenshot. WAN was not visible before. So I removed nothing.

# cat network 

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix '....:....:....::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.178.57'
	option gateway '192.168.178.1'
	option dns '192.168.178.1'

config interface 'wan'
	option ifname 'eth0.2'
	option proto 'none'

config interface 'wan6'
	option ifname 'eth0.2'
	option proto 'none'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '2 3 4 5 0t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '1 0t'

I don't know how VID3 gets in there, but you can delete VLAN 2 and 3 - and then 'guess' what to do about WAN for VID 1.

VID 3 was created, when I clicked add, it is not there and I didn't save it.

Edit;
I think I understood it, Removing VID2 removes the WAN functionality and Untagged at VID1 in WAN column adds LAN functionality.