Archer C7 bricked(?) downgrading 19 to 18

I have a TP LINK Archer C7 v2. It was running 19.07.3 and I downgraded it to 18.06.7 using

After flashing 18 the wifis were down, tried also eth and nothing.

So I guess it bricked somehow, I've tried with the tftp recovery but no luck. This is what I'm doing:

  • set pc ip to (tried also with
  • start tftp server with ArcherC7v2_tp_recovery.bin (I'm using openwrt factory image here)
  • turn on the router while the wps/reset button, holding it until the wps light turns on

Nothing happens, I'm not seeing anything logged in the tftp server (tftp32)

Hope this isn't permanent :frowning:

Any ideas? Thanks

When you turn the router on for a normal boot, does the system LED blink fast, then slow, then come on steady? That sequence means that OpenWrt is doing something. After OpenWrt boots try a reset to defaults by holding the reset button for more than 5 seconds then release it.

To do a TFTP recovery from Windows, make sure Windows Firewall and any third party firewalls are disabled. By default they will block the TFTP request packets to your server.

Thanks for your reply

Turns out I installed another tftp server before installing tftpd32 (solarwinds), I think that wasn't working and left a service running that conflicted with tftpd32. Uninstalled the other server, rebooted, and got it working.

Sorry for the dumbness

Thank you all