Archer C60 v3 - is possible to install OpenWrt firmware?

Hi! The V3 stuff simply came to late to be in 19.07. Do not use the V2 Image. You can use snapshots. Be aware that you have to installl Luci by yourself in snapshots. See the wiki for that. The other problem is described here.


The snapshot image should be working. However, maybe the hacked 18.06 is the source of the problem? I will try the snapshot on my device later to make sure.

You are lucky, as I've built a backport for downstream anyway and therefore merged it into 19.07 as well (which typically would not have happened for a device supported after the branch).

C60 v3 should be built for the next point release. Or build it yourself if you can't wait for it :slight_smile:

But be aware that for me TFTP didn't work with vendor firmware image, so if you flash OpenWrt you might have to stick to it.

Actually, I'd be very interested if someone here could try to reproduce that (and thus prove that it's not me doing it wrong). TFTP with stock image is not working, but TFTP with OpenWrt factory image works fine.

You aren't alone @adrianschmutzler. TFTP with stock image didn't work on my C60 v3 either. I had the snapshot image on but couldn't get the internet setup (too long process). So I went back to the 18.06.5 image that @JamesT42 built.

I believe we need a stripped version of the v3 stock firmware in order to get it working again. Can someone help ?

Okay, so then the TFTP issue is not just limited to me. I haven't tried to mess with the vendor image in order to get it working, as I don't have a serial console attached and doing the wrong thing here will easily destroy my bootloader.

Note that I tried to flash snapshot yesterday and it worked perfectly fine.
Obviously, since the ar71xx version has a different board name, and that one is not added in master, flashing the snapshot will require the "-F" parameter. So, it is expected that sysupgrade will complain about non-matching board when upgrading from the "18.06" hack to master.

1 Like

Any luck with installing the stock firmware on c60 v3 ? Has anyone found a way ?

I tried installing a stripped version on the stock firmware in my c60 v3, but in vain. This doesn't seem to work & neither does the original firmware from TPL website. I guess we have no way to go back to stock firmware from Openwrt on TPL C60 v3 ??

i really need to go back to original firmware i just dont like the open wrt firmware any updates .
i've tried tftp and then forcibly installation through open wrt but it bricks the router then i have to flash theopen wrt firmware through tftp in order to make my router at least in operational mode.
but when i try to install the factory image through tftp it doesn't seem to work it just boots up in openwrt firmware. literally i'm stucked any help.
p.s i'm ready to do any kind of experiments to install the firmware just ping me up i'll try on the behalf of the developer

hey can you give me the stripped version of the factory image ?
i can try it on my router ...

Check your inbox please

What extra features we would get with this custom firmware ?
I'm actually looking for Bandwidth control for individual users which is been replaced by QoS and its not much useful.

Please help.

As it appears, TP-Link might have just put the wrong soft_ver in the image file:

Unfortunately, one cannot just change that, but has to fix the checksum as well...

Just managed to fix the soft_ver and recalculate the checksum. I'd be happy if somebody could test the TFTP image provided here: Help in unbricking TP-Link Archer C60 V3

Hello! TP-Link has released a new firmware for this device with soft_ver 1.2.0 ( Could you please change the soft_ver to 3.2.0 and recalculate the checksum? Thank you, Marios.

Hmm, would be interesting whether this 1.2.0 would be flashable over the original state now ...

My router originally came with 3.0.0 and the new firmware can't be installed because the soft_ver is to low. I tried through TP-Link webUI and TFTP but couldn't install it. One thing I'm concerned about is if I could install openwrt again after flashing this firmware.

I tried to modify the string to 3.2.0 but since I don't know how to recalculate the checksum it wasn't accepted. Could anyone help me or give some instructions on how the checksum works and how to recalculate it?

It's possible. Only BIOS Chip flash. I did. That. It's working. But I don't have V.3 file. I have V.2. Now my device V.2. BEFORE V.3. IF ANYONE Have dump file C60 V.3. Please share to me. Email