Archer C60 - Cant access Admin (connection refused)

Hello there! I'm with a lot of issues with my Archer C60 v2.0. It had the OpenWrt installed and it was not allowing me to configure 5ghz band properly, so i decided to Upgrade it to version 19. But after trying to flash the upgrade, it never left the Loading wheel and screen, so i thought it was already done and tried to refresh the page and reset the router. The result is now i cant access the admin using the ip, even though its the default gateway. It always shows "Connection Refused". I can see the network when i Power On and connect to it, but cant access the admin page, no matter what i do. I tried to download the correct firmware for my version on TP-Link website to flash it via TFTP, but with no results, nothing appears on the log tab. I changed my IP to and tried to power on while holding the reset button, but nothing happens at all, and it powers only the power LED and only corrects when i shutdown and power on again, without holding the reset. When i try to ping it accepts and answers, but i dont know what to do to make it work and/or install again a new firmware. Could someone please help me on that? Thanks!

First try a reset to defaults -- allow to boot fully, then press and hold the reset button for more than 5 seconds then release. All the lights should blink then it reboots with default settings.

If that doesn't help, next try ssh to

1 Like

Finally got it to work! Differently from the tutorials here, the TFTP only worked when i plugged the Ethernet cable on the WAN port, instead of LAN port. Then it flashed the firmware normally and rebooted. I changed the file name to tp_recovery.bin and used the IP, although my router gateway was

Thanks for this forum and all people who helped solving these issues. I spent last night trying to do this, and luckily in my last attempt (i was about to throw it on the garbage) it finally worked! Dont give up hahah

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.