Archer C6 V3.20 EU going back to stock firmware

Hello everyone, I tried today to install the OpenWRT firmware on my TP-LINK Archer C6 V3.20 EU but I dont think I did it very good. I flashed the first image and now I can only acces my router with TELNET, it responds to the IP adress but it asks me for login credentials... username and password, since this is my first install of custom firmware on a router I managed to find out only that the username is "root" but, I dont know what password to use. I get this message only when logging in with TELNET:
Thank u everyone!

Which version did you install? No current openwrt version would allow telnet, only SSH.
I guess you didn't successfully flashed openwrt and recommend you try again via TFTP solution.

1 Like
1 Like

I tried TFTP but i dont know if i did it right, I downloaded the stock firmware from TP-LINK but I keep the TFTP open but I dont get any answer. Can u please tell me exactly what I have to do? This router is new and I hope I didn't bricked it... Maybe some forum posts/article link, thank u so much. I installed the one listed on my router's page on openwrt website:

your router will be the client.

I assume you will be using windows

1 Like

Does this help?

Also see this:

1 Like

The most common reason for failing TFTP flashes is the enabled firewall on the TFTP server host.

1 Like

I just want to go back to stock firmware, I can only connect with TELNET to the router, TFTP is not working... Can someone help me? I can give Teamviewer/Ultraviewer or anything you need, please, it's a new router I think I broke it.

Did you try this: First time installing OPENWRT - #6 by Lynx

1 Like

follow this guide if you have trouble.
and did you follow @Lynx advice?


So, I need to set IP to auto, and power on the router, but, turn it off before it boots? 4 times, and, I can connect to that IP and upload the stock firmware? I dont think it's bricked, I can connect with telnet, the router's DHCP is working.


simply change the ip of your pc to subnet 2552552550

So you need to set manual IP as above.

plug in lan cable to lan port on router..power it on...and voila...

u can find the router on

I have never tried this but it looks like this gets you into a recovery GUI accessible from the browser? Perhaps someone else can confirm.

1 Like

I dont think it's bricked, I can connect to it, on the openwrt IP, only with telnet but it asks for username and password, and i did not set one, I know only the "root" username, but it asks for password too... The GUI is not working, will it enter recovery in this case?

I once used TFTP once to recover my 1043ND, it usually doesn't work on the first try, but it does work.

1 Like

Ah, so no GUI it's just that this allows you to use TFTP?

So @RaresC95 maybe you need to follow the video above. Seems pretty clear to me.

1 Like

I can't use TFTP, I press the reset but it dosen't see the router, it just boots into OPENWRT, but, i can not set it, only TELNET acces to the router, no GUI.

Once you have flashed back to the stock firmware.
follow this and flash Openwrt the easy way. OpenWrt is much better and has more features than stock

1 Like

This indicates that you are not connecting to the C6 v3, but to the modem to which the C6 v3 is connected (ZTE ZXA10 F625G perhaps?).

By the way: What do you want to do, install OpenWrt or go back to TP-Link firmware?


separating the TFTP host and the C6, from the rest of the network, would be a good idea.

1 Like

I want to restore the TP-LINK Firmware. I dont have any modem connected... That's what is saying when I type the gateway IP in the telnet.