Archer c6 v2 eu slow speed

Hi all,

Recently I installed the latest open wrt on my official rom i'm getting very good speed I thought I'll get a good performance but here is something bad with me.

on stock rom my speed is 400MB
on openwrt 100MB

I am using Archer c6 v2 EU Please help me to improve my speed I'm very very upset from last 24 hours and spend everything every setting also I tried to revert back to stock firmware that also I am not able to do I did that successfully but after flashing my wifi is not working so again I flash open writ at least here i'm getting 100 mbps but it is not enough so can anyone help me please to get the correct speed.

Install htop, see if you max out the CPU.

Please guide me how to do that i'm in putty command

opkg update
opkg install htop

Seems good

Is this while achieving max speed, when using speedtest, or similar ?

This screenshot while testing a speed test. CPU is 100%

So now you know.

As for why it's capable of doing 400mbit on stock fw, is because the closed source fw uses hw acceleration, not available to Openwrt.

So can you tell me what I can do now because I need some solution even I am trying to revert back to old version but I'm able to flash firmware successfully but then after that my router does not reboot only one light is on other than that everything is off. If you help me that's really good I see there is a option for hardware acceleration But I don't know how to configure I'm ok to go with my previous stock version so if else you help me that really helpful for me.

The "correct" speed using this device with PPPoE via WiFi on OpenWrt should be around 300Mbps. The "correct" speed using PPPoE via Ethernet on OpenWrt should be more than 600Mbps.

This is assuming flow offloading works as intended, but on OpenWrt 22.03 and 23.05 it is not really achievable as-is as there is a known bug affecting PPPoE connection on all devices, not just yours.

There is also a known workaround to activate the flow offloading functionality; connect via SSH to the router, and type (or better copy and paste):

cat >/etc/nftables.d/20-custom-flowtable.nft <<EOF
flowtable myft {
	hook ingress priority 0;
	devices = { "br-lan", "pppoe-wan" };

chain forward {
	type filter hook forward priority filter; policy drop;
	meta l4proto { tcp, udp } flow offload @myft;

Once this is done, restart the firewall by typing:

/etc/init.d/firewall restart

Then test again and see what speeds you are getting.

1 Like

WOW now it's 200MB But still it's less by actually speed is above 350MB Can we do something to get that more and I really really helpful that you shared the things.

Have you also tried via Ethernet?

Unfortunately, the 5GHz 802.11ac QCA9886 chip your router has doesn't have any kind of CPU offloading (even possible) in modern OpenWrt.

Unlike more modern MT7615/MT7915/MT798x that have additional hw acceleration baked into the linux kernel, or out-of-tree (supported by unofficial OpenWrt builds) QCA NSS acceleration for more modern Qualcomm/Atheros devices, your device uses the older atheros mips SoC and only hardware acceleration is available via ShortcutFE out-of-tree driver that was AFAIK only successfully ever built on OpenWrt/LEDE 17.01.

Have you also tried via Ethernet?
No Guide me how to do this but my connexion is based on pppoe

Also, I'm getting closer to 300Mbps on my C6v2 PPPoE via WiFi, but I don't know what additional settings you have.


flow offload @myft;

offloader includes tcpudp filter.

1 Like

I have not done any additional settings screenshot I already shared in my first message only these settings I have.

I meant testing while you are connected to the router via a network cable.

Please enter htop settings and disable "hide kernel threads" and enable "detailed cpu time"
That would show what part of now red band is softirq (violet after change) and what stays hardware irq.
From the 1st change well see it is more load form wifi or wired.

Done here is results

not blaming you, but intuitive things sometimes bring worse.
sofirq is firewall and qdisc - hope you did not enable any extra qos module?
kworker is offload - given the nftables.d fragment you have to disable offloads in luci?
of minor impact - drop invalid packets checkbox gives small relief.