Archer C6 v2 EU: 5Ghz Wifi dropping, revert to stock not possible

Hi all,

because of an issue with the stock firmware I tried the current snapshot (r10766-3032bf7f89) on a TP-Link Archer C6 v2 EU yesterday.
It turned out that the 5Ghz Wifi drops after several hours of working flawlessly.
The syslog contained this message:
executable path /usr/sbin/wpad does not match process path ()
The wifi is shown as unassigned in the webinterface and the SSID is no longer broadcasted.
(I just flashed again and lost syslog, but I can post more from the syslog once this happens again).

In order to get Wifi working again I wanted to revert to the stock firmware which seems to be not possible. Does anyone have experience with this model and could please help me with this?

What I did so far (as there is not much doc/posts on this model I will give more detail):

  • Installing OpenWrt in the OEM web UI did not work as the file failed the check.

  • TFTP method worked:

    • PC LAN interface set to 192.168.0.66, subnet mask 255.255.255.0, gateway 192.168.0.1, connect to LAN1 on router
    • Installed tftpd-hpa (Linux Mint), started service, renamed and copied openwrt bin to /var/lib/tftpboot/ArcherC6v2_tp_recovery.bin
    • Keep reset button pressed on router, switch router on, wait till all lights flash up, release button (tcpdump on PC can be used to observe transfer)
  • The following steps worked according to the generic docs (ssh, install luci, etc.). In my case installing the package luci-ssl-openssl made the GUI unresponsive as ui.js would constantly fail to query endpoints. Maybe it helps to use a properly signed certificate but it seems better to not install this package on a first time installation.

  • Wifi was enabled using all default settings, except SSIDs, encryption (WPA2), cipher (CCMP/TKIP)

  • 2.4Ghz works fine, 5Ghz drops after some hours. See error message described initially.

I assumed that something might be broken in a snapshot version but my bigger problem is that it's impossible to revert to the original firmware.

I downloaded the firmware release 2019-02-20 I had installed before from here:
https://www.tp-link.com/de/support/download/archer-c6/#Firmware

I followed the same procedure that worked for openwrt using TFTP.
This results in the router not booting up after flashing: just the power LED lights up, can't ping or connect on 192.168.0.1 or 192.168.1.1, DHCP not working.
Same with the older stock firmware.
I also tried to flash in Luci and using the CLI sysupgrade, which both require forcing (-F) the update and result in the router not booting anymore.

As far as I understood stripping parts of the .bin file is not needed if the image does not include a boot partition but I am not sure about that.

Fortunately, flashing openwrt worked each time.

I would very much appreciate any help on how to install the original firmware again and/or on how to get 5Ghz Wifi running stable.

Thanks in advance!

5GHz wifi is problematic for some devices but it does work. I'd suggest you tu choose correct country for the 5GHz band and also choose a single channel rather using auto. Experiment with different channels and see for yourself which works best.

Hi Ahmar,
alright, I set the correct country code and fixed channels with max bandwidth on both wlan0 and wlan1. So far the 5Ghz wifi dropped twice (yesterday and this night), I will update my post with the syslog if it happens again.

That may be a problem. You may not have clear channels to support 160 MHz bandwidth or even 80 MHz. DFS and other users can force the radio to shut down and change channels. Also, the base channel needs to be consistent with the bandwidth.

Ok, thanks. I was not aware of that auto shutdown mechanism and I do not remember if or which bands I picked yesterday.
The device allows 80Mhz maximum bandwidth on the 5Ghz Wifi and which is what I used with the stock firmware if I remember correctly.
I picked a channel now which should stay within the regulation of my country and will reduce bandwidth in case of problems.

Hello @jeff and @mashedpotatoes.

5 GHz is a know issue for this router.
Take a look:
https://github.com/openwrt/openwrt/pull/2470

I have an Archer C2 (US), hope that a solution for this problem can be found soon.

Regards.
Juliano

1 Like

Hello people.

From your experience, can we still have any hope that the 5Ghz band will work properly someday?

Or is this chip one of those where developers can't do much due to driver / hardware implementation?

Is there a way to find out if anyone is working on it?

Regards.
Juliano

Hello.

A new hope for us...

https://github.com/greearb/ath10k-ct/commit/3e3d0adb3cc6c6cf56a05ff661796948f09c5aa8

Regards.
Juliano

Update:
Tried today.
No improvements for 5Ghz. :frowning:

Juliano

@julianocs hey, I got openwrt to boot on my Archer C6 V2 (US) . I had to use the snapshot. Anyway, I have the same issue, Wifi 5Ghz is abysmal, no range nor speed. Did you figure anything out yet?

Hi.

I didn't figure anything out.

Honestly, I don't know if there will ever be a solution to this 5Ghz problem because lately I don't see anyone or any developer saying they are working on that, sad.

I don't have enough knowledge for that, I could only help in the testing part.

Regards,
Juliano