Archer C6 failsafe mode n/a?


I thrifted a couple of Archer C6 soap boxes recently. One of them was apparently 1337 hAx0red professionaly to OpenWRT by its previous owner: once booted the LEDs on the device will turn off (probably GPIO LED settings are skewed due to faulty firmware), however networking will be available and is listening to

However trying to access LuCI gives a forbidden text first in the browser than the following:

"No root node was registered, this usually happens if no module was installed.
Install luci-mod-admin-full and retry. If the module is already installed, try removing the /tmp/luci-indexcache file."

I concluded that the OpenWrt version on it is basically trashed. Trying SSH will prompt me for the root password which obviously I don't have.

I have tried booting failsafe mode, apparently, as this time the power and ethernet LEDs are on, however the issue remains the same, SSH would still ask for password, instead of letting me in without it, as it should be default when failsafe mode is on.

Is there some other way to circumvent, or clear the current firmware to defaults within the current OpenWrt installation or accessing proper failsafe mode? I have tried TFTP boot without luck, as this particular device is tricky (very short timeframe for TFTP) and at this point I'm not even sure if it works. Also the serial port test points are so tiny and are in an obsucre place on the circuit board, that I have reservations about soldering pins.

Long pressing the physical reset button (after boot completed) should restore OpenWRT to the default configurations and you should be able to login via root without password.

If you press the reset button before boot while power is flashing slowly you should get into Fail Safe mode.

1 Like

That did the trick, thank you! Also it helps to clear your browser cache/temp junk when LuCI is in the picture too.

P.s. It wasn't vanilla OpenWrt on the device after all, it was TP-Links factory image, which apparently is also based on OpenWrt.

pretty much all home wifi devices are based on openwrt or LEDE.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.