Archer C6 cannot install stock fw


I have bricked C6, so i tried to install firmware via TFTP, but without success
I am able to install OpenWRT this way, but when i try to flash back stock firmware, it is not succesful
TFTP sends recovery file to router, than router restarts immediately, and only power led is on.
I tried more fw versions, but with no luck
I am still able to flash OpenWRT, but i want stock fw because of OneMesh

i was able to flash "stock" fw from this site (thx to @123serge123)
Archer c6 v2 recovery bin - Installing and Using OpenWrt - OpenWrt Forum

but i have still the same problem like previous user. I can not install stock fw, probably because of version number.
In router, it shows, that i have version 1.9.1, but newest original verison is 1.3.6

Is there a way, how to "force" change this version number?? Or can i somehow "force" router to downgrade?

@123serge123 , dont you know, how to solve this? Maybe prepare another modified fw, but with number 1.3.0 for example?

There exist reports that very old stock firmware (something like soft_ver 1.0.1) can be used for recovery without problem.
Or read/backup partition which contain soft_ver, correct value with binary editor and write it back. To make partition writable use kmod-mtd-rw package.

1 Like

Many thx, this was helpful
I found oldest fw (Archer C6(EU) and flashed it to my C6
No i have newest version installed
Great job

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.