Archer C50 v4 Mac80211 Loses Internet Access after 20'+ Away from Router But Maintains Connection

serious problem also with my c50v4 devices...
note though, e.g. netgear r6120 is NOT affected although it uses the same mediatek chip.

Thanks for creating a binary :). Do you have to delete your old configuration to install this patch? I installed the patch but it still says that radio0 is "Generic 802.11bgn" and I still get 1Mb speeds. I was able to confirm the hardware ID for mine is 0x7600.

dd if=/dev/mtd9 of=output.binary
hexdump -C /dev/output.binary
outputs:
00000000 00 76 00 02 00 0c 43 e1 76 30 00 00 00 00 00 00 |.v....C.v0......|

Also big thanks to dtrautmann!

1 Like

I built a snapshot last night. In addition to the patch, it has zram-swap, zram-tmp, adblock, ddns, ipv6, and unbound built in. I removed any PPPoE packages, but there may be enough space to install using opkg.

Link.

Thanks for sharing. I've yet to have any luck applying VintageRain's upgrade file.
Is your an image or upgrade file? Can it be used to flash OEM -> Openwrt or do i need to be on Openwrt first then use it as an upgrade?

It's a sysupgrade. Follow the directions here to flash from OEM firmware to openwrt, then apply this as an upgrade.

Thanks @ronasimi for pointing me back to the wiki. The instruction regarding building your own image has changed since i last visited. There are some additional terminal lines added. I'll give it a go again later this evening.

The relevant section of the wiki page:

If you do not want to create your own OpenWRT install image, pre-built albeit older 19.07 snapshot images are available. The images were built by the forum user bill888 and announced here.

Download and extract the contents of the zip file in this dropbox folder. The file contains Open Wrt image files, an image file to revert from OpenWrt to the TPlink stock firmware and detailed instructions for installation via Web GUI and TFTP.

To install using TPlink Web GUI:

Log into the TPlink's stock firmware Web GUI at 192.168.0.1;
Flash the router with 'boot.bin';
After the router restarts, log into LuCI at 192.168.1.1;
Download the latest stable release: tplink_C50-v4-squashfs-sysupgrade.bin (linked above, in the “Downloads” section). Use LuCI to install the sysupgrade file, untick the 'Keep Settings' check box.

Works great on my Archer C50 v4 Thanks !!

it works guys on c50 v4 thank you for this great work
god bless you all :heart:

Works great on my C50 V4.20 (CA) :slight_smile:
Thank you for your build !

1 Like

Hi @VintageRain. Nice that you managed to build a version with the correct driver. I tried but unfortunately I was unable to apply the patch in the build process.

I followed the recommendation of @dtrautmann, that is, I put the patch inside the packages/kernel/mt76/patches directory and simply recompiled it. I think there are some more steps to properly apply the patch.

If anyone can help, I am immensely grateful.

1 Like

I too would be grateful to see a mini tutorial. I've done custom FW builds using the imagebuilder file that are downloadable via https://downloads.openwrt.org/releases/19.07.4/targets/ramips/mt76x8/ . But i've never needed to apply patches before. I tried the compiling method but was overwhelmed and ultimately unsuccessful.

Based on your screenshot, the patch isn't at the good directory? You put it on Patches-5.4 folder
I built an image (v19.7.04 not from master) this morning and the patch applied to the m76 kernel. You have to put on the good folder provided by drautmann.

If someone have the same problem, I had some dropouts when streaming from Netflix/Disney (Chromecast)

I reverted a commit on mtk_soc_eth.c (just wrote back from the older blob)

Hi @darkmaxx1

Could you provide us with the steps you followed to compile your version, please?

I tried several times and did not apply the patch. I'm almost giving up. :disappointed:

Assuming you have a working linux environment with git, clone the openwrt repo from github and follow the steps here: https://openwrt.org/docs/guide-developer/build-system/use-patches-with-buildsystem

Thanks for the tip @ronasimi
But I have already followed these steps several times. I'm certainly doing something wrong at some point.

I'm very new on OpenWrt, since a few days I switched the tp-link firmware to open-wrt

As always, it is as your own risk for doing the compiling and applying the bin.
Note: It creates a bin file to apply on OpenWrt only, not for TP-Link stock GUI

I may did something wrong or forgot something, but Open-Wrt flashed and rebooted OK for my case.

I compiled from a Xubuntu 20.04 LTS

Used the guide https://openwrt.org/docs/guide-user/additional-software/beginners-build-guide and https://openwrt.org/docs/guide-developer/quickstart-build-images

on the terminal, the folder I was @ /home/myuser/

git clone https://git.openwrt.org/openwrt/openwrt.git
cd openwrt
git tag
git branch
git checkout v19.07.4
./scripts/feeds update -a

(3 errors, installed: gawk / ncurses / python2)

sudo apt-get install libncurses5-dev libncursesw5-dev
sudo apt-get install gawk
sudo apt-get install python2
./scripts/feeds update -a (again because of the errors)
./scripts/feeds install -a
make menuconfig
“Target System” ⇒ “Select” ⇒ “mediatek ralink mips” ⇒ “Select”
“Subtarget” ⇒ “Select” ⇒ “mt76x8” ⇒ “Select”
“Target Profile” ⇒ “Select” ⇒ “tplink_c50-v4” ⇒ “Select”

Don't forget to add LUCI
LuCi/Collections/luci with an [ * ]

Exit the menu and save

I really don't know how to use quilt so I just save as with right-click the link for 442.patch into the folder
"openwrt/package/kernel/mt76/patches/" (the patches folder isn't there, you have to create it)

Then you do a "make" it takes a long time, you should see a file.bin into the folder "openwrt/bin/targets/ramips/mt76x8/"

The file size should be around 3.9Mb, without Luci it would be 3.5Mb.

I compiled three times:
1st bin : didn't have LuCI
2nd bin : didn't have the patch (the patch file was @ openwrt/package/kernel/mt76/)
3rd bin : works good, tested my iphone with fast.com in my living room where it couldn't do the test without the patch, and the 2.4ghz signal was stronger vs 5ghz.

Hope it helps

2 Likes

Thank you so much for taking the time to help me !!!!
I deleted all the files and started again just like you did and everything is working now.
I really have no words to thank you.

1 Like

I second hborba's thanks to @darkmaxx1. This was straight forward vs the wiki's explanation. Where do i check in the router to confirm that the patch applied? What's the eeprom file location of the that has the added line of text "case 0x7600"?

I couldn't find the file location on my openwrt folder. I cannot answer that.
But I know when you execute the "make" command, you can see a line where it mentions the kernel for MT76, so I guess it creates the eeprom inside the bin and apply the patch... or it is created inside the building/working dir ? That's beyond my comprehension.

You might be able to check on SSH and call some commands, but you can test the bandwidth on internet, before the patch that was 1Mbps or nothing, after the patch, at the same place, I got my internet provider speed (40mbps)

You can check on the WIFIs signal 2.4ghz vs 5ghz away from the router. 5ghz was way stronger.
That's all I did to know if it worked or not. The 2nd bin I created didn't have the patch and the bandwidth test couldn't start. so I had the bug.