Archer C50 v4 Mac80211 Loses Internet Access after 20'+ Away from Router But Maintains Connection


I’m not familiar with replacing bin files but I definitely give it a try ASAP on my unit. It looks straight forward to do though.

You just need to copy and paste the files. You can use scp (cp over ssh) to copy them.

EDIT: remeber to either reboot or reload the modules after doing the copy.

Trial #1
MT7610.bin rename dto mt7628.bin
mt7612_patch_e1_hdr.bin renamed to mt7628_e1.bin

Able to double the distance before i loose access to internet (wifi connection remains), speeds degrade the closer i reach the point where i loose internet access.

Trial #2
MT7610.bin rename dto mt7628.bin
mt7612_patch_e1_hdr_0417.bin renamed to mt7628_e1.bin

Same as above.

EDIT1: I wouldn't take the above as solid evidence that its the driver that improved 2.4Ghz wifi. Shortly after i finished testing, i noticed 19.07.1 service release was published. I factory rest my router and applied the sysupgrade then tested with same wifi config above, the results where somewhat the same. My conclusion is that my environment (out of my control) changed enough that the results where positive.

I upgraded to 19.07.1. I can now see the network from further(I think) distances but still cant connect.

I'm curious. If I had both a stock unit and a OpenWRT; has anyone performed an actual comparison of signal strength and connections on 2.4ghz? Is it possible that the stock TP-Link firmware is just as bad?

I'll be comparing a stock router and openwrt side-by-side as i have multiple sets in the next couple days.

I just finished testing on the latest Canadian stock TP-Link firmware and am able to get about 5.5 times the distance and access the internet (speed test).

I eagerly await a fix. I had bought a C50 a few weeks ago because I heard it was supported. In the mean time I am using my old router as an access point for 2.4ghz. Mine showed no issue with uploads but downloads didn'tt go above 0.9Mb/s on 2.4Ghz.

Add me as someone else experiencing poor wireless download on 2.4Ghz with a TP-Link Archer 50 v4 (Canada).

OpenWrt 19.07.1 r10911-c155900f66

Hoping for a fix sooner rather than later.

Count me in as well

I'm using the router on the exact same place it was before installing OpenWRT and I do have this problem.

To keep everyone up to date.

There is a bug report on the OpenWRT bug tracker and a bug report on the kernel bugzilla. Unfortunately we still have no response from the kernel devs. Looking at the patches to the kernel, there seems to have been another card, from the same family and with the same problem, that had it fixed with a driver update. If anyone is interested in taking a look, see the kernel bug report.

There seems to be a way to improve receiving performance. From the kernel bug report:

iw phy phy0 set antenna_gain 20

To keep the thread alive, i recently tried 19.07.2 and don't see any improvements. Thought i'd give it a shot and see if any in the service coincidentally fixed our issue. Give it a try yourself if you'd like.

Hello, today 2019 April 8, is this problem still unresolved?
I decided to install OpenWRT but If there is a such a big connectivity problem, I can't see the reason to upgrade the device from the official TP-Link's firmware to OpenWRT.

Any advice would be appreciated.

Hi Stefanos,

At this time, there isn’t any fix or workaround.

1 Like

Hello, I have the same problem with my TP-Link Archer C50 v4 BR. I had an improvement in the signal using the settings below, but the transfer rate is low, around 1Mbps.

Firmware Version: OpenWrt 19.07-SNAPSHOT r10269-5100629e32 / LuCI openwrt-19.07 branch (git-19.190.55584-ab90938)

Kernel Version: 4.14.133


config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11g'
        option path 'platform/10300000.wmac'
        option legacy_rates '1'
        option country 'AU'
        option channel 'auto'
        option htmode 'HT40'
        option distance '15'
        option noscan '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'psk2'
        option short_preamble '0'

FYI 19.07.3 has been released. Haven’t tried it yet on this unit to see if it correct the 2.4 wifi issue where having.

I read in the comments some recommended procedures for burning the firmware, what would be the recommended procedure for burning the firmware? TFTP or do you have a recommended procedure just for upgrading?

Instructions are from memory as it took me some time and a lot of research and trial and error to interpret the material i found on the internet. Sorry if they are not step by step.

I compiled my own image using the image builder, for the 19.07.3 release HERE.

The bin file created above can't be used as is. See HERE for an outline of how to apply a bin file.

Instructions . This only works on a Linux machine or VM ( i used vmware the free VMWare workstation Player + Linux Mint). I tried the Frontends, but i was never successful.

Just applied 19.07.3 and made replicated my original wireless setting...nothing crazy, just the basics for my region. No positive change from any 19.07.x. I suppose reading the log change file would have told me there was no change for this router.

1 Like