Archer C50 V3 Firmware update


I have bought an Archer C50 V3 a few month ago, and installed OpenWRT on it. At installation I had to use the TFTP boostraping method, but it worked.

I never had good wifi performance (ie wifi disappears on a regular basis). I tried updating to the latest version 18.06.2 last week, and it successfully updated. But after updating (and I did it once more this morning to be sure), the FW version in Lucy shows :
OpenWrt 18.06.1 r7258-5eb055306f / LuCI openwrt-18.06 branch (git-18.228.31946-f64b152)

Is this a minor version reportingglitch with 18.06.2, or am I not updated to the latest version ?

Thank for your feedback.

That's 18.06.1, see

Ok, I do not have the proper version.
I started there (selected the update link ):

Got the file withSHA256 :
Nom: openwrt-18.06.2-ramips-mt76x8-tplink_c50-v3-squashfs-sysupgrade (1).bin
Taille: 3801266 octets (3712 KiB)
SHA256: 07788EBB8AB77D3D0025A664FE66F6D7549D479C7C4B5DE6A9AA931F7AA6BC9A

Then I go to flash firmware in lucy and get this check before flashing :

All stars seem properly aligned, but I do not get updated to 18.06.2. What do I miss there ?