Archer c5 v2 bricked - no serial no tftp - programmer needed for flashing

I have this router, i bricked it accidentally while uploading the stock image. I screwed the serial port soldering, it seems the pad from one of the wholes in the pcb is destroyed, i've already arranged with a friend who owns a rework station to remove the flash and solder it back, before that i would like to know how to flash it, what programmer to use and what image to flash.

The flash seems to be fl128sa1f00 but not much info on the web about this.

I have attached a video of the boot process and the led blinking so maybe you can identify the actual state or give me a clue of what's wrong with the device, so probably no direct flash needed, tftp doesn't seem to work.

It looks like the bootloader started then it failed to boot the kernel and went to TFTP recovery. This is indicated by the WPS light coming on and staying on.

Probably can just TFTP it, may not need to even open the case.

Also check that the reset button is not stuck down.

1 Like

Thank you very much for your reply, i already tried to do tftp on all the 5 ports, but checking with tcpdump, it doesn't seem to be any activity from the router, the link is up, but no packets.

Nov 19 00:16:50 Equipo4 kernel: [83994.116439] dm9601 1-10:1.0 eth2: link up, 100Mbps, full-d
uplex, lpa 0xFFFF

I've also checked the reset button using a multimeter and is normally open as it should be.

Is there any hope for this device?

use a switch in between... far back button from front the left one...

#pc needs ip -> ArcherC5v2_tp_recovery.bin to

I already tried with that ip also with the ip in all possible ethernet ports, the server has all the possible image names on it, but nothing. I even tried to put the file on the ip you mentioned

even when i know the router is the one who makes the request.

How a switch would be helpful if there's already a link?

The switch keeps the PC from restarting its port driver while the router goes up and down. The PC will have a constant Ethernet link from the switch and keep its IP address set.

Running a TFTP server on Windows requires disabling the firewall. The PC must not be connected to any other networks wired or wifi during TFTP recovery.

No, that's not the problem i check the ip address after turning the router off, and the system keeps the ip, by the way i'm not using windows and i've tested the tftp server from another machine and it works. Anyways i tried the switch in between but the same result, no requests to my machine.