Archer C2 (v1.1) no TFTP download after ACK init

Hello guys,
I'm owner of Archer C2 (v1.1) Tbh, I'm not sure how to find out if it is EU/NonEU version

I somehow bricked my device and all it does after turning it on is:

  1. only power led is on
  2. after 3s "globe" led is on (together with power led)
  3. after next 2s all leds are on
  4. after next 2s GOTO 1 -> 2 ... -> 4

After searching/browsing forums I found out, that TFTP should be possible, so I tried that one too, but none of the clients I've tried so far could upload the firmware. Every time it failed. I tried 3 servers on Mac (pumpKIN, TftpServer, native one) , 2 on ubuntu (atftp, tftp-hpa) and tftpd64 on Windows.

So just to be sure what is going on, I installed wireshark and saw this.
After setting all the necessary (static IP/subnet for server) and starting router with reset button pressed on, the router asks for file ArcherC2V1_tp_recovery.bin my tftp confirms it (ACK) and starts serving it with block 1, but router doesn't "accept" it, so the servers tries to serve the block few times and then stops, because there is no reply (ACK) from router.

I found some articles reading hints like setting some arguments for server could help (retries, timeout, anticipation window), but all this changes is that my server tries to repeat sending first block more times, or he sends block 1-5 few times, but at the end, there is no answer from router.

I've tried connecting router - PC directly, through another router, running server in virtual box, but the same result all the time = NO ACK from router.

Do you guys please have any idea what could I try next, or the router is "dead" and I can throw it away. Soldering and connecting serial console is out of my hw skills :slight_smile:

Thank you for any suggestion

Place the ArcherC2v1_tp_recovery.bin file in the same folder as TFTPD64.

Open your network settings in Windows, and select the wired adapter (don't try this on a wireless connection).

Right-click and select Properties.

Select Internet Protocol Version 4 (TCP/IPv4) and click on the Properties button.

In the General tab, select the radio button for Use the Following IP Address.

Enter for the IP address.

Should default to for the Subnet Mask.

Turn the router off.

Make sure nothing else is connected to the router, it should be just the router and your computer.

Open TFTPD64. You may be asked to allow it through the firewall. Select Public.

Go to Settings > Global, and uncheck everything except TFTP Server.

Go to Settings > TFTP. Select None for TFTP security. Uncheck Option negotiation, and enter in the Bind to this IP address drop down.

Go back to the main window, and make sure the Current Directory dropdown is showing the path to the TFTPD64 folder, which should also contain your recovery firmware file ArcherC2v1_tp_recovery.bin

The IP address should be displayed in the Server Interface dropdown. If not, select it.

Go to the router and press the power button and the reset button at the same time.

Release the power button...but continue to hold the reset button for about 4 or 5 seconds, then release.

You should see a progress bar going across the TFTPD64 screen (although it should only take a very short time).

View the log. It should show 100% transferred.

Go back to your wired network adapter, and change the radio button back to Obtain an IP Address Automatically.

Try to access the router GUI. The stock firmware IP address is and admin/admin for the User Id and Password.

If you can see that you have Internet access in the Network icon, but can't access the GUI, open a Command prompt and run ipconfig /release and then ipconfig /renew.

Try to access the GUI again.

Hi, thank you for you hint, but it's almost the same I've already tried (except of some settings of that server you proposed) So when I uncheck those options and select *.66 everywhere I still can see the same "flow" in wireshark =

  • router asks for file (which exists, since 512 bytes are sent in block 1)
  • server confirms and starts to serve the first block (512 bytes)
  • no ACK from router

I also tried to run the server as admin/nonadmin, from ProgramFIles/Desktop...

Screen Shot 2021-11-20 at 11.55.41

Screen Shot 2021-11-20 at 12.03.51

What firmware file did you use for ArcherC2V1_tp_recovery.bin?

From the wiki on the C2 recovery -

If you encounter timeouts, you might want to put a switch between your router and client to facilitate the flashing process. The tips below might not be needed after that.

A few users reported that flashing via TFTP server was only possible when the option “Use anticipation window of” with 1000 bytes was enabled in TFTPD32 * for Windows. So, if your flashing process hang at some point, restart the process with this option enabled.

Also, you might have to lower your ethernet link to 10 Mbps Half Duplex in order to finish the process.

*The same setting would apply in TFTPD64.

Hi, thx for hint, I've tried that too. I found a thread when someone suggested setting that anticipation window but it didn't helped me, the 10MB half duplex ethernet either :expressionless:
Those who are using those window/half duplex have at least response from router, so few packets are transferred and than connection is closed.

I'm getting firmware from I tried all 3 versions, including EU ones, so 6 different versions.

So after couple of years, it's time to get a new router I guess :slight_smile: