Archer C2 dumb AP configuration

Openwrt versions 21.x and 22.x do not work correctly as a DUMB AP. The Archer C2 has 2 built-in switches and the instructions are to ignore or delete SWITCH0 and configure SWITCH1 for VLANs. However this doesn't work correctly when operating as a dumb AP. It works fine in router mode however. Openwrt 19.x works fine with this router when configuring for dumb AP and router mode.

21.x / 22.x config dumb AP not working:

network


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdd5:735f:207a::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.1'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device
	option name 'eth0.2'
	option macaddr 'd4:6e:0e:b3:c7:5c'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '0'

config switch
	option name 'switch1'
	option reset '1'
	option enable_vlan '1'
	option enable_vlan4k '1'

config switch_vlan
	option device 'switch1'
	option vlan '1'
	option ports '1 2 3 4 6t'

config switch_vlan
	option device 'switch1'
	option ports '0t 1t 2t 3t 4t 6t'
	option vlan '4'

config interface 'lan_guest'
	option proto 'dhcp'
	option device 'eth0.4'
	option type 'bridge'

config device
	option name 'eth0.4'
	option type '8021q'
	option ifname 'eth0'
	option vid '4'
	option ipv6 '0'

wireless


config wifi-device 'radio0'
	option type 'mac80211'
	option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
	option channel '36'
	option band '5g'
	option htmode 'VHT80'
	option disabled '1'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/10180000.wmac'
	option channel '1'
	option band '2g'
	option htmode 'HT20'
	option cell_density '0'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option mode 'ap'
	option ssid 'OpenWrt_guest'
	option encryption 'psk2+ccmp'
	option key 'ArcherC2'
	option network 'lan_guest'

The configuration posted does not delete switch0 as the instructions say to. Also the configuration of switch1 mixes tagged and untagged on the same ports. This can be problematic, it is recommended to have a trunk port that is only tagged.

In the wifi configuration, set your country code on both radios for best results.

the config shown here is just a recreation for effect. I did delete switch0 and also set country code in my original config. Deleting switch0 has no effect and the problem persists that it refuses to operate as a dumb AP. It works in router mode for some reason, just not as dumb AP.