Archer C1200 filesystem corruption

Hi, I have a tp-link archer c1200, its not supported at all but there is some images that you can flash with the uart console. It works all, but there is a problem with the rootfs_data. The first time you boot it, it works correctly, you can access all the spi nor memory and write. But when you reboot it shows a error about the crc and the files get corrupted on some blocks. I have tried it with two models (v1 and v2) and the same. Later, I make dd (dd if=/dev/zero of=/dev/mtd5), hexdumping and reboot (also unplugging ac) and it doesnt corrupt. I've tried jffs2 and ubifs with the same result, but I have noticed that the fs corrupt when it's uses as root. I'm using lede with kernel 4.9.65. Thanks

1 Like

Hi, I have a tp-link archer c1200 v2.
I uploaded a full dump asus rt-ac 1200g+ and after that I see in console:

Init Arena
Init Devs.
Boot partition size = 262144(0x40000)
DDR Clock: 533 MHz
Info: DDR frequency set from clkfreq=900, *533*
bcm_robo_enable_switch: EEE is disabled
et0: Broadcom BCM47XX 10/100/1000 Mbps Ethernet Controller (r584393)
CPU type 0x0: 900MHz
Tot mem: 131072 KBytes
CFE mem: 0x00F00000 - 0x01795EF0 (9002736)
Data: 0x00F5E400 - 0x00F5E998 (1432)
BSS: 0x00F5E9A8 - 0x00F93EF0 (218440)
Heap: 0x00F93EF0 - 0x01793EF0 (8388608)
Stack: 0x01793EF0 - 0x01795EF0 (8192)
Text: 0x00F00000 - 0x00F5428C (344716)
Device eth0: hwaddr 70-4D-7B-8E-EB-B0, ipaddr, mask
gateway not set, nameserver not set
Null Rescue Flag.
Hello!! Enter Rescue Mode: (by Force)
Reading ::
Flash Device=flash1.trx
TFTP Server.
..tftp retry wait 0
..tftp retry wait 1
..tftp retry wait 2

router not started. I connect from and upload the firmware with cfe miniweb server, but after that nothing changes.

I don`t save a original dump from my router and now I can't return to original firmware.
does anyone have a dump of the original firmware ?