My TP-Link Archer A7 v5 running OpenWrt 22.03.3 intermittently stops working until I manually reboot it. This happens anywhere from once every few days to a few times a day. The symptoms are that the internet will stop working over Wi-Fi from my laptop, but my Wi-Fi connection will still be stable. When this happens, I can still ping the router at 192.168.1.1 but I can no longer ping Google DNS at 8.8.8.8 or another device on my network at 192.168.1.191. If I connect my laptop to the network with an ethernet cable, I have access to the WAN and LAN again. Once I remove the ethernet cable and go back to Wi-Fi, I lose access to the WAN and LAN. Typically I solve this by opening up the OpenWRT control panel (over W-Fi) and go to System > Reboot, everything starts working again. It's almost like the bridge between the Wi-Fi and the LAN/WAN crashes until I reboot. Any tips or ideas?
Please copy the output of the following commands and post it here using the "Preformatted text </>
" button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have:
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall
I am assuming these config files are static, but in case it matters: I printed them out while everything was working correctly.
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix '<redacted>::/48'
config device
option name 'br-lan'
option type 'bridge'
list ports 'eth0.1'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
config device
option name 'eth0.2'
option macaddr 'ac:84:c6:<redacted>'
config interface 'wan'
option device 'eth0.2'
option proto 'dhcp'
config interface 'wan6'
option device 'eth0.2'
option proto 'dhcpv6'
option reqaddress 'try'
option reqprefix 'auto'
config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'
config switch_vlan
option device 'switch0'
option vlan '1'
option ports '2 3 4 5 0t'
config switch_vlan
option device 'switch0'
option vlan '2'
option ports '1 0t'
config wifi-device 'radio0'
option type 'mac80211'
option path 'pci0000:00/0000:00:00.0'
option channel '36'
option band '5g'
option htmode 'VHT80'
option cell_density '0'
config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid '<redacted>2g'
option encryption 'psk2'
option key '<redacted>'
config wifi-device 'radio1'
option type 'mac80211'
option path 'platform/ahb/18100000.wmac'
option channel '1'
option band '2g'
option htmode 'HT20'
option cell_density '0'
config wifi-iface 'default_radio1'
option device 'radio1'
option network 'lan'
option mode 'ap'
option ssid '<redacted>5g'
option encryption 'psk2'
option key '<redacted>'
config dnsmasq
option domainneeded '1'
option boguspriv '1'
option filterwin2k '0'
option localise_queries '1'
option rebind_protection '1'
option rebind_localhost '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option nonegcache '0'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
option nonwildcard '1'
option localservice '1'
option ednspacket_max '1232'
config dhcp 'lan'
option interface 'lan'
option start '100'
option limit '150'
option leasetime '12h'
option dhcpv4 'server'
option dhcpv6 'server'
option ra 'server'
list ra_flags 'managed-config'
list ra_flags 'other-config'
config dhcp 'wan'
option interface 'wan'
option ignore '1'
config odhcpd 'odhcpd'
option maindhcp '0'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'
option loglevel '4'
config defaults
option syn_flood '1'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'
config zone
option name 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
list network 'lan'
config zone
option name 'wan'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'
list network 'wan'
list network 'wan6'
config forwarding
option src 'lan'
option dest 'wan'
config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'
config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'
config rule
option name 'Allow-IGMP'
option src 'wan'
option proto 'igmp'
option family 'ipv4'
option target 'ACCEPT'
config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-MLD'
option src 'wan'
option proto 'icmp'
option src_ip 'fe80::/10'
list icmp_type '130/0'
list icmp_type '131/0'
list icmp_type '132/0'
list icmp_type '143/0'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-IPSec-ESP'
option src 'wan'
option dest 'lan'
option proto 'esp'
option target 'ACCEPT'
config rule
option name 'Allow-ISAKMP'
option src 'wan'
option dest 'lan'
option dest_port '500'
option proto 'udp'
option target 'ACCEPT'
Your configuration appears to be pretty straightfoward, generally not far from the default state.
Have you installed any packages?
Does the problem affect all devices on wifi, or just your laptop?
You could look into the logs and see if there's some error when you lose network connection on wifi...
Your config seems ok. If there's no error, I'll recommend just flashing with the latest build again and start from scratch with default configs.
I also have A7 v5 and as a rule of thumb, I have set it to restart every morning at 6am automatically...this fixes almost any type of issue if there is any.
Here's my restart cronjob,
01 06 * * * sleep 70 && touch /etc/banner && reboot
Thanks!
- As far as I remember, this is exactly the default configuration.
- I did try to flash with the latest build once, and I'll do it again with the next release.
- This error appears on other wireless devices besides my laptop, including my phone.
I have noticed that I can trigger this consistently now. If I only use wifi, it will work indefinitely. When I plug into the wired connection, and then disconnect, the wifi will stop working within a few minutes.
I will try to add the reboot cronjob and see if that helps.
The reboot does not seem to help. This happens more frequently and consistently than every 24 hours. If I find a solution I will post it. I’m the meantime any other help is appreciated.
In the meantime, is there some way to add a hook so that the router automatically reboots whenever a client disconnects from the wired network?
Maybe not quite what you’re looking for but you can try luci-app-watchcat. It can restart wifi or reboot router if a connection goes down (ie cant ping)
After testing 22.03.5 and having the same issues, I finally went back to the factory firmware. This fixed the issue.
I also learned that my ISP recently upgraded me to 1Gbps download, but OpenWrt had been limiting me to around 500Mbps. The factory firmware provides the full 1Gbps download.
The rabbit hole goes much deeper. It turns out the router still had the same behavior sometimes even without OpenWRT, I just hadn't triggered it yet. So I upgraded to a new router: the AX3000. And now I am seeing the same behavior with the AX3000 intermittently. Which makes me wonder if this is a general TP-Link problem, or if it is something even weirder involving my cable modem.