Thats exactly right. Same thing is happening to me
FYI, I personally added the feature for the 4G Cell ID locking in the proto script and as much as I want to help, I don't want to help someone monetizing a firmware build and highlighting this feature as if it is their own.
I found a solution.
Before applying PCI locking, you need to disconnect the modem from the network:
AT+CFUN=4
Then reconnect it:
AT+CFUN=1
Now, apply the PCI lock:
AT+QNWLOCK="common/4g",1,earfcn,pci
To save the lock and ensure it applies after a reboot, use:
AT+QNWLOCK="save_ctrl",1,1
Reboot router.
My latest NSS build for AW1000 is now up:
Release v1.1.3-beta · xhikarishii/openwrt-ipq
- Latest Stable NSS upstream changes from Qosmio
- Fixes with APN multiplexing support
- Send
AT+CFUN=1
on boot to allow modem to initialize properly - Removed
zerotier
- Added
cpuperf
andcpustats
- Added
CF Zerotrust
- Added wifi features
wifi-schedule
,easymesh
,guest-wifi
- 5G and signal indicator LED changes | 5G-SA -
| 5G-NSA -
| LTE -
| Error -
Hi,I am using your V1.1.3 build. Would it be possible to include the following packages in your next build?
kmod-nft-socket,kmod-nft-tproxy,kmod-nf-tproxy,kmod-nf-socket
Adding them as separate .ipk
packages would be perfectly fine.I know I can build my own firmware or use the official OpenWrt build, but having NSS support on this router is very beneficial. I’ve tried building firmware myself several times, but every attempt results in issues with the modem or internet connectivity. Even when the firmware is successfully created without any issues, something is always broken, or I end up with a bricked router.Two times, I ended up with a bricked router with half-duplex LAN (LAN not working), and I’m not sure what I’m doing wrong..Thankfully, I’ve been able to recover the router using the serial and USB port.
Thank you
Hi @Chmod , you can post an issue on my repo so I can have a look into including them on next release. But this is noted
Hi,
I have built firmware using the latest repository and included quectel, qmi, and all nss_drv packages. After setting up the WAN interface using quectel-cm and the modem, it creates a virtual interface. However, it does not obtain an IP address. To establish an internet connection, I need to create a separate DHCP interface for wwan0_1.
Is there a solution for this issue?
log
Sun Jan 5 00:29:35 2025 user.notice root: [ethtool] Disabling feature: rx-gro-list: disabled on (ip6tnl0)
Sun Jan 5 00:29:35 2025 user.notice root: [ethtool] Disabling feature: rx-gro-list: disabled on (lan1)
Sun Jan 5 00:29:35 2025 user.notice root: [ethtool] Disabling feature: rx-gro-list: disabled on (lan2)
Sun Jan 5 00:29:35 2025 user.notice root: [ethtool] Disabling feature: rx-gro-list: disabled on (lan3)
Sun Jan 5 00:29:35 2025 user.notice root: [ethtool] Disabling feature: rx-gro-list: disabled on (lan4)
Sun Jan 5 00:29:35 2025 user.notice root: [ethtool] Disabling feature: rx-gro-list: disabled on (miireg)
Sun Jan 5 00:29:35 2025 user.notice root: [ethtool] Disabling feature: rx-gro-list: disabled on (sit0)
Sun Jan 5 00:29:35 2025 user.notice root: [ethtool] Disabling feature: rx-gro-list: disabled on (wan)
Sun Jan 5 00:29:35 2025 user.notice root: [ethtool] Disabling feature: rx-gro-list: disabled on (wwan0)
Sun Jan 5 00:29:35 2025 user.notice root: [ethtool] Disabling feature: rx-gro-list: disabled on (wwan0_1)
Sun Jan 5 00:29:35 2025 user.notice root: [ethtool] Disabling feature: rx-gro-list: disabled on (wwan0_2)
Sun Jan 5 00:29:35 2025 daemon.notice procd: /etc/rc.d/S26qca-nss-ecm: net.bridge.bridge-nf-call-arptables = 0
Sun Jan 5 00:29:35 2025 daemon.notice procd: /etc/rc.d/S26qca-nss-ecm: net.bridge.bridge-nf-call-iptables = 0
Sun Jan 5 00:29:35 2025 daemon.notice procd: /etc/rc.d/S26qca-nss-ecm: net.bridge.bridge-nf-call-ip6tables = 0
Sun Jan 5 00:29:35 2025 daemon.notice procd: /etc/rc.d/S26qca-nss-ecm: dev.nss.general.redirect = 1
Sun Jan 5 00:29:35 2025 user.notice root: [ethtool] Disabling feature: rx-gro-list: failed to disable on (SQM_IFB_b6c3d)
Sun Jan 5 00:29:35 2025 user.notice skb_recycler: Enabling skb_recycler
Sun Jan 5 00:29:35 2025 user.notice skb_recycler: Setting max_skbs to 1024
Sun Jan 5 00:29:35 2025 user.notice skb_recycler: Setting max_spare_skbs to 256
Sun Jan 5 00:29:35 2025 user.notice root: [ethtool] Disabling feature: rx-gro-list: failed to disable on (SQM_IFB_dddf6)
Sun Jan 5 00:29:35 2025 user.notice root: [ethtool] Disabling feature: rx-gro-list: failed to disable on (SQM_IFB_bd2f9)
Sun Jan 5 00:29:35 2025 cron.err crond[3466]: crond (busybox 1.36.1) started, log level 5
Sun Jan 5 00:29:35 2025 user.notice root: [ethtool] Disabling feature: rx-gro-list: failed to disable on (SQM_IFB_1908e)
Sun Jan 5 00:29:35 2025 user.notice firewall: Reloading firewall due to ifup of lan (br-lan)
Sun Jan 5 00:29:36 2025 daemon.err nlbwmon[3806]: The netlink receive buffer size of 524288 bytes will be capped to 212992 bytes
Sun Jan 5 00:29:36 2025 daemon.err nlbwmon[3806]: by the kernel. The net.core.rmem_max sysctl limit needs to be raised to
Sun Jan 5 00:29:36 2025 daemon.err nlbwmon[3806]: at least 524288 in order to sucessfully set the desired receive buffer size!
Sun Jan 5 00:29:36 2025 daemon.err collectd[3970]: plugin_load: plugin "cpu" successfully loaded.
Sun Jan 5 00:29:36 2025 daemon.err collectd[3970]: plugin_load: plugin "interface" successfully loaded.
Sun Jan 5 00:29:36 2025 daemon.err collectd[3970]: plugin_load: plugin "iwinfo" successfully loaded.
Sun Jan 5 00:29:36 2025 daemon.err collectd[3970]: plugin_load: plugin "load" successfully loaded.
Sun Jan 5 00:29:36 2025 daemon.err collectd[3970]: plugin_load: plugin "memory" successfully loaded.
Sun Jan 5 00:29:36 2025 daemon.err collectd[3970]: plugin_load: plugin "rrdtool" successfully loaded.
Sun Jan 5 00:29:36 2025 daemon.err collectd[3970]: rrdtool plugin: RRASingle = true: creating only AVERAGE RRAs
Sun Jan 5 00:29:36 2025 daemon.err collectd[3970]: Initialization complete, entering read-loop.
Sun Jan 5 00:29:36 2025 user.notice ucitrack: Setting up /etc/config/luci-splash reload dependency on /etc/config/firewall
Sun Jan 5 00:29:36 2025 user.notice ucitrack: Setting up /etc/config/qos reload dependency on /etc/config/firewall
Sun Jan 5 00:29:36 2025 user.notice ucitrack: Setting up /etc/config/miniupnpd reload dependency on /etc/config/firewall
Sun Jan 5 00:29:36 2025 user.notice nlbwmon: Reloading nlbwmon due to ifup of lan (br-lan)
Sun Jan 5 00:29:36 2025 user.notice ucitrack: Setting up /etc/config/odhcpd reload dependency on /etc/config/dhcp
Sun Jan 5 00:29:36 2025 user.notice ucitrack: Setting up /etc/config/dhcp reload dependency on /etc/config/network
Sun Jan 5 00:29:36 2025 user.notice ucitrack: Setting up /etc/config/network reload dependency on /etc/config/wireless
Sun Jan 5 00:29:36 2025 user.notice ucitrack: Setting up non-init /etc/config/fstab reload handler: /sbin/block mount
Sun Jan 5 00:29:36 2025 user.notice ucitrack: Setting up /etc/config/system reload trigger for non-procd /etc/init.d/led
Sun Jan 5 00:29:36 2025 user.notice ucitrack: Setting up /etc/config/luci_statistics reload dependency on /etc/config/system
Sun Jan 5 00:29:36 2025 user.notice ucitrack: Setting up /etc/config/dhcp reload dependency on /etc/config/system
Sun Jan 5 00:29:36 2025 user.notice nlbwmon: Reloading nlbwmon due to ifup of loopback (lo)
Sun Jan 5 00:29:36 2025 user.notice smp_affinity: Pinning IRQ(80) ppdu-end-interrupts-mac1 to CPU 1
Sun Jan 5 00:29:36 2025 user.notice smp_affinity: Pinning IRQ(84) ppdu-end-interrupts-mac2 to CPU 2
Sun Jan 5 00:29:36 2025 user.notice smp_affinity: Pinning IRQ(82) ppdu-end-interrupts-mac3 to CPU 3
Sun Jan 5 00:29:36 2025 user.notice smp_affinity: Pinning IRQ(36) edma_txcmpl to CPU 3
Sun Jan 5 00:29:36 2025 user.notice smp_affinity: Pinning IRQ(37) edma_rxfill to CPU 3
Sun Jan 5 00:29:36 2025 user.notice smp_affinity: Pinning IRQ(38) edma_rxdesc to CPU 3
Sun Jan 5 00:29:36 2025 user.notice smp_affinity: Pinning IRQ(39) edma_misc to CPU 3
Sun Jan 5 00:29:37 2025 user.notice qca-nss-drv: Pinning IRQ(47) nss_queue0 to CPU 0-3 (NSS Core 0)
Sun Jan 5 00:29:37 2025 user.notice qca-nss-drv: Pinning IRQ(48) nss_queue1 to CPU 1 (NSS Core 0)
Sun Jan 5 00:29:37 2025 user.notice qca-nss-drv: Pinning IRQ(49) nss_queue2 to CPU 2 (NSS Core 0)
Sun Jan 5 00:29:37 2025 user.notice qca-nss-drv: Pinning IRQ(50) nss_queue3 to CPU 3 (NSS Core 0)
Sun Jan 5 00:29:37 2025 user.notice qca-nss-drv: Pinning IRQ(58) nss_queue0 to CPU 3 (NSS Core 1)
Sun Jan 5 00:29:37 2025 user.notice qca-nss-drv: Pinning IRQ(44) nss_empty_buf_sos to CPU 1-3 (NSS Core 0)
Sun Jan 5 00:29:37 2025 user.notice qca-nss-drv: Pinning IRQ(45) nss_empty_buf_queue to CPU 2,3 (NSS Core 0)
Sun Jan 5 00:29:37 2025 user.notice qca-nss-drv: Pinning IRQ(55) nss_empty_buf_sos to CPU 3 (NSS Core 1)
Sun Jan 5 00:29:37 2025 user.notice qca-nss-drv: Pinning IRQ(42) xhci-hcd:usb1 to CPU 1,3
Sun Jan 5 00:29:37 2025 user.notice qca-nss-drv: Pinning IRQ(80) ppdu-end-interrupts-mac1 to CPU 1
Sun Jan 5 00:29:37 2025 user.notice qca-nss-drv: Pinning IRQ(82) ppdu-end-interrupts-mac3 to CPU 2
Sun Jan 5 00:29:37 2025 user.notice qca-nss-pbuf: Setting CPU scaling governor to 'performance'
Sun Jan 5 00:29:37 2025 user.notice qca-nss-pbuf: Disabling ath11k stats
Sun Jan 5 00:29:37 2025 user.notice qca-nss-pbuf: Setting n2hcfg values for board: arcadyan,aw1000
Sun Jan 5 00:29:37 2025 user.notice qca-nss-pbuf: arcadyan,aw1000 - setting dev.nss.n2hcfg.extra_pbuf_core0=10000000
Sun Jan 5 00:29:37 2025 kern.info kernel: [ 24.677689] qca-nss 39000000.nss: Configuring additional NSS pbufs
Sun Jan 5 00:29:37 2025 user.notice qca-nss-pbuf: arcadyan,aw1000 - setting dev.nss.n2hcfg.n2h_wifi_pool_buf=36864
Sun Jan 5 00:29:37 2025 kern.info kernel: [ 24.707431] qca-nss 39000000.nss: Additional pbufs of size 10002432 got added to NSS
Sun Jan 5 00:29:37 2025 user.notice qca-nss-pbuf: arcadyan,aw1000 - setting dev.nss.n2hcfg.n2h_high_water_core0=72512
Sun Jan 5 00:29:37 2025 daemon.notice procd: /etc/rc.d/S95qca-nss-pbuf: 'radio0' is disabled
Sun Jan 5 00:29:37 2025 daemon.notice procd: /etc/rc.d/S95qca-nss-pbuf: 'radio1' is disabled
Sun Jan 5 00:29:37 2025 daemon.notice procd: /etc/rc.d/S95qca-nss-pbuf: 'radio0' is disabled
Sun Jan 5 00:29:37 2025 daemon.notice procd: /etc/rc.d/S95qca-nss-pbuf: 'radio1' is disabled
Sun Jan 5 00:29:37 2025 daemon.notice procd: /etc/rc.d/S96led: setting up led 5G
Sun Jan 5 00:29:37 2025 daemon.notice procd: /etc/rc.d/S96led: setting up led WAN
Sun Jan 5 00:29:37 2025 daemon.notice procd: /etc/rc.d/S96led: setting up led WAN-PORT-LINK
Sun Jan 5 00:29:37 2025 daemon.info procd: - init complete -
Sun Jan 5 00:29:38 2025 kern.info kernel: [ 25.525726] nss-dp 3a001000.dp1 lan1: PHY Link up speed: 1000
Sun Jan 5 00:29:38 2025 kern.info kernel: [ 25.525868] br-lan: port 1(lan1) entered blocking state
Sun Jan 5 00:29:38 2025 kern.info kernel: [ 25.530463] br-lan: port 1(lan1) entered forwarding state
Sun Jan 5 00:29:38 2025 daemon.notice netifd: Network device 'lan1' link is up
Sun Jan 5 00:29:38 2025 daemon.notice netifd: bridge 'br-lan' link is up
Sun Jan 5 00:29:38 2025 daemon.notice netifd: Interface 'lan' has link connectivity
Sun Jan 5 00:29:38 2025 daemon.err odhcpd[3281]: Failed to send to fe80::4ec6:4cff:fe2f:fb2e%lan@br-lan (Address not available)
Sun Jan 5 00:29:38 2025 daemon.info dnsmasq[1]: read /etc/hosts - 12 names
Sun Jan 5 00:29:38 2025 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 0 names
Sun Jan 5 00:29:38 2025 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c.3870 - 0 names
Sun Jan 5 00:29:38 2025 daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 0 names
Sun Jan 5 00:29:39 2025 daemon.info dnsmasq[1]: exiting on receipt of SIGTERM
Sun Jan 5 00:29:39 2025 daemon.err procd: Got unexpected signal 1
Sun Jan 5 00:29:39 2025 daemon.info dnsmasq[1]: started, version 2.90 cachesize 1000
Sun Jan 5 00:29:39 2025 daemon.info dnsmasq[1]: DNS service limited to local subnets
Sun Jan 5 00:29:39 2025 daemon.info dnsmasq[1]: compile time options: IPv6 GNU-getopt no-DBus UBus no-i18n no-IDN DHCP DHCPv6 no-Lua TFTP conntrack no-ipset nftset auth cryptohash DNSSEC no-ID loop-detect inotify dumpfile
Sun Jan 5 00:29:39 2025 daemon.info dnsmasq[1]: UBus support enabled: connected to system bus
Sun Jan 5 00:29:39 2025 daemon.info dnsmasq-dhcp[1]: DHCP, IP range 192.168.1.100 -- 192.168.1.249, lease time 12h
Sun Jan 5 00:29:39 2025 daemon.info dnsmasq[1]: using only locally-known addresses for test
Sun Jan 5 00:29:39 2025 daemon.info dnsmasq[1]: using only locally-known addresses for onion
Sun Jan 5 00:29:39 2025 daemon.info dnsmasq[1]: using only locally-known addresses for localhost
Sun Jan 5 00:29:39 2025 daemon.info dnsmasq[1]: using only locally-known addresses for local
Sun Jan 5 00:29:39 2025 daemon.info dnsmasq[1]: using only locally-known addresses for invalid
Sun Jan 5 00:29:39 2025 daemon.info dnsmasq[1]: using only locally-known addresses for bind
Sun Jan 5 00:29:39 2025 daemon.info dnsmasq[1]: using only locally-known addresses for lan
Sun Jan 5 00:29:39 2025 daemon.warn dnsmasq[1]: no servers found in /tmp/resolv.conf.d/resolv.conf.auto, will retry
Sun Jan 5 00:29:39 2025 daemon.info dnsmasq[1]: read /etc/hosts - 12 names
Sun Jan 5 00:29:39 2025 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 4 names
Sun Jan 5 00:29:39 2025 daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 0 names
Sun Jan 5 00:29:39 2025 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Sun Jan 5 00:29:40 2025 daemon.notice netifd: 5g (2991): ./quectel.sh: eval: line 70: atinout: not found
Sun Jan 5 00:29:40 2025 daemon.notice netifd: 5g (2991): [01-05_00:29:40:188] Will use cdc-wdm='/dev/cdc-wdm0', proxy='quectel-qmi-proxy0'
Sun Jan 5 00:29:40 2025 daemon.info dnsmasq[1]: read /etc/hosts - 12 names
Sun Jan 5 00:29:40 2025 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 4 names
Sun Jan 5 00:29:40 2025 daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 0 names
Sun Jan 5 00:29:40 2025 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Sun Jan 5 00:29:40 2025 daemon.info dnsmasq[1]: read /etc/hosts - 12 names
Sun Jan 5 00:29:40 2025 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 4 names
Sun Jan 5 00:29:40 2025 daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 2 names
Sun Jan 5 00:29:40 2025 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Sun Jan 5 00:29:41 2025 daemon.warn odhcpd[3281]: No default route present, overriding ra_lifetime to 0!
Sun Jan 5 00:29:43 2025 daemon.notice netifd: 5g (2991): [01-05_00:29:43:195] QConnectManager_Linux_V1.6.5
Sun Jan 5 00:29:43 2025 daemon.notice netifd: 5g (2991): [01-05_00:29:43:196] Find /sys/bus/usb/devices/4-1 idVendor=0x2c7c idProduct=0x800, bus=0x004, dev=0x002
Sun Jan 5 00:29:43 2025 daemon.notice netifd: 5g (2991): [01-05_00:29:43:196] Auto find qmichannel = /dev/cdc-wdm0
Sun Jan 5 00:29:43 2025 daemon.notice netifd: 5g (2991): [01-05_00:29:43:196] Auto find usbnet_adapter = wwan0
Sun Jan 5 00:29:43 2025 daemon.notice netifd: 5g (2991): [01-05_00:29:43:196] netcard driver = qmi_wwan_q, driver version = V1.2.6
Sun Jan 5 00:29:43 2025 daemon.notice netifd: 5g (2991): [01-05_00:29:43:196] qmap_mode = 2, qmap_version = 9, qmap_size = 31744, muxid = 0x81, qmap_netcard = wwan0_1
Sun Jan 5 00:29:43 2025 daemon.notice netifd: 5g (2991): [01-05_00:29:43:196] Modem works in QMI mode
Sun Jan 5 00:29:43 2025 daemon.notice netifd: 5g (2991): [01-05_00:29:43:196] connect to quectel-qmi-proxy0 sockfd = 7
Sun Jan 5 00:29:43 2025 daemon.notice netifd: 5g (2991): [01-05_00:29:43:197] cdc_wdm_fd = 7
Sun Jan 5 00:29:43 2025 daemon.notice netifd: 5g (2991): [01-05_00:29:43:233] Get clientWDS = 14
Sun Jan 5 00:29:43 2025 daemon.notice netifd: 5g (2991): [01-05_00:29:43:265] Get clientWDS = 15
Sun Jan 5 00:29:43 2025 daemon.notice netifd: 5g (2991): [01-05_00:29:43:297] Get clientDMS = 1
Sun Jan 5 00:29:43 2025 daemon.notice netifd: 5g (2991): [01-05_00:29:43:329] Get clientNAS = 4
Sun Jan 5 00:29:43 2025 daemon.notice netifd: 5g (2991): [01-05_00:29:43:361] Get clientUIM = 1
Sun Jan 5 00:29:43 2025 daemon.notice netifd: 5g (2991): [01-05_00:29:43:393] Get clientWDA = 1
Sun Jan 5 00:29:43 2025 daemon.notice netifd: 5g (2991): [01-05_00:29:43:425] requestBaseBandVersion RG500QEAAAR13A01M4G
Sun Jan 5 00:29:43 2025 daemon.notice netifd: 5g (2991): [01-05_00:29:43:457] qmap_settings.rx_urb_size = 31744
Sun Jan 5 00:29:43 2025 daemon.notice netifd: 5g (2991): [01-05_00:29:43:457] qmap_settings.ul_data_aggregation_max_datagrams = 11
Sun Jan 5 00:29:43 2025 daemon.notice netifd: 5g (2991): [01-05_00:29:43:457] qmap_settings.ul_data_aggregation_max_size = 4096
Sun Jan 5 00:29:43 2025 daemon.notice netifd: 5g (2991): [01-05_00:29:43:457] qmap_settings.dl_minimum_padding = 0
Sun Jan 5 00:29:43 2025 kern.info kernel: [ 30.834362] net wwan0: ul_data_aggregation_max_datagrams=11, ul_data_aggregation_max_size=4096, dl_minimum_padding=0
Sun Jan 5 00:29:43 2025 daemon.notice netifd: 5g (2991): [01-05_00:29:43:649] requestGetSIMStatus SIMStatus: SIM_READY
Sun Jan 5 00:29:43 2025 daemon.notice netifd: 5g (2991): [01-05_00:29:43:713] requestGetProfile[pdp:1 index:1] internet///0/IPV4V6
Sun Jan 5 00:29:43 2025 daemon.notice netifd: 5g (2991): [01-05_00:29:43:713] requestSetProfile[pdp:1 index:1] internet///0/IPV4V6
Sun Jan 5 00:29:43 2025 daemon.notice netifd: 5g (2991): [01-05_00:29:43:713] no need to set skip the rest
Sun Jan 5 00:29:43 2025 daemon.notice netifd: 5g (2991): [01-05_00:29:43:745] requestRegistrationState2 MCC: 413, MNC: 2, PS: Attached, DataCap: LTE
Sun Jan 5 00:29:43 2025 daemon.notice netifd: 5g (2991): [01-05_00:29:43:777] requestQueryDataCall IPv4ConnectionStatus: DISCONNECTED
Sun Jan 5 00:29:43 2025 daemon.notice netifd: 5g (2991): [01-05_00:29:43:809] requestQueryDataCall IPv6ConnectionStatus: DISCONNECTED
Sun Jan 5 00:29:43 2025 daemon.notice netifd: 5g (2991): [01-05_00:29:43:809] ip link set dev wwan0 down
Sun Jan 5 00:29:43 2025 daemon.notice netifd: 5g (2991): [01-05_00:29:43:811] ip addr flush dev wwan0_1
Sun Jan 5 00:29:43 2025 daemon.notice netifd: 5g (2991): [01-05_00:29:43:814] ip link set dev wwan0_1 down
Sun Jan 5 00:29:43 2025 daemon.notice netifd: 5g (2991): [01-05_00:29:43:841] requestSetupDataCall WdsConnectionIPv4Handle: 0x40dd7eb0
Sun Jan 5 00:29:43 2025 daemon.notice netifd: 5g (2991): [01-05_00:29:43:937] requestSetupDataCall QMUXResult = 0x1, QMUXError = 0xe
Sun Jan 5 00:29:43 2025 daemon.notice netifd: 5g (2991): [01-05_00:29:43:937] call_end_reason is 1
Sun Jan 5 00:29:43 2025 daemon.notice netifd: 5g (2991): [01-05_00:29:43:937] call_end_reason_type is 2
Sun Jan 5 00:29:43 2025 daemon.notice netifd: 5g (2991): [01-05_00:29:43:937] call_end_reason_verbose is 210
Sun Jan 5 00:29:43 2025 daemon.notice netifd: 5g (2991): [01-05_00:29:43:937] try to requestSetupDataCall 5 second later
Sun Jan 5 00:29:44 2025 daemon.notice netifd: 5g (2991): [01-05_00:29:44:001] ip link set dev wwan0 up
Sun Jan 5 00:29:44 2025 daemon.notice netifd: 5g (2991): [01-05_00:29:44:004] ip link set dev wwan0_1 up
Sun Jan 5 00:29:44 2025 kern.info kernel: [ 31.378283] net wwan0: link_state 0x0 -> 0x1
Sun Jan 5 00:29:44 2025 daemon.notice netifd: 5g (2991): [01-05_00:29:44:013] busybox udhcpc -f -n -q -t 5 -i wwan0_1
Sun Jan 5 00:29:44 2025 daemon.notice netifd: 5g (2991): udhcpc: started, v1.36.1
Sun Jan 5 00:29:44 2025 daemon.notice netifd: 5g (2991): udhcpc: broadcasting discover
Sun Jan 5 00:29:44 2025 daemon.notice netifd: 5g (2991): udhcpc: broadcasting select for 10.108.130.129, server 10.108.130.130
Sun Jan 5 00:29:44 2025 daemon.notice netifd: 5g (2991): udhcpc: lease of 10.108.130.129 obtained from 10.108.130.130, lease time 7200
Sun Jan 5 00:29:44 2025 daemon.notice netifd: 5g (2991): [01-05_00:29:44:430] udhcpc: ip addr add 10.108.130.129/255.255.255.252 broadcast + dev wwan0_1
Sun Jan 5 00:29:44 2025 daemon.notice netifd: 5g (2991): [01-05_00:29:44:432] udhcpc: setting default routers: 10.108.130.130
Sun Jan 5 00:29:44 2025 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan) 4c:c6:4c:2f:fb:2e
Sun Jan 5 00:29:44 2025 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan) 192.168.1.124 4c:c6:4c:2f:fb:2e
Sun Jan 5 00:29:44 2025 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan) 4c:c6:4c:2f:fb:2e
Sun Jan 5 00:29:44 2025 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan) 192.168.1.124 4c:c6:4c:2f:fb:2e
Sun Jan 5 00:29:44 2025 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan) 192.168.1.124 4c:c6:4c:2f:fb:2e
Sun Jan 5 00:29:44 2025 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan) 192.168.1.124 4c:c6:4c:2f:fb:2e XIAOMI_AX6000
Sun Jan 5 00:29:45 2025 kern.info kernel: [ 32.485654] l11: disabling
Sun Jan 5 00:29:45 2025 daemon.notice netifd: 5g (2991): [01-05_00:29:45:473] requestSetupDataCall QMUXResult = 0x1, QMUXError = 0xe
Sun Jan 5 00:29:45 2025 daemon.notice netifd: 5g (2991): [01-05_00:29:45:473] call_end_reason is 1
Sun Jan 5 00:29:45 2025 daemon.notice netifd: 5g (2991): [01-05_00:29:45:473] call_end_reason_type is 2
Sun Jan 5 00:29:45 2025 daemon.notice netifd: 5g (2991): [01-05_00:29:45:473] call_end_reason_verbose is 210
Sun Jan 5 00:29:45 2025 daemon.notice netifd: 5g (2991): [01-05_00:29:45:473] try to requestSetupDataCall 10 second later
Sun Jan 5 00:29:45 2025 daemon.warn odhcpd[3281]: No default route present, overriding ra_lifetime to 0!
Sun Jan 5 00:29:47 2025 daemon.err uhttpd[3694]: [info] luci: accepted login on /admin/system/reboot for root from 192.168.1.124
Sun Jan 5 00:29:48 2025 daemon.notice netifd: 5g (2991): Setting up wwan0
Sun Jan 5 00:29:48 2025 daemon.notice netifd: Interface '5g' is now up
Sun Jan 5 00:29:48 2025 daemon.notice netifd: Network device 'wwan0' link is up
Sun Jan 5 00:29:48 2025 daemon.notice netifd: Interface '5g_6' is enabled
Sun Jan 5 00:29:48 2025 daemon.notice netifd: Interface '5g_6' has link connectivity
Sun Jan 5 00:29:48 2025 daemon.notice netifd: Interface '5g_6' is setting up now
Sun Jan 5 00:29:48 2025 daemon.notice netifd: Interface '5g_4' is enabled
Sun Jan 5 00:29:48 2025 daemon.notice netifd: Interface '5g_4' has link connectivity
Sun Jan 5 00:29:48 2025 daemon.notice netifd: Interface '5g_4' is setting up now
Sun Jan 5 00:29:48 2025 daemon.notice netifd: 5g_4 (5769): udhcpc: started, v1.36.1
Sun Jan 5 00:29:48 2025 daemon.err odhcp6c[5763]: Failed to send RS (Address not available)
Sun Jan 5 00:29:48 2025 daemon.notice netifd: 5g_4 (5769): udhcpc: broadcasting discover
Sun Jan 5 00:29:48 2025 user.notice firewall: Reloading firewall due to ifup of 5g (wwan0)
Sun Jan 5 00:29:48 2025 daemon.err odhcp6c[5763]: Failed to send SOLICIT message to ff02::1:2 (Address not available)
Sun Jan 5 00:29:48 2025 user.notice nlbwmon: Reloading nlbwmon due to ifup of 5g (wwan0)
Sun Jan 5 00:29:49 2025 daemon.warn odhcpd[3281]: No default route present, overriding ra_lifetime to 0!
Sun Jan 5 00:29:49 2025 daemon.err odhcp6c[5763]: Failed to send SOLICIT message to ff02::1:2 (Address not available)
Sun Jan 5 00:29:49 2025 daemon.warn odhcpd[3281]: No default route present, overriding ra_lifetime to 0!
Sun Jan 5 00:29:51 2025 daemon.notice netifd: 5g_4 (5769): udhcpc: broadcasting discover
Sun Jan 5 00:29:51 2025 daemon.err odhcp6c[5763]: Failed to send SOLICIT message to ff02::1:2 (Address not available)
Sun Jan 5 00:29:52 2025 daemon.err odhcp6c[5763]: Failed to send RS (Address not available)
Sun Jan 5 00:29:54 2025 daemon.notice netifd: 5g_4 (5769): udhcpc: broadcasting discover
Sun Jan 5 00:29:55 2025 daemon.err odhcp6c[5763]: Failed to send SOLICIT message to ff02::1:2 (Address not available)
Sun Jan 5 00:29:56 2025 daemon.err odhcp6c[5763]: Failed to send RS (Address not available)
Sun Jan 5 00:30:00 2025 daemon.err odhcp6c[5763]: Failed to send RS (Address not available)
Sun Jan 5 00:30:03 2025 daemon.err odhcp6c[5763]: Failed to send SOLICIT message to ff02::1:2 (Address not available)
Sun Jan 5 00:30:20 2025 daemon.err odhcp6c[5763]: Failed to send SOLICIT message to ff02::1:2 (Address not available)
Sun Jan 5 00:30:20 2025 daemon.notice netifd: 5g (6080): Stopping network 5g
Sun Jan 5 00:30:20 2025 daemon.notice netifd: 5g (6080): Command failed: ubus call network.interface notify_proto { "action": 0, "link-up": false, "keep": false, "interface": "5g" } (Permission denied)
Sun Jan 5 00:30:20 2025 daemon.notice netifd: Interface '5g' is now down
Sun Jan 5 00:30:20 2025 kern.info kernel: [ 68.255090] net wwan0: link_state 0x1 -> 0x0
Sun Jan 5 00:30:20 2025 daemon.err odhcp6c[5763]: Failed to send RS (Address not available)
Sun Jan 5 00:30:20 2025 daemon.notice netifd: Interface '5g' is setting up now
Sun Jan 5 00:30:20 2025 daemon.notice netifd: Network device 'wwan0' link is down
Sun Jan 5 00:30:20 2025 daemon.notice netifd: Interface '5g_6' has link connectivity loss
Sun Jan 5 00:30:20 2025 daemon.notice netifd: Interface '5g_4' has link connectivity loss
Sun Jan 5 00:30:20 2025 daemon.notice netifd: 5g_4 (5769): udhcpc: read error: Network is down, reopening socket
Sun Jan 5 00:30:21 2025 daemon.notice netifd: 5g_4 (5769): udhcpc: received SIGTERM
Sun Jan 5 00:30:21 2025 daemon.notice netifd: 5g_4 (5769): udhcpc: entering released state
Sun Jan 5 00:30:21 2025 daemon.notice netifd: 5g_4 (5769): Command failed: ubus call network.interface notify_proto { "action": 0, "link-up": false, "keep": false, "interface": "5g_4" } (Permission denied)
Sun Jan 5 00:30:21 2025 daemon.notice netifd: Interface '5g_4' is now down
Sun Jan 5 00:30:21 2025 daemon.err odhcp6c[5763]: Failed to send SOLICIT message to ff02::1:2 (Network unreachable)
Sun Jan 5 00:30:21 2025 daemon.notice netifd: Interface '5g_6' is now down
Sun Jan 5 00:30:21 2025 daemon.notice netifd: Interface '5g_6' is disabled
Sun Jan 5 00:30:22 2025 daemon.info dnsmasq[1]: read /etc/hosts - 12 names
Sun Jan 5 00:30:22 2025 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 4 names
Sun Jan 5 00:30:22 2025 daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 2 names
Sun Jan 5 00:30:22 2025 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Sun Jan 5 00:30:23 2025 daemon.warn odhcpd[3281]: No default route present, overriding ra_lifetime to 0!
Sun Jan 5 00:30:25 2025 daemon.notice netifd: 5g (6102): ./quectel.sh: eval: line 70: atinout: not found
Sun Jan 5 00:30:25 2025 daemon.notice netifd: 5g (6102): [01-05_00:30:25:912] Will use cdc-wdm='/dev/cdc-wdm0', proxy='quectel-qmi-proxy0'
Sun Jan 5 00:30:28 2025 daemon.notice netifd: 5g (6102): [01-05_00:30:28:914] QConnectManager_Linux_V1.6.5
Sun Jan 5 00:30:28 2025 daemon.notice netifd: 5g (6102): [01-05_00:30:28:914] Find /sys/bus/usb/devices/4-1 idVendor=0x2c7c idProduct=0x800, bus=0x004, dev=0x002
Sun Jan 5 00:30:28 2025 daemon.notice netifd: 5g (6102): [01-05_00:30:28:915] Auto find qmichannel = /dev/cdc-wdm0
Sun Jan 5 00:30:28 2025 daemon.notice netifd: 5g (6102): [01-05_00:30:28:915] Auto find usbnet_adapter = wwan0
Sun Jan 5 00:30:28 2025 daemon.notice netifd: 5g (6102): [01-05_00:30:28:915] netcard driver = qmi_wwan_q, driver version = V1.2.6
Sun Jan 5 00:30:28 2025 daemon.notice netifd: 5g (6102): [01-05_00:30:28:915] qmap_mode = 2, qmap_version = 9, qmap_size = 31744, muxid = 0x81, qmap_netcard = wwan0_1
Sun Jan 5 00:30:28 2025 daemon.notice netifd: 5g (6102): [01-05_00:30:28:915] Modem works in QMI mode
Sun Jan 5 00:30:28 2025 daemon.notice netifd: 5g (6102): [01-05_00:30:28:915] connect to quectel-qmi-proxy0 sockfd = 7
Sun Jan 5 00:30:28 2025 daemon.notice netifd: 5g (6102): [01-05_00:30:28:915] cdc_wdm_fd = 7
Sun Jan 5 00:30:28 2025 daemon.notice netifd: 5g (6102): [01-05_00:30:28:962] Get clientWDS = 14
Sun Jan 5 00:30:28 2025 daemon.notice netifd: 5g (6102): [01-05_00:30:28:994] Get clientDMS = 1
Sun Jan 5 00:30:29 2025 daemon.notice netifd: 5g (6102): [01-05_00:30:29:026] Get clientNAS = 4
Sun Jan 5 00:30:29 2025 daemon.notice netifd: 5g (6102): [01-05_00:30:29:058] Get clientUIM = 1
Sun Jan 5 00:30:29 2025 daemon.notice netifd: 5g (6102): [01-05_00:30:29:090] Get clientWDA = 1
Sun Jan 5 00:30:29 2025 daemon.notice netifd: 5g (6102): [01-05_00:30:29:122] requestBaseBandVersion RG500QEAAAR13A01M4G
Sun Jan 5 00:30:29 2025 daemon.notice netifd: 5g (6102): [01-05_00:30:29:154] qmap_settings.rx_urb_size = 31744
Sun Jan 5 00:30:29 2025 daemon.notice netifd: 5g (6102): [01-05_00:30:29:154] qmap_settings.ul_data_aggregation_max_datagrams = 11
Sun Jan 5 00:30:29 2025 daemon.notice netifd: 5g (6102): [01-05_00:30:29:154] qmap_settings.ul_data_aggregation_max_size = 4096
Sun Jan 5 00:30:29 2025 daemon.notice netifd: 5g (6102): [01-05_00:30:29:154] qmap_settings.dl_minimum_padding = 0
Sun Jan 5 00:30:29 2025 daemon.notice netifd: 5g (6102): [01-05_00:30:29:281] requestGetSIMStatus SIMStatus: SIM_READY
Sun Jan 5 00:30:29 2025 daemon.notice netifd: 5g (6102): [01-05_00:30:29:346] requestGetProfile[pdp:1 index:1] internet///0/IPV4V6
Sun Jan 5 00:30:29 2025 daemon.notice netifd: 5g (6102): [01-05_00:30:29:346] requestSetProfile[pdp:1 index:1] internet///0/IPV4
Sun Jan 5 00:30:29 2025 daemon.notice netifd: 5g (6102): [01-05_00:30:29:410] requestRegistrationState2 MCC: 413, MNC: 2, PS: Attached, DataCap: LTE
Sun Jan 5 00:30:29 2025 daemon.notice netifd: 5g (6102): [01-05_00:30:29:442] requestQueryDataCall IPv4ConnectionStatus: DISCONNECTED
Sun Jan 5 00:30:29 2025 daemon.notice netifd: 5g (6102): [01-05_00:30:29:442] ip link set dev wwan0 down
Sun Jan 5 00:30:29 2025 daemon.notice netifd: 5g (6102): [01-05_00:30:29:445] ip addr flush dev wwan0_1
Sun Jan 5 00:30:29 2025 daemon.notice netifd: 5g (6102): [01-05_00:30:29:447] ip link set dev wwan0_1 down
Sun Jan 5 00:30:29 2025 daemon.notice netifd: 5g (6102): [01-05_00:30:29:474] requestSetupDataCall WdsConnectionIPv4Handle: 0x41816e90
Sun Jan 5 00:30:29 2025 daemon.notice netifd: 5g (6102): [01-05_00:30:29:602] ip link set dev wwan0 up
Sun Jan 5 00:30:29 2025 daemon.notice netifd: 5g (6102): [01-05_00:30:29:605] ip link set dev wwan0_1 up
Sun Jan 5 00:30:29 2025 kern.info kernel: [ 76.979478] net wwan0: link_state 0x0 -> 0x1
Sun Jan 5 00:30:29 2025 daemon.notice netifd: 5g (6102): [01-05_00:30:29:609] busybox udhcpc -f -n -q -t 5 -i wwan0_1
Sun Jan 5 00:30:29 2025 daemon.notice netifd: 5g (6102): udhcpc: started, v1.36.1
Sun Jan 5 00:30:29 2025 daemon.notice netifd: 5g (6102): udhcpc: broadcasting discover
Sun Jan 5 00:30:29 2025 daemon.notice netifd: 5g (6102): udhcpc: broadcasting select for 10.108.130.129, server 10.108.130.130
Sun Jan 5 00:30:29 2025 daemon.notice netifd: 5g (6102): udhcpc: lease of 10.108.130.129 obtained from 10.108.130.130, lease time 7200
Sun Jan 5 00:30:29 2025 daemon.notice netifd: 5g (6102): [01-05_00:30:29:970] udhcpc: ip addr add 10.108.130.129/255.255.255.252 broadcast + dev wwan0_1
Sun Jan 5 00:30:29 2025 daemon.notice netifd: 5g (6102): [01-05_00:30:29:972] udhcpc: setting default routers: 10.108.130.130
Sun Jan 5 00:30:33 2025 daemon.notice netifd: 5g (6102): Setting up wwan0
Sun Jan 5 00:30:33 2025 daemon.notice netifd: Interface '5g' is now up
Sun Jan 5 00:30:33 2025 daemon.notice netifd: Network device 'wwan0' link is up
Sun Jan 5 00:30:33 2025 daemon.notice netifd: Interface '5g_4' is enabled
Sun Jan 5 00:30:33 2025 daemon.notice netifd: Interface '5g_4' has link connectivity
Sun Jan 5 00:30:33 2025 daemon.notice netifd: Interface '5g_4' is setting up now
Sun Jan 5 00:30:33 2025 daemon.notice netifd: 5g_4 (6574): udhcpc: started, v1.36.1
Sun Jan 5 00:30:34 2025 daemon.notice netifd: 5g_4 (6574): udhcpc: broadcasting discover
Sun Jan 5 00:30:34 2025 user.notice firewall: Reloading firewall due to ifup of 5g (wwan0)
Sun Jan 5 00:30:34 2025 user.notice nlbwmon: Reloading nlbwmon due to ifup of 5g (wwan0)
Sun Jan 5 00:30:34 2025 daemon.warn odhcpd[3281]: No default route present, overriding ra_lifetime to 0!
Sun Jan 5 00:30:37 2025 daemon.notice netifd: 5g_4 (6574): udhcpc: broadcasting discover
Sun Jan 5 00:30:40 2025 daemon.notice netifd: 5g_4 (6574): udhcpc: broadcasting discover
The build of v1.1.3-beta is a solid stable compared to v1.1.2-beta which was insanely blazing fast, the only issue that I once did encounter on v1.1.3-beta build was the Wi-Fi goes off on both bands and the only solution I tried was to restart the modem to get the Wi-Fi back on. I thought it because of 160MHz on 5GHz is the reason and since I'd no backup Wi-Fi I revert back to 80MHz but now for over 4 days I switched back to 160 to check if it was the real reason. I personally don't expect an official build of official OpenWrt that can achieve stability more than this build does. The only enhancement could be for this build is more compiled packages availability then it would be more than we do ask for. Much appreciation for xHikari and the rest of developers who made this build possible.
Greetings, community. I'm new to OpenWRT and 5G modems.
After flashing the latest @xHikari v1.1.3b build, I'm encountering a JSON error when attempting to access the 3Ginfo section.
I've tried modifying the 3ginfo settings from option device '/dev/ttyUSB2'
to option device '/dev/cdc-wdm0'
, but the issue persists.
It seems I might be missing a configuration step.
Here are my configuration files:
network
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.255.0.0'
config globals 'globals'
option ula_prefix 'fd26:aaef:2b33::/48'
config device
option name 'br-lan'
option type 'bridge'
option ports 'lan1 lan2 lan3 lan4 wan'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.88.1'
option netmask '255.255.255.0'
option ip6assign '60'
config interface 'wan'
option device 'wwan0_1'
option proto 'dhcp'
option metric '1'
config interface 'wan6'
option device 'wwan0_1'
option proto 'dhcpv6'
option metric '1'
config interface '5g'
option proto 'quectel'
option device '/dev/cdc-wdm0'
option apn 'internet'
option auth 'none'
option pdptype 'ipv4v6'
option delay '15'
option metric '1'
3ginfo
config 3ginfo
option website 'https://www.cellmapper.net/enbid?cellid='
option network 'wan'
option device '/dev/ttyUSB2'
hello, I use it and perfect in the 5G interface Do you have the APN of your ISP on?
I finally got it working!
The problem was with the Quectel RG500Q-EA modem's firmware. My initial version, RG500QEAAAR11A06M4G, was likely outdated. I downloaded RG500QEAAAR13A01M4G from https://github.com/4IceG/RG500Q-EA. Using a pre-built binary of qfirehose, extracted from this image: http://aturnofthenut.com/autobuilds/Arcadyan-AW1000-GO2024-06-19-AB_1800.zip, I successfully upgraded the modem's firmware.
My latest build for AW1000 is now up!
What's New
-
ROOter features including:
- APN Profile Management
- Automatic APN
- Connection Monitoring (with router or modem reboot)
- Custom TTL Mangling (for hotspot)
- 4G/5G Signal Stats
- Bandwidth Reporting and Monitoring
- SMS Function
- Sending AT Commands
- Band and Cell Locking
- Modem Debugging
-
NSS Updates and fixes from Qosmio's upstream. Commit: 833dee3
-
LED Changes, added
sim error
andconnecting
status on signal LED indicator. -
MWAN3 Support (Set to WAN to WWAN failover by default).
-
OpenVPN Server Support.
hola, va a haber más actualizaciones o la nueva es la de rooter?
In English please.
But yes, going forward, releases will be built with minimal ROOter for Modem management
Hello, I see that there is a new version and you are asking two users to try it, and one commented that the reboot had been solved, if you need more testers I offer to do it. v1 1.3-beta is the only one that I don't need to add anything to it to reconnect to the ISP when the IP changes.
Sorry for the late post here, but the issue with the reboot has been resolved on this version.
Thanks for the folks who helped me troubleshoot the issue
Yup, other than the ones that commented on my github repo, I also have local users who verified that the issue has been fixed.