It seems that we have a new option to connect WIFi nodes, besides mesh and wds:
https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=e80520197c9ca7bced50d3605d6baba6dead6e35.
How can we test that and contribute?
Relevant:
Here is a blog article about APuP: https://blog.freifunk.net/2024/08/24/a-new-way-to-mesh-apup/
Thanks!
I have currently WDS between Cudy Wr3000 and Xiaomi Ax3000T ( running after x86).
I will test that out after my vacation ( both running old snapshots and needs to be upgraded).
WDS runs bulletproof at the moment, but a bit of experiment and community test will not harm.
Kr
K
Do you know if Gio (who authored the hostapd patch) is on the forum? What's the best way to reach out to both you & Gio if I have any questions?
Do I understand the blog article correctly, that without the mesh routing protocol APuP should not be used with more than 2 devices?
@G10h4ck is on the forum
APuP is not a mesh routing protocol, but offers a setup to send packages from one device to all nearby devices with the same setup.
The bridges are what is causing the loop. Usually you want to use APuP with a mesh routing protocol to prevent loops.
Do I understand the blog article correctly, that without the mesh routing protocol APuP should not be used with more than 2 devices?
It depends on the topology, if a loop is possible you need a routing protocol to avoid them. If the loop is not possible you can do it with a plain bridge. Two devices is the simplest case, but even with N devices there can be loop free setups.
As an example with 3 devices that see all each other you need a routing protocol to avoid loops. Instead if you have 3 device in a line in which the first cannot see directly the last, then you can use a plain bridge without problems.
I played a bit today with the ApuP, but could not get it working. I have WDS between Xiaomi AX3000T and Cudy WR3000. So in essence I have just added uci set wireless.default_radio1.apup=1 uci commit wireless
on Xioami which was the WDS AP. I removed the WDS line, than I did the same with Cudy however I disabled the WDS client and left the Master. However I both didn't connected. I will play a bit more in the next comming days. By reading the article I do not see any other setups to be done. But am I missing something? Also I could not see phy0-ap0.sta1 or phy0-ap0.sta2 created on Cudy. On the Xioami there were such an interfaces.
PS: If I apply just optio apup on the working wds connection - the connection still works and hostapd starts reporting new to me messages in the system log.
offtopic: I wasn't aware but just found out that the Freifunk community has some interesting GSoC 2024 projects:
https://blog.freifunk.net/2024/08/26/gsoc-2024-ebpf-performance-optimizations-for-a-new-openwrt-firewall-final-report/
https://blog.freifunk.net/2024/08/29/gsoc-2024-development-of-a-modular-assistant-for-openwrt-final-report/
There is currently a bug related to APuP and WDS: https://github.com/openwrt/openwrt/pull/16298
Maybe it is affecting you.
Thanks @mwarning, just one confirmation. When setting up ApuP, shell I remove the "Client WDS (sta)" or shell I leave it to the setup. So essence shell I use WDS + ApuP or shell I remove the WDS ?
Better disable WDS for now.
Ok, I will try to test it tommorow, however I am afraid without WDS it didn't work yesterday. With WDS and ApuP it worked. Well, I am not sure if APuP was working, but I had connection between the routers.
If you see the phy0-ap0 device, then APuP is working.
well sorry to push you @mwarning with my limited knowelege, but I see that even now without APuP I have phy0-ap0 device. Below the details:
and on Cudy:
And the real config:
Xiaomi:
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fda3:79cc:f764::/48'
option packet_steering '2'
config device
option name 'br-lan'
option type 'bridge'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.1.2'
option netmask '255.255.255.0'
option ip6assign '60'
option gateway '192.168.1.1'
list dns '192.168.1.1'
config device
option name 'wan'
option macaddr '50:88:11:52:d9:12'
config interface 'wan'
option device 'wan'
option proto 'dhcp'
config interface 'wan6'
option device 'wan'
option proto 'dhcpv6'
config device
option name 'phy0-ap0'
config device
option name 'phy1-ap0'
Cudy:
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fde2:3d30:594c::/48'
option packet_steering '2'
config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.1.4'
option netmask '255.255.255.0'
option ip6assign '60'
option gateway '192.168.1.1'
list dns '192.168.1.1'
config interface 'wan'
option device 'wan'
option proto 'dhcp'
config interface 'wan6'
option device 'wan'
option proto 'dhcpv6'
Here is the current wireless config:
Xioami:
config wifi-device 'radio0'
option type 'mac80211'
option path 'platform/soc/18000000.wifi'
option band '2g'
option channel '11'
option htmode 'HE40'
option country 'PA'
option cell_density '0'
config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'IK2.4'
option encryption 'psk2'
option key 'hiden'
option ieee80211r '1'
option mobility_domain '2222'
option reassociation_deadline '20000'
option ft_over_ds '0'
option ft_psk_generate_local '1'
option ieee80211k '1'
option time_advertisement '2'
option time_zone 'EET-2EEST,M3.5.0/3,M10.5.0/4'
option bss_transition '1'
config wifi-device 'radio1'
option type 'mac80211'
option path 'platform/soc/18000000.wifi+1'
option band '5g'
option channel '36'
option htmode 'HE160'
option country 'PA'
option cell_density '0'
option txpower '26'
config wifi-iface 'default_radio1'
option device 'radio1'
option mode 'ap'
option ssid 'IK51'
option time_advertisement '2'
option time_zone 'EET-2EEST,M3.5.0/3,M10.5.0/4'
option key 'hiden'
option network 'lan'
option encryption 'psk2+ccmp'
option dtim_period '3'
option ieee80211r '1'
option mobility_domain '2222'
option reassociation_deadline '20000'
option ft_over_ds '0'
option ft_psk_generate_local '1'
option ieee80211k '1'
option bss_transition '1'
option wds '1'
and Cudy:
config wifi-device 'radio0'
option type 'mac80211'
option path 'platform/soc/18000000.wifi'
option band '2g'
option channel '1'
option htmode 'HE40'
option country 'PA'
option cell_density '0'
config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'IK2.4'
option encryption 'psk2'
option key 'hiden'
option ieee80211r '1'
option mobility_domain '2222'
option reassociation_deadline '20000'
option ft_over_ds '0'
option ft_psk_generate_local '1'
option ieee80211k '1'
option bss_transition '1'
option time_advertisement '2'
option time_zone 'EET-2EEST,M3.5.0/3,M10.5.0/4'
config wifi-device 'radio1'
option type 'mac80211'
option path 'platform/soc/18000000.wifi+1'
option band '5g'
option channel '36'
option htmode 'HE160'
option cell_density '0'
option country 'PA'
option txpower '24'
config wifi-iface 'default_radio1'
option device 'radio1'
option network 'lan'
option mode 'sta'
option ssid 'IK51'
option encryption 'psk2+ccmp'
option wds '1'
option key 'hiden'
option time_advertisement '2'
option time_zone 'EET-2EEST,M3.5.0/3,M10.5.0/4'
option bss_transition '1'
option dtim_period '3'
config wifi-iface 'wifinet2'
option device 'radio1'
option mode 'ap'
option ssid 'IK51'
option encryption 'psk2+ccmp'
option dtim_period '3'
option key 'hiden'
option ieee80211r '1'
option mobility_domain '2222'
option reassociation_deadline '20000'
option ft_over_ds '0'
option ft_psk_generate_local '1'
option ieee80211k '1'
option time_advertisement '2'
option time_zone 'EET-2EEST,M3.5.0/3,M10.5.0/4'
option bss_transition '1'
option network 'lan'
yeah, you are proably right. phy0-ap0 is just the AP interface that is there if APuP is enabled or not. Look out for phy0-ap0.sta1 then (but a different AP with ApuP will to be present).
I got phy0-ap0.sta1 in my tests yesterday on both, but only when WDS was switched on.
I will try to test tomorrow (probably - need green light from my other half- wife).
But again with or without WDS?
To me without WDS means "Client WDS" in Luci ti be present.
Wohoo the thread was unlocked!
Hello, let me ask a question about APuP.
Today I have 3 Xiaomi 4a gigabit connected by a 802.11s mesh.
The topology is:
AP02, due to long distance, cannot see the main router and must pass trough ap01.
I want to test APuP in those conditions, as I understood to avoid loops i need batman or equivalent, won't enabling STP be enough? Is there any documentation / how-to that includes batman?
Thank you and have a nice weekend.
With the topology you showed there is no risk of loop, so a plain bridge of the APuP peers interfaces should be enough, at worst try enabled STP but shouldn't be needed at all.