APU2e4 install OpenWrt

i liked my first openwrt experience a lot but it wasnt a stable build on a xiaom i27 $ router so i tought i go all the way with openwrt! so i brought a pcengine APU2E4 router for 200$ good specs and i tought how hard can it be to install openwrt on it.

Im testing the router now and wanna install openwrt i can get a serial connection, but there are no tutorials how to install openwrt on this device. so i have a couple of questions before i like the last one:

is the APU2C4 version from: PC Engines APU 2 [OpenWrt Wiki] the good version or do i need to learn how to build my own version?

And if it is the good version i have a option to boot from usb, so do i first install tinycore on the harddrive than boot to the harddrive and install openwrt from usb? or do i directly try to boot from the usb with openwrt to try to install it?

thanks in advance

As you can see from the PC Engines website the differences mostly boil down to NICs and RAM sizes. They should all be supported without fault by OpenWrt, since those differences are minimal.

You're good to go.

Please report back to confirm, then the wiki can be adapted.

1 Like

Thanks it was really easy to do, but i cant find the vlan and wifi options.
the vlan isnt that big of a deal because i have a dedicated switch for that but its like openwrt isnt finding the pcie wifi card its a Compex WLE200NX 802.11a/b/g/n miniPCI because on the site they where sure that that one works. anyone any idea how to enable the card?

thanks in advance

You have to install its drivers manually. APU2 by default doesn't have any wireless add-in cards installed, so that's how the OpenWrt support is set up as well.

VLAN is just in LuCI networking or on the command line.

ok thanks it works like a charm execpt vlans i had trouble on the first router to get that working (turns out that it hasnt vlan support).
i hope someone knows what im looking for i dont know what im searching for so i ask from you guys and girls a search term that could help me to solve the problem and getting smarter :smile:

problem:
if i setup vlans for my router that my provider provides 300 for the internet and 640 for the television. if i bridge eth0.300 to eth1 i have perfect internet but no dhcp ip. so i cant reach luci anymore.
if i setup the vlan like eth0Preformatted text.300 wil become standalone bridged and eth1 is static i have a fully working dhcp but no internet.

the tv was way easyer that was just bridge eth0.640 to eth2. that doenst need dhcp.

first the orginal network file (no vlan just how i opened it for the first time):


config interface 'loopback'
   option ifname 'lo'
   option proto 'static'
   option ipaddr '127.0.0.1'
   option netmask '255.0.0.0'

config globals 'globals'
   option ula_prefix 'fde4:ca0d:b4b6::/48'

config interface 'lan'
   option type 'bridge'
   option ifname 'eth1 eth2'
   option proto 'static'
   option ipaddr '192.168.1.1'
   option netmask '255.255.255.0'
   option ip6assign '60'

config interface 'wan'
   option ifname 'eth0'
   option proto 'dhcp'

config interface 'wan6'
   option ifname 'eth0'
   option proto 'dhcpv6'


the vlan without internet but dhcp:


config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fde4:ca0d:b4b6::/48'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ifname 'eth1'

config interface 'wan'
	option ifname 'eth0'
	option proto 'dhcp'

config interface 'wan6'
	option ifname 'eth0'
	option proto 'dhcpv6'

config interface 'tv'
	option ifname 'eth0.640 eth2'
	option proto 'dhcp'
	option type 'bridge'

config interface 'internet'
	option type 'bridge'
	option proto 'dhcp'
	option ifname 'eth0.300'

the uci output THANK GOD for serial I LOVE IT!:

network.loopback=interface
network.loopback.ifname='lo'
network.loopback.proto='static'
network.loopback.ipaddr='127.0.0.1'
network.loopback.netmask='255.0.0.0'
network.globals=globals
network.globals.ula_prefix='fde4:ca0d:b4b6::/48'
network.lan=interface
network.lan.type='bridge'
network.lan.proto='static'
network.lan.ipaddr='192.168.1.1'
network.lan.netmask='255.255.255.0'
network.lan.ip6assign='60'
network.lan.ifname='eth1'
network.wan=interface
network.wan.ifname='eth0'
network.wan.proto='dhcp'
network.wan6=interface
network.wan6.ifname='eth0'
network.wan6.proto='dhcpv6'
network.tv=interface
network.tv.ifname='eth0.640 eth2'
network.tv.proto='dhcp'
network.tv.type='bridge'
network.internet=interface
network.internet.type='bridge'
network.internet.proto='dhcp'
network.internet.defaultroute='0'
network.internet.igmp_snooping='1'
network.internet.ifname='eth0.300 eth1'

i hope someone knows where im looking for or knows the solution.
Thanks in advance