Anyone successfully built for an ARM target with GCC > 7.x?

Just wondering if anyone has gotten a successful build with any GC > 7.x (8.1,8.2) on an ARM target. Works fine for me on MIPS, but fails with assembler support error on ARM.


No for me can compile with GCC 8


whatahoot, so any idea why that fix is not coming in with GCC pushes? Colour me confused.


With the GCC 8.3.0 push today, I decided to take another kick at compiling against version 8 of GCC. Starting with current master git pull, distclean, package update & install, menuconfig, choosing mvebu target (mamba), changing to binutils 2.32, GCC 8.3.0, make. This still yields an assembler error for the ARM target from what amounts to a clean buildroot.

Yes, PR1846 was pushed, I pulled, and I get the above.

Edit: I guess your point is that PR1203 issue is still not dealt with? Mine is why are things still coming in that are not right; or perhaps to point, why are things allowed to be wrong.

Well, the comment part got stripped. I have no idea why it gets it wrong on GCC 8. IMX6 should have the same issue as far as I can tell, I'll give it a try :slight_smile:

Not unexpectedly IMX6 also fails with the same error....