Anyone else still using TL-WR703 with 8M flash?

I owned a TL-WR703N modded with with 8M flash and 64M RAM that I purchased back in 2013, which I used as a primary router with OpenWRT/LEDE for 5 years. To me, it is still a great router with great form factor (as I personally never use more than 10 Mbps, no matter how fast the connection is). Also it's light enough that I might carry it on a small drone!

Recently I tried to revive it and install the latest OpenWRT build. I want to share some of my experience here -- when I searched online there are very little up-to-date info available. I did find one related thread, however it's for 16M mod and I didn't immediately figure out how to adapt that python script for 8M.

My first attempt is to follow the step in the above thread and use the image builder (with ATH79), and changed "4mlzma" to "8mlzma", and I did not change the kernel DTS. I'm trying my luck here, as I have been installing 4M firmware onto my 8M mod for many times without issue. The image builder succeeded without error, however to my surprise the router falls into a boot loop.

I don't have a serial cable handy so I didn't debug, and I just flashed back the previous 17.0x firmware from U-boot. Thanks to the tips from everyone regarding backing up bootloader+firmware+ART before flashing! Use "dd if=/dev/mtdX of=/tmp/xxx" then scp.

My second attempt is to build everything from source. Thanks to the well-written guide, I followed step-by-step on a Ubuntu 18.04 server and it just worked (used ~15G disk). I used the default build config for ar71xx TL-WR703N, and it produced a sub-4M image (without luci), which booted successfully. I then ssh-ed and configured WAN port as LAN to connect the router to my existing network and used opkg to install all the packages. I'm happy to share in case anyone else is looking for sth for their WR703N.

However, after reading a bit, I realized ar71xx is being deprecated for ath79. I have just built an ath79 firmware and will try it soon.

In the meantime, I also read about how to change the DTS in the source definition, and I'm still learning about the build system. My goal is to build a 8M firmware that includes luci and other stuff. I guess I can figure this out myself but discussion is welcomed, and I hope I can connect with everyone else still using this tiny workhorse router.

Update: built ath79 firmware and it worked like a charm. The following changes are needed for 8M mod (following this 16M mod thread).

  • change 4mlzma to 8mlzma in ```
* change DTS table in ```

Using 0x20000 0x7d0000 for firmware partition and 0x7f0000 0x10000 for art partition.

I am glad that my post helped you. Did you test whether the USB works or not? The last time I try to install 19.07, I cannot make it work.

I just saw your other thread. I can't say for sure, because I was testing with a weird Huawei dongle and can't make it work after installing a lot of dongle-related modules (but I can't make the dongle work under a Linux laptop either).

I'll probably build 21.02 at some time and test the USB again with just a USB storage device. Will report dmesg etc.

1 Like

yes,I still using wr703 whith 16M flash.
I try to use ts-d084 / Omega firmware version 21.02.
but the usb is not work..

If your firmware test ok,pls let me know.