Any easy way debricking miwifi?

hi all. messing around with my routers a lot lately. the point is im looking for an easy method. in this case regarding the miwifi mini. the process is flashing official firmware > unlocking through a time consuming process > flashing openwrt. so i was wondering since the router has by default usb recovery to stock firmware. is it possible to just use usb to flash the breed bootloader only so i can recover it that way and flash openwrt directly? im guessing the device has uart as well but im trying to avoid time consuming recovery. since the router never required uart in the first place, would need to solder the pins etc. the device has support for breed bootloader but somehow after the last brick it doesnt work.

im guessing its not possible, however since i was running openwrt and i must have had the breed bootloader before just dont remember last time flashing. thought maybe usb recovery might have been possible. the device just bricked itself all of a sudden it showed no services on init.d and after reboot doesnt boot, no lan, no breed bootloader. if anyone knows a shortcut ill be glad to know since its a long time ago i did the painstaking process of reverting to stock just to get openwrt on it. rereading the wiki also provides most details on the method i mentioned.[]=miwifi&s[]=mini
i dont even remember getting an ssh password as the wiki states. been so long ago.

since i dont remember and the reverting to stock section links to xiaomis website which shows it needs usage of android or windows which i dont have atm. i dont remember basically, i downloaded a dev firmware the first section and it doesnt get recognized after formatting mbr, fat32, miwifi.bin. if anyone knows any potential shortcut id be glad. thanks.

If the device bootloader is dead, the only way is installing a bootloader first by an SPI programmer.

1 Like

i have the black ch341a but a bad experience using it last time with flashrom. its 5v but developers told me they never heard of a brick using higher voltage on spi. my bad for not reading the chip wasnt supported with flashrom. im not really handy with the clip either. what do you think is it safe to run it at 5v? due to not having much experience i think ill probably short circuit it. i really hate the clip. besides the point it does show led signs of booting. however didnt have time to waste on trying much and preferred waiting on this thread. it has uart as well but the wiki doesnt say much about using it. i did however run wrt with most probably breed bootloader at the time of the brick. could also be that ive picked another developers version firmware not supported by usb recovery cause the links were dead for those that did. well its just a miwifi mini. ill see what i can do and worst case fry it with spi.

Are you sure your ch341a tools is 5V? I measured mine, 3.3V to the chip.

1 Like

i have the black cheap chinese knockoff. ofcourse the chip is the same but the rest isnt. it has 3.3v for uart but as im not familiar with spi ive heard the voltage runs through the whole thing instead of just 1 connection like uart. however the developers of flashrom for linux told me they never heard of voltage being a problem. and on internet nearly everyone had the same black knockoff. they also told me spi chips are really durable compared to the rest on the motherboard. ofcourse i dont know much. but what i wonder is, what tools you use for flashing are there more tools for linux? i know there are some good windows tools for flashing but i couldnt get my spi supported in wine cause it didnt show up as a serial interface in /dev/ttyUSB or something. it kind of defeats the purpose if i have to install windows lol. at least, adblock can block all the telemetry with openwrt.

after the first time ive used spi, and probably the chip died cause lack of support. im afraid using spi. also because its really hard keeping the clip in place. i wonder what happens if i short circuit it. maybe my clip is faulty i dont know.
im not sure btw if it is 5v. i just read on internet everywhere about it being 5v but it didnt matter people didnt use converter adapters. it shows 3.3v on uart side and 5v on the spi side. i didnt measure it. spi is a new thing for me i have no clue.
how did you measure it which points, i must have a multimeter laying around somewhere, at least to be sure of what voltage it is to have some courage to try spi once again.
by the way by the time i had tried windows on my first and last spi experience it was dead already couldnt be read. if anyone knows linux tools theyve used before for flashing openwrt hardware id be glad to know.

Hi, you no need typing too much here, wast your time, just do it.
Windows PC is must, I use this tools: AsProgrammer

Yes, the IC clipper is dificult to do right, easy to not connected ok, but not easy short-circuit then damaged the IC. Take care the Pin-4(GND) and Pin-8(Vcc) right is enough.

1 Like

im on a very old backup pc now. took me almost a week to set it up for it to be decent and scripted all luckily so i dont have to do it again. windows doesnt even run on this thing its a real pain. i will do it soon though. waiting for ryzen prices in a week or 2 to get a new rig. i think thats why i bricked my other decent rig, using flashrom while it had no support. i tried asprogrammer as well my chip was listed, almost every chip was. will check if i can get it to work on wine because ill waste 2 days just getting windows on this thing. off topic but not so off topic, i was wondering while i get myself a new system to order an spi chip for the other bricked rig to fix that as well. but to be sure im asking cause i dont want to waste effort and money on it. my chip wasnt listed on flashrom although it did find comparable chips of the same manufacturer. i tried reading it didnt get read, i tried flashing it it got read. i left it on for an hour it never finished. mind you this was the first try. after that first attempt it couldnt get read anymore no matter what i did it was dead. i didnt short circuit it on my first attempt. later on? sure, but it was already dead. i thought even if writing goes wrong or chip is not supported spi can always be saved. the developers also found it unusual. i will post an update when i try soon though. fingers crossed it goes better this time. btw motherboard did boot but halted at post codes. usually i save it within a day this time was different. after spi flashing it didnt turn on at all. no power.