Another VLAN Configuration DSA- Issue

I was just given a Linksys WRT1900AC v1 installed version 23.05-rc4. So far things are working but when I try to make a simple VLAN and assign it to port 1. I keep getting errors.
This is how I do it in devices created bridge br-lan2, assign bridge port 1
in the propierties - enable VLAN filtering - assing VLAN ID 20 id then egress untagged (for devices)
Then I go back and assign an interface, and that is were things are not making sense I get an error "device not present"
What I am




missing?

I wonder why they keep making things more difficult, seen lots of videos online about VLANs and such they explanations and logical but in practice things feel more complex, my hope is that is not just me.

should provide some pointers.

Looks like you tried creating additional objects "br-lan..."
Whenever I had more than the default DSA br-lan, I had weird effects.

I would recommend creating all needed VLANs on the existing br-lan device in the VLAN bridge tab. If this is not sufficient, try explaining what you need it for

then from your interfaces, link to those VLANs e.g. as br-lan.13 (13 in this case being a VLAN id)

1 Like

I did try different settings and still no dice. Interesting so you are saying that if one creates another bridge device the router gets un-stable? If that is the case honestly I wonder why use this firmware? My apologies if I sound like I am complaining please do not take things that way. But, for my device maybe the version that I am using is not stable or something?
I am re-reading the DSA tutorial, and like I said before looking at videos, from what I gather feels like there are different ways to accomplish a VLAN on port 1 of the router which is what I am trying to do.
Not sure why it feels so difficult in this version of this firmware. I do see others confuse as I seems to be at this time.

Please describe the vlan-port membership you desire (so what vlan(s) on what ports and the tagging status of each vlan on said ports).

Then, let’s see your configuration.

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network

Netwrk - Interfaces - Devices - br-lan -

Network . Interfaces - Add New Interface

or one bridge per vlan:

config device 'device7'
	option bridge_empty '1'
	option ipv6 '0'
	option multicast '0'
	option name 'br-vlan20'
	list ports 'eth0.20'
	option sendredirects '0'
	option type 'bridge'

eth0 being my only eth port

I will be trying the different options shared by all of you and report back soon,

Thanks!!

from the default settings when you first boot your newly flashed router your LAN interface is on the eth0.1 device.

when you first enable VLAN filtering on the bridge and click apply a new device is automatically created called br-lan.1 but the LAN interface does not get automatically assigned to this new interface. So to avoid being locked out when you first enable VLAN filtering you need to remember to click save then go back and reassign the LAN interface over to the new br-lan.1 interface before finally clicking apply settings.

  1. enable VLAN filtering
  2. click save (do not click apply settings)
  3. go back to interfaces and reassign LAN interface to br-lan.1
  4. NOW click on apply settings and wait for LUCI to come back up.
  5. Go back to the bridge VLAN page and continue creating your new VLANs

I would vote for the developers of LUCI to automatically do this as a default action as this seems to catch out all newcomers to openwrt.

1 Like

After some trial and error, I got the Vlan to work. :sweat_smile:
In all honesty there is a lot of conflicting information out there specially on the videos that lots of people are putting on Youtube and other sites.

By far this is the best guide I was able to find:
https://www.saudiqbal.com/blog/openwrt-vlan-setup-guide-using-luci-for-iot-and-wireless-with-dsa.php
To my surprise lots of people are having issues when setting up VLANS on OpenWRT. My hope is that in the future others find this much easier what it is now.
Thanks to everyone for all the help.

After, re-reading what you are saying my hopes is that they implement that as a solution.