Android device wifi and bluetooth getting disabled and enabled suddenly when using wpa3

android device wifi and bluetooth getting disabled and enabled suddenly when using wpa3

when i use my bluetooth speakers and my android device and my openwrt wpa3 cipher, i get a strange error, my wifi and bluetooth get disabled like if airplane mode gets activated by 1 second, tried with other router using wpa 2 and got no errors,

what could it be?

this may be an error in last version of openwrt, it may be happening to some other persons, so it may be interesting to know, and debug it for further improvement of the software

I don't think this is an error with OpenWrt, especially if your device is causing both wifi and BT to disconnect. This sounds like an issue with your specific device.

Yes, other users have had issues with WPA3... most of the issues are related to WPA2/WPA3 mixed mode operation (sae-mixed), but some devices just don't work well with WPA3 in general.

A few things:

  1. Do you have another non-OpenWrt router that supports WPA3 that you can use to test the WPA3 behavior of your Android device in general?

  2. Can you post your configs for review... we canot guess what it could be without seeing how things are setup and if there are any errors there.

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall
config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix '--:--:--::/--'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'
        option igmp_snooping '1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '-.-.-.-'
        option netmask '-.-.-.-'
        option ip6assign '60'

config device
        option name 'eth0.2'
        option macaddr '-:-:-:-:-:-'
        option ipv6 '0'
        option igmpversion '3'

config interface 'wan'
        option device 'eth0.2'
        option proto 'dhcp'

config interface 'wan6'
        option device 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0 6t'

user@wifirouter:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type '-'
        option path '-/-.wmac'
        option band '2g'
        option htmode 'HT20'
        option channel '-'
        option cell_density '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid '-'
        option isolate '1'
        option skip_inactivity_poll '1'
        option disassoc_low_ack '0'
        option encryption 'sae'
        option key '-'
        option ieee80211w_max_timeout '20'
        option ieee80211w_retry_timeout '20'

user@wifirouter:~# cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option localservice '1'
        option ednspacket_max '1232'
        option quietdhcp '1'
        option sequential_ip '1'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        option ra_slaac '1'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

if i install this would help? : https://openwrt.org/packages/pkgdata/wpad-wolfssl

at the time i do not have other openwrt compatible device

You have redacted so much information as to make thie configuration generally impossible to read. Very little of the data in these files is sensitive and private... even MAC addresses do not necessarily represent sensitive information, although many people do redact them.

From what I can see, these three lines may have some impact on the situation...

and you might try removing these two lines:

As well as try removing IGMP snooping from your lan bridge and your eth0.2 device definitions.

I was actually asking if you have another device that has WPA3 -- it doesn't need to be OpenWrt (in fact, might be better if it isn't for this test). Or, for your current device, does the stock firmware support WPA3? If so, you can try reloading the vendor firmware and using WPA3 on that.

Finally, you did not post your firewall file... please post that as well as the output of

ubus call system board
1 Like