Allow non public ip ddns

Hello, need help, how can I configure DDNS with private IP? To allow access with non-public ip to ddns. Before on the stock firmware I could configured ddns and it’s works with the private ip, now on openwrt I have following error:

 165419       : Detect local IP on 'network'
 165419       : Local IP '100.70.XXX.XXX' detected on network 'wan'
 165419       : Update needed - L: '100.70.XXX.XXX' <> R: '185.105.XXX.XXX'
 165419 ERROR : No or private or invalid IP '100.70.XXX.XXX' given! Please check your configuration
 165419 ERROR : No update send to DDNS Provider
 165419       : Waiting 600 seconds (Check Interval)

add the entry to your dnsmasq config, in your router ?

No, could you please tell me how to do this? And which entry need to add

Network -> DHCP and DNS -> Hostnames

add your FQDN and IP, restart dnsmasq afterwards.

you can disable the DDNS, since it's not a public IP.

If I disable ddns my private ip will be changed on every router restarts

is it of any importance, it is, as you said, private ... ?

I mean that have you mentioned to add in host names, it works, but will it work after my router will restart later? My isp will give to my wan another private ip, is it possible just configured as it works on stock firmware?

Just disable in ddns checking non public ip and work with private

Depends on what IP you used.

No idea, since I don't know hoe it works on your stock fw.

Still can't see the use case, since the DDNS IP you're updating cannot be used from outside ( = the internet), unless you have two subscriptions with the same carrier, and are running traffic between those two.

It is used only inside my country to have access to my private ip, it needs for vpn server configured in my router to have access from another pc/phone e.g from work and etc, I can connect now to vpn on my router, but because of every restarts it changes my private ip, I have to configure my vpn server’s private ip manually to have access to my vpn

uci set 1



Sorry, could you please tell where it is need to be added ?

Just type it on the CLI.
Or manually add the appropriate entry to /etc/config/ddns, but the fact you had to ask means the CLI command is probably safer.


Nothing changes, the same error. In ddns config can’t see that entry:

config ddns 'global'
option ddns_dateformat '%F %R' 
option ddns_loglines '250' 
option ddns_rundir '/var/run/ddns' 
option ddns_logdir 'var/log/ddns'

config service 'dd'
option service_name '' 
option use_ipv6 '0' 
option lookup_host '' 
option domain '' 
option username' 
option password ' XXX 
option use_syslog '2' 
option check_unit 'minutes' 
option force_unit 'minutes' 
option retry_unit 'seconds' 
option ip_source 'network' 
option ip_ network 'wan' 
option interface 'wan'
• Read 22 lines

uci commit ddns


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.