After upgrading samsung S8 to android 9.0, usb tethering works abnormally

#1

Environmental description:
Openwrt 18.06 kernel version: 4.9.120
Problem Description:
Before the Samsung S8 mobile phone upgraded android 9.0, usb tethering worked normally; after the upgrade, usb tethering could not work normally, and the usb0 interface could not be recognized.
I used the latest openwrt source (kernel version 4.14.111) to find that Samsung s8 android 9.0 usb tethering works fine. I compared the usb and net/usb related drivers of the two versions of the kernel and found that the changes were great.
Due to the limitations of the product flash and memory, I don't want to upgrade the kernel version. Is there a kernel patch that can solve this problem?

0 Likes

#2
  • Are you able to just temporarily test a snapshot version - to determine if its solved there?
  • What device do you have?
0 Likes

#3

I add this patch to linux-4.9.120 and its solved.
https://patchwork.ozlabs.org/patch/819317/

2 Likes

closed #4

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.

0 Likes