After upgrading 19.07 to 21.02 can not acces to Luci

after upgrading, I can not acces to Luci interface through https, I have set before.
Certificate is untrusted.
I do not remember, but I think, I have http connection to Luci disabled.
Can I connect via SSH and enable http connection?

Thank yout

Set what before and in what?

Luci on 21.02.0 doesn’t have https rerouted as default. That was only on rc1.

But “cert untrusted”…can’t you just say ok and continue the connection?

If you get a cert error, then it is accessible...?

Had a similar issue and resolved.

If you have not changed ssh settings, you can connect via ssh with "ssh root@" (use your ip, if it's not and from there edit /etc/config/uhttpd with "vi /etc/config/uhttpd" (see a vi/vim manual for it's usage)
Also see for detailed webserver config options.

I set "option redirect_https to 0"
Now, I see page with link to Luci Configuration Interface, but, links looks like, do not work.
Before, in 19.07, borwser automatically redirected to login page, but now, it does'not.
After clicking on the link, it does not work too.

I think I once had sth. similar after an upgrade, where I had to clear my browser's cache.

So, I tried to use "virtul" web browser from my NAS to connect to router, but it is the same. White page with link to "Luci", but does not work.

do a hard reset - press and hold the reset button for 10 to 15 seconds - then start from the beginning

... or ssh to the device, and run firstboot.

check this Can not login to luci anymore.. help needed - #10 by boredhominid

Tried several methods, but without luck.
Finally made fresh install openwrt.

Thank you for your help.

For what it's worth, along with its certificates, the router's https cookies in the browser need deleting too. This happens to me when I log in and out of openwrt routers (not on same network) with same IP address (, for example).

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.