After Trying to Bridge Lan and Wlan, Couldn't Connect

Hi Guys,
I was trying to use my old TL Archer A7 router as wifi client for my desktop pc. But after following the step-by-step tutorial (, I am not able to connect to my router for ever. I checked my main router, it says openwrt is connected to the wifi, and the leds look good. But I just cannot open, even ping gets a request time out.

The only thing I may made mistake according to the tutorial was STEP 3, I put as the ip address, which is the same as my lan setting. My main router is

I also tried to recover the router by pressing reset button before power it up, and keep pressing it for a while. But nothing happened.

Hope you guys can help me!

should help.


Thank you very much! I will take a look

Ah, just found that this article was the one I followed this afternoon. None of the methods works for me.
I am wondering that maybe because I set the bridge interface the same address as the lan interface, which caused an infinite loop. So that the openwrt system is looping by itself, then the system is kinda frozen.

It is very unlikely that OpenWrt itself will bootloop because of wrong network configurations, but it might very well become inaccessible over the network (which is the only way of access for normal users) that way.

I don't have your device, so can't confirm if the failsafe procedure does really work on it - but it should, keep in mind, it's not necessarily the reset button to press, but may be the WDS one). Other options might include push-button tftp recovery.


I got it work!
I pressed both WPS and RESET button before power it up. Then the system led started blinking. I tried to ssh the router, and it was succeed. Then I reset the system. Right now I am using the router as the wifi adapter of my PC.
Thank you so much for your advice! And thanks to the developers of openWrt!

This topic was automatically closed 0 minutes after the last reply. New replies are no longer allowed.