After setup by relay_configuration,My device doesn't have internet access

relay_configuration
I followed this document to carry out openwrt's network settings, wireless settings, firewall settings, and restarted the device after completing all the settings, but when my mobile phone and computer were connected to the WiFi signal of the wireless relay, I found that I could not access the Internet, but the ping gateway and ping Bing in the repeater were all right, in addition, I rechecked every step from the beginning, and found that after connecting to the superior WiFi, I have not used the relay bridge for bridging, and my network is normal, The mobile phone connected to the repeater, the computer can access the Internet normally, in addition, in addition to the above attempts, I also changed the wwan to dhcp to obtain the IP of the superior WiFi, but it is useless, does anyone understand why or have you encountered this problem?

/etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/ahb/18100000.wmac'
        option channel 'auto'
        option band '2g'
        option htmode 'HT20'
        option disabled '0'
        option country 'CN'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'zhongjitest'
        option encryption 'psk2'
        option key '12345678'

config wifi-iface 'repeater'
        option device 'radio0'
        option network 'wwan'
        option mode 'sta'
        option key '12345678'
        option encryption 'psk2'
        option ssid 'MyWiFi'
        option disabled '0'

/etc/config/network
config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd17:0d26:357d::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'relaybridge'
        option proto 'relay'
        list network 'lan'
        list network 'wwan'
        option ipaddr '192.168.110.72'

config interface 'wwan'
        option _orig_ifname 'wlan0'
        option _orig_bridge 'false'
        option proto 'static'
        option ipaddr '192.168.110.72'
        option netmask '255.255.255.0'
        option gateway '192.168.110.1'
        option broadcast '192.168.110.255'
        option dns '192.168.110.1'

/etc/config/firewall
config defaults
        option syn_flood        1
        option input            ACCEPT
        option output           ACCEPT
        option forward          REJECT
        option fullcone 0

config zone
        option name             lan
        list   network          'lan'
        list   network          'wwan'
        option input            ACCEPT
        option output           ACCEPT
        option forward          ACCEPT

What is the output of

ubus call system board
{
        "kernel": "5.10.199",
        "hostname": "OpenWrt",
        "system": "Qualcomm Atheros QCA9533 ver 2 rev 0",
        "model": "TP-Link TL-WR810N v1",
        "board_name": "tplink,tl-wr810n-v1",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "SNAPSHOT",
                "revision": "r6317-ca06f4142",
                "target": "ath79/generic",
                "description": "OpenWrt SNAPSHOT r6317-ca06f4142"
        }
}

Start by upgrading to the latest stable release of OpenWrt.
https://firmware-selector.openwrt.org/?version=23.05.2&target=ath79%2Fgeneric&id=tplink_tl-wr810n-v1

In the process, you should not keep settings -- your config looks like it is quite old and will be incompatible with 23.05. So you'll be starting from a default state... follow the directions again to setup the relay and then share your config if it still doesn't work.

OK,thank you,let me try

This firmware not contain relayd,when i try to install it ,opkg prompts me unknown

Did you first run

opkg update

Yes,I run it at first

Let’s see the results of the opkg commands.

Unknown package 'luci-proto-relay'.
Collected errors:
 * pkg_hash_check_unresolved: cannot find dependency relayd for luci-proto-relay
 * pkg_hash_fetch_best_installation_candidate: Packages for luci-proto-relay found, but incompatible with the architectures configured
 * opkg_install_cmd: Cannot install package luci-proto-relay.

Unknown package 'relayd'.
Collected errors:
 * opkg_install_cmd: Cannot install package relayd.

Please show the following:

ubus call system board 
opkg update
opkg install relayd luci-proto-relay

{
        "kernel": "5.15.137",
        "hostname": "OpenWrt",
        "system": "Qualcomm Atheros QCA9533 ver 2 rev 0",
        "model": "TP-Link TL-WR810N v1",
        "board_name": "tplink,tl-wr810n-v1",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05.2",
                "revision": "r23630-842932a63d",
                "target": "ath79/generic",
                "description": "OpenWrt 23.05.2 r23630-842932a63d"
        }
}
Downloading https://mirrors.tuna.tsinghua.edu.cn/openwrt/releases/21.02.0/targets/rockchip/armv8/packages/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_core
Downloading https://mirrors.tuna.tsinghua.edu.cn/openwrt/releases/21.02.0/packages/aarch64_generic/base/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_base
Downloading https://mirrors.tuna.tsinghua.edu.cn/openwrt/releases/21.02.0/packages/aarch64_generic/luci/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_luci
Downloading https://mirrors.tuna.tsinghua.edu.cn/openwrt/releases/21.02.0/packages/aarch64_generic/packages/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_packages
Downloading https://mirrors.tuna.tsinghua.edu.cn/openwrt/releases/21.02.0/packages/aarch64_generic/routing/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_routing
Downloading https://mirrors.tuna.tsinghua.edu.cn/openwrt/releases/21.02.0/packages/aarch64_generic/telephony/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_telephony

This is not the right repo. How did you end up with this?

I’m guessing you did not follow my instructions:

Let’s reset to defaults:

firstboot -y && reboot
Package libtiff5 version 4.2.0-1 has no valid architecture, ignoring.
Package libudev-zero version 1.0.1-1 has no valid architecture, ignoring.
Package libunbound version 1.17.1-1 has no valid architecture, ignoring.
Package libunistring version 0.9.10-1 has no valid architecture, ignoring.
Package libusb-compat4 version 0.1.7-2 has no valid architecture, ignoring.
Package libuv1 version 1.40.0-3 has no valid architecture, ignoring.
Package libvorbis version 1.3.7-1 has no valid architecture, ignoring.
Package libvorbisidec version 1.0.3-20180319-1 has no valid architecture, ignoring.
Package libwebp version 1.1.0-2 has no valid architecture, ignoring.
Package libwebsockets-full version 3.1.0-2 has no valid architecture, ignoring.
Package libwebsockets-openssl version 3.1.0-2 has no valid architecture, ignoring.
Package libxml2 version 2.9.14-1 has no valid architecture, ignoring.
Package libzmq-curve version 4.3.4-1 has no valid architecture, ignoring.
Package libzmq-nc version 4.3.4-1 has no valid architecture, ignoring.
Package mariadb-server-base version 10.4.26-2 has no valid architecture, ignoring.
Package nginx-ssl-util version 1.6-1 has no valid architecture, ignoring.
Package nspr version 4.29-1 has no valid architecture, ignoring.
Package nss-utils version 3.67-1 has no valid architecture, ignoring.
Package pulseaudio-daemon-avahi version 14.2-6 has no valid architecture, ignoring.
Package pulseaudio-daemon version 14.2-6 has no valid architecture, ignoring.
Package python3-asgiref version 3.3.1-1 has no valid architecture, ignoring.
Package python3-codecs version 3.9.16-1 has no valid architecture, ignoring.
Package python3-django1 version 1.11.29-4 has no valid architecture, ignoring.
Package python3-light version 3.9.16-1 has no valid architecture, ignoring.
Package python3-logging version 3.9.16-1 has no valid architecture, ignoring.
Package python3-openssl version 3.9.16-1 has no valid architecture, ignoring.
Package python3-pytz version 2021.3-1 has no valid architecture, ignoring.
Package python3-sqlparse version 0.4.1-1 has no valid architecture, ignoring.
Package python3-urllib version 3.9.16-1 has no valid architecture, ignoring.
Package python3-xml version 3.9.16-1 has no valid architecture, ignoring.
Package python3 version 3.9.16-1 has no valid architecture, ignoring.
Package sbc version 1.5-1 has no valid architecture, ignoring.
Package strongswan version 5.9.2-3 has no valid architecture, ignoring.
Package tor-basic version 0.4.7.10-1 has no valid architecture, ignoring.
Package tor version 0.4.7.10-1 has no valid architecture, ignoring.
Package vim-full version 8.2-3 has no valid architecture, ignoring.
Package vim-fuller version 8.2-3 has no valid architecture, ignoring.
Package vim version 8.2-3 has no valid architecture, ignoring.
Package yajl version 2.1.0-2 has no valid architecture, ignoring.
Package zoneinfo-simple version 2023c-1 has no valid architecture, ignoring.
Package libks1 version 1.7.0-1 has no valid architecture, ignoring.
Unknown package 'relayd'.
Unknown package 'luci-proto-relay'.
Collected errors:
 * opkg_install_cmd: Cannot install package relayd.
 * pkg_hash_check_unresolved: cannot find dependency relayd for luci-proto-relay
 * pkg_hash_fetch_best_installation_candidate: Packages for luci-proto-relay found, but incompatible with the architectures configured
 * opkg_install_cmd: Cannot install package luci-proto-relay.

The result of this command contains too many lines to be shown to you, this is the last part, and everything above it is ignored like the previous ones

Because i'm in China,the repo of openwrt cannot be used,so i turn it to Tsinghua University repo.

Well, if you’re going to use a mirror or alternate repo, you must use the correct version (23.05.2 with the matching kernel version) and the correct architecture. Both of which are wrong in the repo you selected.

Is the openwrt repo entirely unreachable from China? How did you download the firmware I linked earlier? It is the same downloads site.


I download this firmware

Right. The firmware came from the same site as the openwrt repo is hosted

downloads.openwrt.org

Did you try to install the relayd packages before changing the repos?