Afoundry EW1200


I am new to LEDE, but I have very decent computer knowledge. I am very familiar with flashing devices like routers to the latest firmware from the manufacturer.

I bought the AFoundry EW1200 router because it was a relatively cheap powerhouse! I ended up really dissapointed because this router requires very frequent reboots to simply stay connected to the internet. There has never been any firmware update from the manufacturer (I have 5.4 installed) and support is horrible. So I wanted a better solution like LEDE or OpenWRT.

I found the Techdata page for my router:

From your instructions, my understanding is that since my router is running the original manufacturer's firmware, I should be flashing using the file under "Firmware LEDE Install URL" in my router's TechData page.

Can I install LEDE simply by downloading this file, logging on my router's Web interface, going to System - Firmware upgrade, browse to file, upgrade? Or do I need to do some kind of special telnet like command? If so, do I need to do this via the RS232 interface with some special software to connect to it?


The git commit that the device page links to has the instructions on how to flash.

The device page is the bare minimum we have about support status in LEDE, if I understand correctly there should also be a regular wiki entry for the corresponding device, with more info (and device specific instructions). That is, if someone created that; it's not generated automatically.

Thanks for your reply. I was scared this would get highly complicated / risky of bricking the device!

I can't seem to find a Wiki page on this router. Here are the "instructions" on how to flash this router from the page you linked:

Firmware update page on the stock web interface can not accept sysupgrade
images, it bricks the device.
At this point, the only working solution I found was to connect to the
serial console port (available on J4 header) and to use opkg to install
Then scp the sysupgrade file in the device's /tmp and run sysupgrade from
console without preserving configuration files.

Would you be willing to share a bit more details about these instructions.

Am I looking at the right file to flash in my original post?
Once I have connected the USB to UART cable to the J4 header of the router, which software do I use to connect to the router?
Do I have to somehow install opkg on the router or is that something I run on my PC?
I imagine SCP is a command of the software that you use to connect to the router via RS232?

Thanks for your help!

I'm not familiar with the flashing process so I'll let someone else comment on that. I think you'd need something like minicom (screen might work too). Opkg is part of any LEDE firmware, and maybe als of the default firmware on your device. I don't know anything about that.

SCP is part of the OpenSSH suite. On Windows, the easiest way to use it is through FileZilla (SFTP).

I just finished flashing this without opening the unit. I exported the config from the stock web interface and enabled Telnet Access by editing “telnet.cfg”and restored the edited config file.
Once I had telnet access to the shell, downloaded “lede-ramips-mt7621-ew1200-initramfs-kernel.bin” with wget and applied with sysupgrade.
After the reboot I upgraded it with “lede-ramips-mt7621-ew1200-squashfs-sysupgrade.bin”, rebooted configured for my network and away I went. Both radios are fully functional.

1 Like

How are you liking the setup? I've kept a keen eye out for this router but i'm aware of the issues with the firmware. I currently use OpenWRT and I was very much interested in the power of the AFoundry EW1200 but I saw it doesn't support OpenWRT, is LEDE very similar and is the install you listed above pretty straight forward. I'm rather linux savvy but I always get concerned with bricking brand new devices XD.

It's been very good so far. I've always had signal issues in my house and the EW1200 has replaced a Linksys EA6300 and a Trendnet Archer C5 that had been operating as APs in both ends of my house. With the EW1200 centrally located, I get great signal and speed everywhere.

The factory firmware was horrible. Multiple reboots a day were required. With LEDE installed, I have not rebooted since the date of install. LEDE is an offshoot of OpenWRT so it is a very similar OS at the base level.

1 Like

Thank you kindly for your reply. Did you install LUCI as well I've read that it isn't necessarily installed alongside LEDE but is a pretty simple install with "opkg update - opkg install luci"? What's your telnet client of choice?? Just wiped my linux partition so I would be working with windows for a quick setup.

Super pumped right now because the EW1200 is $99 on amazon right now and it looks beastly but I knew the firmware was crap.

I did install LUCI and yes it was that simple. I used Putty as a client.

Oh and just a quick note, it's Telnet on stock firmware and SSH after you load the first LEDE image.

1 Like

Thank you for all your help and the quick response! I'll let you know how it goes when I get the unit in this week.


How in the hell were you able to get the edited config to restore? I downloaded the backup and edited the telnet.cfg then tried to restore and I get operation failed. Then I downloaded the backup and tried to restore the freshly downloaded backup and i'm getting operation failed...thoughts?

Finally got the stupid configuration to take but I'm still unable to get telnet access and upon rebooting it seems that telnet is once again disabled in the config. Any advice?

If anyone could email me some suggestions I would appreciate it.

How did you export his file from the GUI? I can only export the settings from the backup menu.


I was wondering if it would be possible to provide step by step instructions (I know it's a big ask), but I've stumbled at the first hurdle - like yellaboyla I've not even been able to work out how to export the config file from the existing GUI.


Hi yellaboyla,

Did you manage to resolve this, as I have the same issue.



I actually have the newer 750 unit. I contacted Afoundry, and they pretty much told me that it was not supported. Also, I enabled Telnet, and they told me pretty much, that is cosmetic. Not activated. Mine does not have a pin header that I can see, so I cant go that route. Frustrating when this unit is running OpenWRT, and we can't get the source code. I have a new router coming, and I plan on doing surgery on this 1. I may have to add a header to start.

No luck just yet figuring this all out. Kind of discouraging because the Dev's that work for AFoundry seem to have filled the gap in some of their vulnerabilities. Telnet is in fact purely cosmetic in the exported configuration and I've gotten nowhere with that. Decided what the hell and cracked my router open today with my CP2102 USB to UART bridge and I'm unable to get the terminal to respond via a 57600 8-N-1 configuration on Tera Term, Hyperterminal, and Putty. Just need a little break in the action until someone chimes in and helps me right my wrong.


I have the appropriate connections.


Baud Rate: 57600
Data: 8bit
Parity: None
Stop: 1bit
Flow Control: None

Thoughts? Would love to get this running today! As soon as I can get this damn terminal to emulate correctly the rest should be a walk in the park. I'm curious as to whether AFoundry messed with their routers to discourage this type of modding.

you need to connect VCC. From my experience take a look here

Never ever connect VCC.

Sorry, not to connect vcc pin on board, but you should powered the Serial Port Converter

I was under the assumption that it was powered through the USB portion of the USB to UART bridge. I’m not using one similar to his.

This is the one that I purchased.

Perhaps that I should purchase the one that he got.

I have done some research and apparently reversing the TX and RX seems to be the standard... It appears that TX refers to transmit while RX refers to receive so in reality the TX on the interface should transmit to the corresponding RX on the device and the TX on the device to the RX on the interface to create a loop. How off is my research?


TX -> RX
RX -> TX


Found this resource here:

I really like editing posts.

just try to switch and test both options, there is no problem. And thats depend of the uart you have. In my case you should conenct rx to rx and so on (, and power the serial converter through usb, if not it doesnt work.