Afoundry EW1200 router Bricked

Hello has anyone managed to unbrick the EW1200 router I have been using the openWRT software, but the latest version has bricked the router, all I have is the power LED and intermittent LAN port, I have tried holding the reset down and then supply the power but no LED flashes or comes on, I was going to try the stock firmware which uses an IP address of also tried using a static IP address on the computer, it does have the 3 programmable pins inside the router and I have a serial interface but that’s as far as I got, any suggestions would be very greatly appreciated.

  • What previous version?
  • I assume you mean 22.03.3, correct?

You may wish to provide more details (i.e. not as if every user of the device has suffered this issue).


That's a lot.

  • Information?
  • Have you connected to them?
    • (Do you know how?)
    • If so,what's the output?

Thanks for the reply yes I flashed 22.03.3, normally goes without a hitch, but sadly this time not, I set the computer with a static IP address for the openWRT, but set the computer to, I have Putty on the computer as well as FTPD64 tried a few things off you tube but all I get is stacks of rolling nonsense, the serial interface is the correct voltage for the router and I can see 3.3v on both the TX & RX pins, but I was wondering if the router had a recovery mode, don’t matter how long I hold the reset down no flashing or indication that I’ve entered recovery mode, to answer your question no I’m a novice at SSH if that helps

Sorry it dies is a spelling mistake I’ve corrected it.


Are you using a Serial (5V) to TTL (3.3V) Serial adapter?

Actually, I thought that's what it said. What does "dies" mean?

Are you using a Serial (5V) to TTL (3.3V) Serial adapter Yes

Hi i managed to get serial TTL working and have this image in putty but stuck what to to next, the last firmware was the openWRT which uses 1.1 but the default firmware used 2.1 default gatway.
Below is some information.

Any help for a novice would be brilliant

Connect an ethernet cable between your router LAN port 1 and PC

Set the IP on your PC to static, subnet

On your PC start TFTPD64 (server), copy the firmware to the same directory as the program. Name it openwrt.bin.

Power on the router with the serial console. Press "1" to use option 1: Load system code to SDRAM via TFTP.

Input device IP ( ==: (Router)
Input server IP ( ==: (PC)
Input Linux Kernel filename () ==:openwrt.bin

The device should boot into openwrt. Set your PC to DHCP and it will get an IP on the network. Connect to LuCI and flash the sysupgrade file.

This is roughly what you need to do. If you have anymore questions or are unsure. Feel free to ask questions.

1 Like

That’s fantastic I will give that a good go just to confirm are you saying rename the original firmware (stock firmware for the router) to openwrt.bin or name the OpenWRT, why I’m confused is the (sysupgrade file) is the same on your download link as I would be flashing the same firmware ware twice, that might be correct just as long as I’m clear on that, hope I’ve explained myself clearly.
I do really appreciate your help really nice of you, as so many that are really competent in this field just pick on posted like mine rather then help.

I just realised you had a different file for the firmware and for the normal firmware the [sysupgrade file] I already have, sorry I will try that first, thanks.

First file is

openwrt-22.03.3-ramips-mt7621-afoundry_ew1200-initramfs-kernel.bin - this will be on your PC and you will rename it to openwrt.bin.

The second file is openwrt-22.03.3-ramips-mt7621-afoundry_ew1200-squashfs-sysupgrade.bin. You'll use this in LuCI and it will flash openwrt permanently onto your router.

Hope this helps.

Hi tried this a few times to eliminate my mistakes but it ends up the same

Is the firewall off on your Windows machine?

What do the logs on tftpd64 say?

Hi yes I do have a firewall on the computer and the tftpd64 logs are blank, I did select the correct ip address in tftpd64 as well and the correct directory where the renamed firmware is.
I will try again tonight and completely disable the firewall as I’m not on line when doing this, thank you

Hi unfortunately it made no difference i disarmed both firewall and antivirus, if i don't chose any number there is a further message which I've uploaded.

under the number 3: not sure if its relevant, i tried all the ports just in case, so now I'm plugged back into LAN 1, the tftpd64 never does anything just sits there, i have showing and the directory which the the firmware is and renamed to openwrt.bin.
I wonder if you have any further suggestions

Does it just hang with no more messages?

Are you able to ping router to pc or pc to router?

Can you please copy and paste output rather than providing screenshots. Makes it much easier to read, also it's easier to search too :slight_smile:

Hi sorry I won’t put an image up unless you ask.
After the 3: message if left will go through lots of zeros and ones until it gets back to please chose the operation: again, I’m on a tablet at the moment to later I will try to ping the router from windows, but without putty running windows keeps identifying network then unplug cable continuously, but with putty and the please chose the operation: it stays connected, I will post later with the ping results, but I never get any messages logs or nothing from tftpd64.

Hi well i attempted to ping the address this is what i got:

Pinging with 32 bytes of data:
Reply from Destination host unreachable.
Reply from Destination host unreachable.
Reply from Destination host unreachable.
Reply from Destination host unreachable.

Ping statistics for
****Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

I hope that what you wanted, the router is stable to ping only when entering one of the options or after its failed, then if you hit Ctfl & C it then starts its loop again

I've tried the same test on a different computer and it comes back the same, when you enter the automatic subnet always enters
Is the router looking for the original firmware afoundry 5.4, not the openWRT firmware

As anybody got any suggestions why I can’t fix this router, it really didn’t like openwrt-22.03.3, is it possible only the original firmware will fix this