Advice to new TP-Link Archer A7 owners

Hi,

Simple advice DO NOT FLASH UPGRADE FACTORY FIRMWARE.

After some hair tearing out yesterday I have found that A7s come with quite old factory firmware. Do NOT be tempted to upgrade this before attempting to flash OpenWrt firmware. I have found that the latest firmware will reject OpenWRT images and will not allow you to flash back to older firmware. The old default firmware that the A7s arrive with do not have this issue and will accept flashing to with OpenWRT no problem at all. I was lucky that I bought two A7s but unlucky that I only worked this out when I factory upgraded the first one and then found it would not accept OpenWRT. Fortunately the second one I had left as delivered and it worked fine. I am now replacing the first one with a new one and all will be well.

CJ

Flash how ?

TFTP generally works no matter what firmware version you have installed.

I used the TP-Link GUI - manual upload image file in the upgrade options of the gui. Could not get tftp to work.

CJ

A week ago I flashed an A7. The stock firmware was relatively new (end of 2020). Flashing via GUI was not possible.

image

There were no problems with the TFTP method. Do not forget to stop the firewall of the machine, hosting the tftp server. You can hold down the reset button until you see a request on the tftp server console.

Yes, the ones I have received in the last couple of days from Amazon UK had 1.0.16 firmware so pretty old. I had the exact error you did when I tried flashing with current firmware.

Picked one of these up via amazon and I'm failing to get OpenWRT on it. Feeding the bin in the GUI = invalid file type no matter what it is named.
Archer A7 v5.0 (says 5.8 on sticker)
1.1.0 Build 20201120 rel.50399(5553)

Also failing at doing TFTP as per docs. Only tip I didn't see in the docs is setting Tftpd64 to bind to the 192.168.0.66, if you don't the server will change to a NIC that is active while router is off. I approved the firewall prompts, and also just turned it off but I never see a request come into Tftpd64. Held the reset switch for ten seconds, also held it all the way through boot, power light stops blinking at 1:45 and held it to 2 minutes.

My first time trying TFTP, maybe something basic wrong?
tftpDIR

Let go of the button once the WPS light turns on. The power light will go out, the WPS light should be the only one on.

Disconnect the PC from all other networks and disable all firewalls. Don't try to tweak them to allow TFTP, just turn them off. This is safe to do since the PC isn't connected to any other networks. Nearly all problems with running a TFTP server are due to a firewall blocking incoming TFTP requests.

Finally got it, needs to be plugged into a LAN port not the WAN port.

Connection received from 192.168.0.86 on port 3755 [11/11 18:34:58.830]
Read request for file <ArcherC7v5_tp_recovery.bin>. Mode octet [11/11 18:34:58.831]
OACK: <timeout=5,blksize=1468,> [11/11 18:34:58.832]
Using local port 63654 [11/11 18:34:58.832]
<ArcherC7v5_tp_recovery.bin>: sent 3857 blks, 5660903 bytes in 1 s. 0 blk resent [11/11 18:34:59.563]