Advice on how to configure an isolated "IoT" VLAN in home network

Hello, I'm planning to setup a separate IoT/camera VLAN on my home network to connect various devices that should not have access to WAN. They should only be able to connect to a Home Assistant server.
This HA server, on the other hand, is reachable and can reach both the IoT and the home VLAN.
So far I've been using this config that works fine for a single OpenWRT router:

network:

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.50.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'camera'
	option 'proto' 'static'
	option 'ipaddr' '192.168.10.1'
	option 'netmask' '255.255.255.0'

firewall:

config defaults
	option syn_flood	1
	option input		ACCEPT
	option output		ACCEPT
	option forward		REJECT

config zone
	option name 'camera'
	list network 'camera'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'

config zone
	option name 'lan'
	list network 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'

config forwarding
	option src 'lan'
	option dest 'wan'
	
config forwarding
	option src 'lan'
	option dest 'camera'

wifi:

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'home network'

config wifi-iface 'camera'
	option device 'radio0'
	option network 'camera'
	option mode 'ap'
        option ssid 'camera network'

I'd now like to "propagate" the home and camera/IoT VLANs across my home network so that my Ubiquiti AP can also advertise 2 SSIDs: one for cameras/IoT, one for devices that should have full access to internet. Here is a schema of my network.:


I'm more specifically looking for some guidance regarding the configuration both intermediate Zyxell switches (I'll flash them with OpenWRT too) and the unify AP.
Kind regards,
Sébastien