Advice for troubleshooting terribly slow upload speed? (WiFi client wwan)

Hello networking gurus,

I've been searching, tweaking, and failing for days now. I've got a Linksys EA6350v3 running the Optimized build for IPQ40xx devices by NoTengoBattery. Everything seems to be working well with this build. With one major issue that I assume is my doing.

I'm currently connecting my Macbook Pro to my router running as an Access Point via ethernet and my router is connecting to a WPA2 network as a client using PEAP / EAP-MSCHAPv2 on the 5GHz radio1. The router is able to connect, authenticate, get a DHCP IP address assigned to my router by the enterprise router and get out to the internet as expected. (I had to uninstall wpad-mini and went with wpad-wolfssl for the Enterprise networking.)

As you surmised from the post title, my upload speeds are terrible. In the Associated Station info, the TX Rate is great. It fluctuates between 40 Mbps and 100 Mbps. The problem is that any device connecting to the router is getting less than 0.8 Mbps, even using an Ethernet cable. (I've also tried using WiFi to connect to the router with the same results.)

I've got SQM / QoS turned off. I've experimented with Software flow offloading being enabled/disabled, setting the MTU to various sizes, and enabling/disabling MSS clamping. None of these have made a difference. I've also tried disabling/stopping the firewall through the System Startup LuCI interface (although I didn't reboot after stopping the firewall).

Do you have any pointers for other settings to check or diagnostics to get to the bottom of this?

Many thanks!

SSH in to the router and run the following -

cat /etc/config/network 

cat /etc/config/wireless

cat /etc/config/firewall

Note: Make sure to obscure the "option key" value(s) in the wireless config results before posting.

Post each result in preformatted text, by using the icon highlighted in red...

OpenWRT Posting Icons

1 Like

So your OpenWrt router acts as a WiFi client, right?

Is this only about client devices getting slow speed, or does the OpenWrt router itself get a slow speed? Have you run the speed test script on the router?
e.g. the speedtest-netperf package that is in 21.02 and master, see

You mentioning that also devices connecting wiredly to the openwrt router are slow makes me to think that there is something wrong with the connection to the enterprise stuff.

Are you using router/firewall functionality in OpenWrt at all, or is everything on Lan zone?

1 Like

Thanks for taking a look! I ran speedtest-netperf as recommended by hnyman and it was getting the same slow upload speeds, so it's definitely between my OpenWrt router and the building router.

/etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fda0:985f:9b13::/48'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.1'

config device
	option name 'eth0.1'
	option macaddr '60:38:e0:93:fb:95'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device
	option name 'eth0.2'
	option macaddr '60:38:e0:93:fb:94'

config interface 'wan'
	option device 'eth0.2'
	option proto 'dhcp'
	option dns '127.0.0.1'
	option peerdns '0'

config interface 'wan6'
	option device 'eth0.2'
	option proto 'dhcpv6'
	option dns '::1'
	option ifname '@wan'
	option peerdns '0'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 0t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '5 0t'

config interface 'wwan'
	option proto 'dhcp'

/etc/config/wireless

config wifi-device 'radio0'
	option channel '11'
	option hwmode '11g'
	option type 'mac80211'
	option path 'platform/soc/a000000.wifi'
	option htmode 'HT20'
	option cell_density '0'

config wifi-device 'radio1'
	option hwmode '11a'
	option type 'mac80211'
	option path 'platform/soc/a800000.wifi'
	option htmode 'VHT80'
	option cell_density '0'
	option channel 'auto'

config wifi-iface 'wifinet0'
	option device 'radio1'
	option mode 'sta'
	option network 'wwan'
	option ssid 'BuildingSSID'
	option encryption 'wpa2'
	option eap_type 'peap'
	option auth 'EAP-MSCHAPV2'
	option identity 'myidentity'
	option password 'mypassword'

/etc/config/firewall

config defaults
	option syn_flood '1'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option flow_offloading '1'

config zone
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	list network 'lan'

config zone
	option name 'wan'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'
	list network 'wan'
	list network 'wan6'
	list network 'wwan'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option src_ip 'fc00::/6'
	option dest_ip 'fc00::/6'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config rule
	option name 'Support-UDP-Traceroute'
	option src 'wan'
	option dest_port '33434:33689'
	option proto 'udp'
	option family 'ipv4'
	option target 'REJECT'
	option enabled 'false'

config include
	option path '/etc/firewall.user'

Thanks for pointing me to speedtest-netperf. I ran it and am getting the same slow upload speeds (less than 0.5 Mbps), so it's definitely between my OpenWrt router and the building router. (Also speedtest-netperf is now down because it exceeded the monthly bandwidth.)

I've got the wireless interface (I've named it WWAN) in the wan firewall zone. I haven't changed any firewall rules. Do you have any recommendations on fine tuning the wan zone?

Sorry, no real suggestions. Just some small ideas.

I didn't spot the country setting in your WiFi settings, so you might set that, as if affects the radio capabilities somewhat.

One possibility might be an overlap in addressing, both the building network and you using 192.168.1.x as the local address space. That would cause routing trouble and slowness. You might test changing your router to use 192.168.2.x or some else. (Just check what is the IP address on the wwan interface. It can't be the same as in Lan)

Thanks for the ideas. The building address space is 192.168.100.x, so unfortunately, that's not the issue.

I tried setting the country code, and it didn't have an effect.

I appreciate the thoughts...

Problem solved. I had to switch from the NoTengoBattery build to the standard build (I used v 21.02.2), uninstall wpad-basic-wolfssl, install wpad-wolfssl, and everything is working as expected now. I'm finally in the promised land of 100+ Mbps uploads.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.