AdGuard Home, opkg and ping on router not working

Hey, everybody. I installed AdGuard Home on my router (Asus RT-AX1800U) following these instructions from the wiki:
https://openwrt.org/docs/guide-user/services/dns/adguard-home
In general everything worked, but I encountered the same problem as the author of this post: Cannot update opkg after installing adguard.
Internet works, but when I try to run any opkg command from the router itself or just ping any site, no packets are forwarded. The author of the post above solved the problem by moving AGH to port 5353, left DNSmasq on 53 and enabled DNS forwardings to 192.168.1.1#5353, but in this case AGH sees only one client in its interface, namely 192.168.1.1, which significantly limits its ability to keep statistics.

Help to understand how to leave AGH to listen to port 53, and DNSmasq 54, and at the same time restore the connection of the router with the Internet. I suspect that the problem is port forwarding, but my experiments with this did not give anything. Thanks in advance!

executed on the router, post the output of ping 8.8.8.8, and nslookup forum.openwrt.org
post your /etc/config/firewall file..

Ping 8.8.8.8:
Снимок экрана 2024-03-18 в 19.49.59

nslookup forum.openwrt.org:
Снимок экрана 2024-03-18 в 19.51.28

/etc/config/firewall file:



Ping google.com:
Снимок экрана 2024-03-18 в 19.58.20

you need to make AGH listen to 127.0.0.1 too,
or use some other, external, DNS for the router itself,
or start dnsmasq on 127.0.0.1, only.

as a temp workaround, you could try echo "nameserver 1.1.1.1" >> /etc/resolv.conf.

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/adguardhome.yaml

add - '127.0.0.1' here
you could also replace 192.168.1.1 with 0.0.0.0.

https://github.com/AdguardTeam/AdGuardHome/wiki/Configuration#configuration-file, scroll down to dns.

1 Like

Thanks, that helped! I added the 127.0.0.1 address with the second line and now ping and opkg works.

dns:
  bind_hosts:
    - 192.168.1.1
    - 127.0.0.1

Thank you all for your help!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.