AdGuard Home,Netdata and SQM not working

Hi All,
I've been trying to install AdGuard Home,Netdate and SQM it works perfectly on /overlay extended usb stick. until I reboot the router and everything goes back to the default settings, I can't access Adguard Gui/ SQM and Netdata Gui due to it resetting all the install packages/setting to default, and disabling it.
Router; Linksys openwrt 3200acm
I tried different versions such as OpenWrt 21.02.3, 21.03.0, etc still no luck.
I followed him to setup it up: https://www.youtube.com/watch?v=Q-xDtCxnD0Q (26:30)
and https://www.youtube.com/watch?v=5UjCT99udm0
https://openwrt.org/docs/guide-user/additional-software/extroot_configuration
Big Thanks
Screenshot 2022-09-04 183928



Any help here!!

Resetting as in the packages are gone, or just the settings?

Both package/settings never seems to be there anymore.

Does this mean the /overlay is completely empty, post boot?

Yes, once /overlay were completely empty (had to re do the guide again and it the usb re appeared back again but that packages etc all missing had to reinstall it again) not sure about the post boot. Thanks

You might want to find out..

Sure, any ways to figure that out. Thanks I can check right now since IAM logined in to luci gui and CLI.
Thanks

Oh yes! post boot is empty for /overlay after the reboot. Thanks

is it really empty, or simply not mounted ?

It's mounted and empty, let me share you the picture. Thanks

Hello,
The router (Linksys3200ACM) usually restarts at 5:30(30 5 * * * sleep 70 && touch /etc/banner && reboot
), but the last time when I mounted usb in /overlay adguard home, it never turn back on again (Stuck at the Power light). I had to turn the router off, take out the USB stick, and turn it back on to get it to function.
Normal working fine
figure1 Normal working fine without mounting USB.
after rebooting with USB mounted in /overlay
figure2 Sometimes it restarts fine with USB mounted sometimes it sucks at power ( after rebooting with USB mounted in /overlay)

It is mounted and visible to me, however, these days when it restarts, either the files are there and adguardhome, netdata, Qos not simply loading it doesn't restart at all since the power is stuck.