Additional Vlan on Archer C7 v4

I'm using a TP-LINK Archer C7 v4 with gluon-v2019.1.2 Firmware and this is my /etc/config/network:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdc0:e308:ccdd::/48'

config device 'wan_eth0_2_dev'
        option name 'eth0.2'
        option macaddr 'b0:4e:26:a7:a5:6a'

config interface 'wan6'
        option proto 'dhcpv6'
        option ifname 'br-wan'
        option ip6table '1'
        option sourcefilter '0'
        option peerdns '0'
        option reqprefix 'no'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '2 3 4 5 0t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '1 0t'

config interface 'wan'
        option igmp_snooping '1'
        option ifname 'eth0.2'
        option multicast_querier '0'
        option peerdns '0'
        option auto '1'
        option type 'bridge'
        option proto 'dhcp'
        option macaddr '8a:b3:d0:2b:91:50'

config rule6 'wan6_lookup'
        option mark '0x01/0x01'
        option lookup '1'

config route6 'wan6_unreachable'
        option type 'unreachable'
        option table '1'
        option target '::/0'
        option metric '65535'
        option gateway '::'
        option interface 'loopback'

config interface 'mesh_radio0'
        option proto 'gluon_mesh'

config interface 'ibss_radio1'
        option proto 'gluon_mesh'

config interface 'mesh_wan'
        option ifname 'br-wan'
        option index '0'
        option proto 'gluon_wired'
        option disabled '1'
        option transitive '1'

config interface 'mesh_lan'
        option igmp_snooping '0'
        option ifname 'eth0.1'
        option index '4'
        option proto 'gluon_wired'
        option disabled '1'
        option transitive '1'
        option macaddr '8a:b3:d0:2b:91:54'

config interface 'client'
        option igmp_snooping '1'
        option type 'bridge'
        option auto '1'
        option ra_holdoff '30'
        option multicast_querier '1'
        option macaddr 'b0:4e:26:a7:a5:69'
        list ifname 'eth0.1'
        list ifname 'local-port'
        list ifname 'bat0'
        option ipv6 '1'
        option keep_ra_dnslifetime '1'
        option sourcefilter '0'
        option peerdns '1'
        option robustness '9'
        option reqprefix 'no'
        option query_interval '2000'
        option query_response_interval '500'
        option proto 'dhcpv6'

config device 'local_node_dev'
        option type 'veth'
        option name 'local-node'
        option peer_name 'local-port'
        option macaddr 'ac:41:95:40:f7:dc'
        option peer_macaddr 'b0:4e:26:a7:a5:69'

config interface 'local_node'
        option ifname 'local-node'
        option ip6addr 'fdac::ac/128'
        option ip6deprecated '1'
        option proto 'static'

config interface 'gluon_bat0'
        option proto 'gluon_bat0'

config interface 'bat0'
        option multicast_router '2'
        option ifname 'bat0'
        option auto '1'
        option macaddr 'b0:4e:26:a7:a5:69'
        option learning '1'
        option proto 'none'

config route6 'local_node_route6'
        option target 'fdac::/64'
        option gateway '::'
        option interface 'client'

config interface 'mesh_vpn'
        option ifname 'mesh-vpn'
        option transitive '1'
        option mtu '1406'
        option macaddr '8a:b3:d0:2b:91:57'
        option fixed_mtu '1'
        option proto 'gluon_mesh'

I want to configure "mesh_wan" to work on taged vlan 4 on WAN-Port. My Idea was, to add a vlan on WAN-Port like this:

config switch_vlan
        option device 'switch0'
        option vlan '4'
        option ports '1t 0t'

and changed mesh_wan to

config interface 'mesh_wan'
        option index '0'
        option proto 'gluon_wired'
        option transitive '1'
        option ifname 'eth0.4'
        option disabled '0'

This didn't work as expected. The AP wasn't reachable anymore from any LAN and WAN-interface. I think I did it wrong. What is the right way to do this?