Adding OpenWrt support for Xiaomi AX3600 (Part 1)

Can anyone with one of these devices answer two questions for me please?

  1. why does this device look so hideous?
  2. does it have wall/ceiling mount screw holes in the the plastic under-body? I want to mount my routers on the ceiling.

Images on google don't suggest so, and there may be various enclosures out there.


  1. I can't speak as to why they made them so hideous
  2. There are no, I repeat NO screw holes in the bottom on any of my three devices (and I haven't tried drilling any myself). Could be doable, because the boards aren't touching the bottom enclosure.

That's for AX3600 in black.

1 Like

While you might not appreciate its appearance, the case-, PCB- and especially the thermal design are pretty solid (and do rely on natural convection of warm air escaping through the top, so bolting the bottom the wall would not be ideal).

1 Like

strapping this mofo to the ceiling would probably lead to certain death :smiley:

At least in case it falls down, impaling you with the antennas :wink:


I don't think so. Ugly beasts as they are, I've never seen any get hot, never mind uncomfortably warm to the touch on the casing.
I exclusively use them as dumb aps, don't know what they'll do with e.g. heavy package filtering.


Or if you strap them to the roof in your RV in the Arizona desert, AC off, but still using it? Never mind, just a thought experiment.

I used a 3D printed mount to mount it bottom-up:

Also a nice mount is this wall-mount:

so no drilling or whatsoever is needed in your router and it's looking good!


Hello, I use the DHCP client protocol, my ip expires every 5 minutes sometimes it disconnects me from the internet for a few seconds. At Asus there is a DHCP query frequency option to set to continue. Is there an identical option in OpenWrt? On an older version but no robimarko I had no problem.

You talking about the continous DHCP mode that is constantly spamming?
That is nothing more than udhcpc being called with -t1 -T5 -A0

Yes it looks like that.
I have the impression that sometimes it recovers the ip in time and therefore I lose the connection. In the old config I had mwan3 if I understood correctly create several requests with a separate time.
The person in the post talks about it, I'm also with the same access provider.

My ISP is even more stupid, they are handing out 3 day leases but after 6 hours they pull the plug and remove the old lease and then it takes time for my RB4011 to figure that out and I have not found a way around it


a long shot but a couple of thoughts :wink:

unsure if you are using fiber or dsl ... if fiber and your provider is doing docsis3 is to set the broadcast flag ... one other method is that your provider probably is expecting you are connected with their own router ... you can determine the vendor class of that router and copy it to your own settings

I can see that in the latest builds GRO is enabled for all ports. Haven't we seen an issue with this on top of PPPoE?

It's been enabled for a couple of months now as enabling/disabling it via ethtool now works.
It usually brings more benefits than trouble so its enabled by default.

@Ansuel and I have been trying to figure out checksum offloading again as that is eating significant CPU time


I'm on fiber. I put the vendor correctly. After the crash remains decent. But on my old version I didn't have this problem.

1 Like

@XiaoliChan: yes sorry, you are right. i just remember, that i installed an uboot recovery, for easier openwrt updating. i tried to go back to the original SW, but it somehow didnt worked out. then i was so pissed and installed the initframs factory image by Robimarko and then the router stopped working.
I opened the router and connected to the serial pins, to see whats going on, which gave me the following output:

▒[    2.809672] Waiting for root device /dev/ubiblock0_0...

Can someone please tell me, what i need to do in order to either boot up normally or restore to factory SW?


I updated three AX3600 from 2013_01_06 (first with expanded partition) to 2013_01_13 without any issues or soft-bricking. I manually updated /lib/upgrade/ to the latest version in the repo before running sysupgrade - just to be safe.

1 Like


I just got AX3600, installed latest snapshot and configured it as dumb AP. It has been running overnight and I have been doing extensive LAN testing on 802.11ax 80Mhz. No routing, just basic iperf3 from WiFi to wired Linux. It is behaving fine...800-ish Mbit/sec both ways with one core at 80% and other three around 6%. No memory leaks.

I also noticed that perceived "range" is subjectively better than with Archer C7 with same channel/width/power but running 802.11ac. So double the bandwidth, and subjectively better range! :+1: I use x86 for routing but I am quite sure this FW is at least ready for AP-duty.

P.S. HTTP to HTTPS GUI switch is not working in Luci, had to configure it manually in SSH. Also, 5GHz did not work before removing it and adding it again. Other than that, smooth sailing.

How can I install Zerotier or OpenVPN on AX3600 if in repository there is no :
libstdcpp6 and kmod-tun or from where I can downlonad it ?
I am using "OpenWrt SNAPSHOT r0-8faba05 / LuCI Master git-22.361.69865-deed682"